Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

L2TPv3 tunnel

I have to configure L2TPv3 tunnel between two ends on 2921 routers. 

Can anybody tell me while configuring xconnect interface the following config will work or not?

R1
pseudowire-class test
encapsulation l2tpv3
ip local interface f0/0
!
!
interface f0/0
ip address 1.1.1.1 255.255.255.252
!

interface FastEthernet0/1
xconnect 2.2.2.2 1 encapsulation l2tpv3 pw-class test
!

R3
pseudowire-class test
encapsulation l2tpv3
ip local interface f0/0
!
!
interface f0/0
ip address 2.2.2.2 255.255.255.252
!
!
interface FastEthernet0/1.1
encapsulation dot1Q 5
xconnect 1.1.1.1 1 encapsulation l2tpv3 pw-class test
!
 

As i have done this config the tunnel is down. When i define xconnect on R3 on the physical interface instead of sub-interface it becomes up.

Is there any prerequisite that we require physical interfaces for xconnect on both end or same encapsulation defined in the subinterface on both ends?

 

Regards,
Mukesh Kumar
Network Engineer
Spooster IT Services

 

  • Metro
1 REPLY
Cisco Employee

Mukesh,The only problem I can

Mukesh,

The only problem I can see is that you have VLAN 5 on the subinterface, but not on the main interface, this means that the traffic might not get to the other end due to the Dot1q encapsulation. If you were to set both to the same dot1q tag it should come up.

Regards,

Alex Sanchez

CCIE R&S #37454

86
Views
0
Helpful
1
Replies