Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

ME3400 Bandwidth Limiting

Trying to limit bandwidth on VLANS with my ME3400. 

I need to have VLAN 602 rate limited to 10mb upload/download, VLAN 361 rate limited to 100mb up/down.  I have a Gig trunk port on 0/4 to a 7609 router(service provider) and do not want the customer to have all this bandwidth at their disposal.

interface GigabitEthernet0/4

description UPLINK

port-type nni

switchport trunk allowed vlan 361,602

switchport mode trunk

end

interface GigabitEthernet0/1

description 10MB Inet

switchport access vlan 602

interface GigabitEthernet0/2

description 100MB TLS

switchport access vlan 361

I've tried different policy maps, but can only get one side to be limited.  I'm pretty new at this, so any help would be greatly appreciated.  I'm pretty confused by the different how to's on the cisco site, and i've been surfing around the CSC.  If someone can give me some insight that would be great.

8 REPLIES
Community Member

ME3400 Bandwidth Limiting

Hi Rob,

ME3400 will not allow you to configure policy on both i.e. input and output.

You can limit the traffic of vlan602 by applying the input only policy on downlink & uplink ports i.e. Gi0/1 & Gi0/4 resp.

Please refer below config for that:

policy-map test-10M

  class class-default

   police cir 10000000

     conform-action transmit

     exceed-action drop

class-map match-all vlan_602

  match vlan 602

policy-map Uplink_policy_test

  class vlan_602

   service-policy test-10M

interface GigabitEthernet0/1

service-policy input test-10M

interface GigabitEthernet0/4

service-policy input Uplink_policy_test

Regards

Pradip

Community Member

ME3400 Bandwidth Limiting

Pradip -

When I get to

class-map match-all vlan_602

match vlan 602

The switch doesn't let me match on "vlan". I only have

access-group

cos

ip

qos-group

Software release?  Or not possible?

Thanks,

Rob

Community Member

ME3400 Bandwidth Limiting

Please tell me the version of your switch.

- Pradip

Community Member

ME3400 Bandwidth Limiting

Pradip -

Cisco IOS Software, ME340x Software (ME340x-METROBASE-M), Version 12.2(52)SE, RELEASE SOFTWARE (fc3)

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Fri 25-Sep-09 05:33 by sasyamal

Image text-base: 0x01000000, data-base: 0x02100000

ROM: Bootstrap program is ME340x boot loader
BOOTLDR: ME340x Boot Loader (ME340x-HBOOT-M) Version 12.2(35r)SE3, RELEASE SOFTWARE (fc1)

WCA_3400 uptime is 0 minutes
System returned to ROM by power-on
System image file is "flash:me340x-metrobase-mz.122-52.SE/me340x-metrobase-mz.122-52.SE.bin"

cisco ME-3400G-2CS-A (PowerPC405) processor (revision F0) with 131072K bytes of memory.
Processor board ID FOC1512W5HY
Last reset from power-on
2 Virtual Ethernet interfaces
4 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : E8:40:40:C7:D9:80
Motherboard assembly number     : 73-10724-07
Power supply part number        : 341-0208-02
Motherboard serial number       : FOC15121R35
Power supply serial number      : LIT150601QW
Model revision number           : F0
Motherboard revision number     : A0
Model number                    : ME-3400G-2CS-A
Daughterboard assembly number   : 73-10798-03
Daughterboard serial number     : FOC15113YQR
System serial number            : FOC1512W5HY
Top Assembly Part Number        : 800-28134-03
Top Assembly Revision Number    : D0
Version ID                      : V03
CLEI Code Number                : COM9Z10ARB
Daughterboard revision number   : A0
Hardware Board Revision Number  : 0x01


Switch Ports Model              SW Version            SW Image
------ ----- -----              ----------            ----------
*    1 4     ME-3400G-2CS-A     12.2(52)SE            ME340x-METROBASE-M

Community Member

ME3400 Bandwidth Limiting

Hi Rob,

Here problem is your "Metrobase" IOS image. You have to upgrade switch IOS to "metro IP access or metro access image"

Please refer below snippet from one of the cisco document.

*****

Classification Based on VLAN IDs

With classification based on VLAN IDs, you can apply QoS policies to frames carried on a user-specified VLAN for a given interface. You can use hierarchical policy maps for per-VLAN classification on trunk ports if the switch is running the metro IP access or metro access image. Per-VLAN classification is not required on access ports because access ports carry traffic for a single VLAN. If you try to attach an input per-port, per VLAN hierarchical policy to a port that is not a trunk port, the configuration is rejected.

The switch supports two policy levels: a parent level and a child level. With the QoS parent-child structure, you can reference a child policy in a parent policy to provide additional control of a specific traffic type. For per-port, per-VLAN QoS, the parent-level class map specifies only the VLAN match criteria, and the child-level class maps provide more detailed classification for frames matching the parent-level class map.You can configure multiple service classes at the parent level to match different combinations of VLANs, and you can apply independent QoS policies to each parent service class using any child policy map.

*****

Regards

Pradip

Community Member

ME3400 Bandwidth Limiting

I'm also not able to control bandwidth in uplink

Switch Ports Model              SW Version            SW Image                

------ ----- -----              ----------            ----------              

*    1 26    ME-3400-24FS-A     12.2(55)SE4           ME340x-METROIPACCESSK9-M

Community Member

ME3400 Bandwidth Limiting

May I know the error please ?

Community Member

ME3400 Bandwidth Limiting

Sorry was a configuration error. My problem is to control the output and input vlan in client interface. Why on uplink I have only one vlan with BGP configuration.

4702
Views
0
Helpful
8
Replies
CreatePlease to create content