Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Not able to add vlans (svi) on a 6500

Hello all,

I am having an issue while trying to create a VLAN/SVI interface on my 6500 Metro Ethernet Aggregator.

I am receiving an error message that I cannot create an SVI without having the vlan added on the L2 vlan database, but the issue is that the vlan is already created there:

1. I created the vlan on the database:

CAT_6k_MT#conf t

Enter configuration commands, one per line. End with CNTL/Z.

CAT_6k_MT(config)#vlan 1241

CAT_6k_MT(config-vlan)#name test

CAT_6k_MT(config-vlan)#exit

% Applying VLAN changes may take few minutes. Please wait...

2. Trying to add the SVI interface for that vlan

CAT_6k_MT(config)#int vlan 1241

CAT_6k_MT(config-if)#no shut

CAT_6k_MT(config-if)#

Oct 14 10:11:04.241 CST: %PM-4-SVI_ADD_CORRESPONDING_L2_VLAN: Vlan 1241 must be added to L2 database in order to be used, do <vlan 1241> from config mode.

Oct 14 10:11:04.257 CST: %LINK-3-UPDOWN: Interface Vlan1241, changed state to down

Then I checked the vlan 1241 is created on the database:

CAT_6k_MT#sh vlan id 1241

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1241 VLAN1241 active Po11, Po61

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1241 enet 101241 1500 - - - - - 0 0

Remote SPAN VLAN

----------------

Disabled

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

CAT_6k_MT#sh run int vlan 1241

Building configuration...

Current configuration : 41 bytes

!

interface Vlan1241

no ip address

end

But when I look at the interface vlan is always down/down:

CAT_6k_MT(config-if)#do sh int vlan 1241

Vlan1241 is down, line protocol is down

Hardware is EtherSVI, address is 0016.9c7b.d7c0 (bia 0016.9c7b.d7c0)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not supported

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Any ideas reagrding this?

Thanks for your help!

Alex

4 REPLIES
Community Member

Re: Not able to add vlans (svi) on a 6500

Are your ports Po11, and Po61 active and passing traffic already?  Do you have any other physical interfaces assigned to that vlan?  I think I've seen cases in the past where someone has had similar issues due to none of the physical interfaces in the vlan being active.  So, for example, if there aren't any active ports in vlan 1241 then there's no need for interface vlan1241 to become up/up.

Re: Not able to add vlans (svi) on a 6500

Hello all,

I am having an issue while trying to create a VLAN/SVI interface on my 6500 Metro Ethernet Aggregator.

I am receiving an error message that I cannot create an SVI without having the vlan added on the L2 vlan database, but the issue is that the vlan is already created there:

1. I created the vlan on the database:

CAT_6k_MT#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

CAT_6k_MT(config)#vlan 1241

CAT_6k_MT(config-vlan)#name test

CAT_6k_MT(config-vlan)#exit

% Applying VLAN changes may take few minutes.  Please wait...

2. Trying to add the SVI interface for that vlan

CAT_6k_MT(config)#int vlan 1241

CAT_6k_MT(config-if)#no shut

CAT_6k_MT(config-if)#

Oct 14 10:11:04.241 CST: %PM-4-SVI_ADD_CORRESPONDING_L2_VLAN: Vlan 1241 must be added to L2 database in order to be used, do from config mode.

Oct 14 10:11:04.257 CST: %LINK-3-UPDOWN: Interface Vlan1241, changed state to down

Then I checked the vlan 1241 is created on the database:

CAT_6k_MT#sh vlan id 1241

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1241 VLAN1241                         active    Po11, Po61

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1241 enet  101241     1500  -      -      -        -    -        0      0  

Remote SPAN VLAN

----------------

Disabled

Primary Secondary Type              Ports

------- --------- ----------------- ------------------------------------------

CAT_6k_MT#sh run int vlan 1241

Building configuration...

Current configuration : 41 bytes

!

interface Vlan1241

no ip address

end

But when I look at the interface vlan is always down/down:

CAT_6k_MT(config-if)#do sh int vlan 1241

Vlan1241 is down, line protocol is down

  Hardware is EtherSVI, address is 0016.9c7b.d7c0 (bia 0016.9c7b.d7c0)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not supported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

Any ideas reagrding this?

Thanks for your help!

Alex

Alex,

Ensure that you have assigned the switch port(s) to VLAN on the switch  side. Also ensure that at least one VLAN port on the switch is connected to the switch or the workstation, and is active.

HTH

Ganesh.H

Community Member

Re: Not able to add vlans (svi) on a 6500

Hello,

This issue has been resolved, the issue here was a corrupted database, I needed to reload the box and after that everything works fine.

Regards!

Alex

Re: Not able to add vlans (svi) on a 6500

Hello,

This issue has been resolved, the issue here was a corrupted database, I needed to reload the box and after that everything works fine.

Regards!

Alex

Alex,

Great your issue has been resloved and even come to know that it was due to corrupted database.

Ganesh.H

3003
Views
0
Helpful
4
Replies
CreatePlease to create content