cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6113
Views
0
Helpful
4
Replies

Per VLAN traffic shaping on ME3400

4mellis
Level 1
Level 1

Customer side Metro 3400 switch:

Port is 100Mb, Vlan 80 is 80MbCIR, Vlan81 is 10MbCIR

want to shape each vlan down to CIR

what is best configuration to do this? Here is what I tried...

class-map match-all vlan81

match vlan 81

class-map match-all vlan80

match vlan 80

!

!

policy-map ATTCIR

class vlan80

bandwidth 80000

class vlan81

bandwidth 10000

policy-map out-policy

class class-default

shape average 90000000

service-policy ATTCIR

!

IMC-OPTEMAN(config)#int gig0/1

IMC-OPTEMAN(config-if)#service-policy out

IMC-OPTEMAN(config-if)#service-policy output out-policy

QoS: Configuration failed. Match VLAN filter is not allowed in classmap of outpu

t policymap

IMC-OPTEMAN(config-if)#

I also try using access-lists and get the following:

access-list 180 permit ip any 192.168.128.0 0.0.0.255

access-list 181 permit ip any 192.168.100.0 0.0.0.255

class-map match-all vlan81

match access-group 181

class-map match-all vlan80

match access-group 180

!

!

policy-map ATTCIR

class vlan80

bandwidth 80000

class vlan81

bandwidth 10000

policy-map out-policy

class class-default

shape average 90000000

service-policy ATTCIR

!

IMC-OPTEMAN(config-if)#service-policy output out-policy

Configuration Failed. Can not have ACL based classification in a class-map withi

n an output policy-map

1 Accepted Solution

Accepted Solutions

This is a limitation of the 3400 Metro egress shaping granularity, which quite frankly is crap. You cannot shape to 80Mbps.

See this document:

http://www.cisco.com/web/DK/assets/docs/sp_me3400_IPTV.pdf

View solution in original post

4 Replies 4

swaroop.potdar
Level 7
Level 7

Please proceed as below, replacing the below sample with actual vlan data. Also you cannot use shaping and bandwidth/priority statement in the same policy map. So when you apply the output policy please remove the shape average from class default.

Do give a feedback how it goes.

Switch(config)# class-map in-class1

Switch(config-cmap)# match access-group 181

Switch(config-cmap)# exit

Switch(config)# policy-map in-policy

Switch(config-pmap)# class in-class1

Switch(config-pmap-c)# set qos-group 1

Switch(config-cmap-c)# exit

Switch(config)# class-map out-class1

Switch(config-cmap)# match qos-group 1

Switch(config-cmap)# exit

Switch(config)# policy-map out-policy

Switch(config-pmap)# class out-class1

Switch(config-pmap)# bandwidth

HTH-Cheers,

Swaroop

thank you!

Your advice worked perfectly for marking the input traffic. Now I am unable to shape the output traffic the way I want. Since this is 100Mb FastEthernet interface the error message is that I can only shape to 50000000

here is config I want, and the 10000000 shaping works but ME3400 will not accept

80000000 class-based shaping on a FastEthernet interface

class-map match-all vlan81class

match vlan 81

class-map match-all vlan81out

match qos-group 81

!

class-map match-all vlan80class

match vlan 80

class-map match-all vlan80out

match qos-group 80

!

!

!

policy-map vlan80group

class class-default

set qos-group 80

policy-map vlan81group

class class-default

set qos-group 81

!

policy-map inputgroup

class vlan80class

service-policy vlan80group

class vlan81class

service-policy vlan81group

!

policy-map ATTOPT

class vlan81out

shape average 10000000

class vlan80out

shape average 80000000

!

You should be able to shape till the port speed (which is 100MB), have you assigned a lower bandwidth or speed on the interface.

HTH-Cheers,

Swaroop

This is a limitation of the 3400 Metro egress shaping granularity, which quite frankly is crap. You cannot shape to 80Mbps.

See this document:

http://www.cisco.com/web/DK/assets/docs/sp_me3400_IPTV.pdf