Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

policing output side

We have been using the 'shape average' command for our traffic shaping on our output side for the bandwidth we sell to customers. It seems that this might not be the best way to traffic shape a rate (like 15meg) to a customer.

After doing much research, I have changed the 'shape average' to 'bandwidth'. After doing so, the traffic shot right up to the max limit on the output side.

My question is, what is the best way from a SP to shape outbound traffic to a customer? Here is what we had before:

policy-map POLICYOUTPUT

description Customer Access Port Policy (Output)

class class-default

shape average 15789488

policy-map POLICYINPUT

description Customer Access Port Policy (Input)

class CLASSMAPALLTRAFFIC

police cir 15789488

interface FastEthernet0/1

switchport access vlan 202

speed 100

duplex full

service-policy input POLICYINPUT

service-policy output POLICYOUTPUT

Here is what it is set to now:

policy-map POLICYOUTPUT-TEST

class class-default

bandwidth 15360

policy-map POLICYINPUT

description Customer Access Port Policy (Input)

class CLASSMAPALLTRAFFIC

police cir 15789488

interface FastEthernet0/1

switchport access vlan 202

speed 100

duplex full

service-policy input POLICYINPUT

service-policy output POLICYOUTPUT-TEST

Thanks!

5 REPLIES
New Member

Re: policing output side

Hello sjamison76.

We use ME3400 as U-PE for MPLS services.

When we sell sub-rate bandwidth of a port-speed we apply "shape average" as Port-Shaping on output direction.

On input direction we use an aggregate or individual policer.

Important: the CE router must be configured for port-based shaping in the direction of MPLS services.

The system is working and our customers are satisfied.

New Member

Re: policing output side

We do shape average too, but ive noticed two customers who have never been able to hit their top bandwidth mark for some reason. By changing this policy to use just 'bandwidth' they have pegged quite a few times now.

Im just curious what this bandwidth command does, and what the best way to do this would be. And why the shape 'average' seems to not give them the bandwidth they are supposed to be getting.

its just strange...

New Member

Re: policing output side

For ME3400 I know the bandwidth command means "minimum band guarantee" for that Class-map.

Shape average is referred to "maximum band" for a Class-map.

Look at:

http://www.cisco.com/en/US/products/ps6580/products_configuration_guide_chapter09186a008087831b.html

New Member

Re: policing output side

Thanks for the doc, that definately explains things a lot better than the previos doc I had.

Taking a look at the traffic patterns of the customer yesterday he had hit his max limit for about 15 minutes yesterday and kept it pegged since using the bandwidth command and did not go over the limit.

Im more curious now as to when you would want to use the 'shape average' or 'bandwidth' command. If there is precedent over one or the other in different situations. Just seems strange to have two commands that seem to do the same thing.

Thanks for your help pbenin, I appreciate it!

New Member

Re: policing output side

Here is a configuration where the customer buys 50Mbps of total bandwidth, min 10Mbps Class_1 (burstable to 50Mbps) and min 20Mbps Class_2 (burstable to 50Mbps).

class-map match-any CLASS_1

match ip dscp cs1

class-map match-any CLASS_2

match ip dscp cs2

class-map match-any CLASS_3

match ip dscp cs3

policy-map PORT-SHAPING

class class-default

shape average 50000000

service-policy CBPQ

policy-map CBPQ

class CLASS_1

police cir 64000

priority

class CLASS_2

bandwidth 10000

class CLASS_3

bandwidth 20000

interface FastEthernet0/1

speed 100

service-policy output PORT-SHAPING

281
Views
0
Helpful
5
Replies
CreatePlease to create content