Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

PPPoE on ASR920 not working

Hi.

I configured a pppoe server on a brand new asr 920 plateform (advanced metro ip access) but it's not working.

My set up is trivial :

Add a bba-group and a virtual template :

bba-group pppoe BBAPPPOE
virtual-template 1
sessions per-mac limit 2
interface Virtual-Template1
ip unnumbered Loopback0
no peer default ip address
ppp authentication pap CPE_USER

Then, configure the Radius :

aaa group server radius<removed>
server<removed> auth-port 1812 acct-port 1813
ip radius source-interface Loopback0
!
aaa authentication ppp CPE_USER group <removed>
aaa authorization network default group removed>
radius-server host<removed> auth-port 1812 acct-port 1813 key 7 <removed>

Finally, I configured an interface accepting pppoe :

interface GigabitEthernet0/0/4
description TEST-PPPOE
no ip address
media-type rj45
negotiation auto
pppoe enable group BBAPPPOE

A router, plugged on the interface Gi 0/0/4, is sending pado packets but ASR920 is not seeing these packets :

Counters does not increment, debug says nothing.

ASR920-ALE-1#sh pppoe statistics 

But I can see input packets with 

ASR920-ALE-1# sh interfaces Gi 0/0/4

Has anyone have experience with  pppoe server on a ASR920 ?

Thanks a lot :)

Nicolas.

14 REPLIES
VIP Purple

I think it should work.

I think it should work.  Tried a different software version on the 920?

The release notes indicate PPPoE support from 3.15.0S onwards.

http://www.cisco.com/c/en/us/td/docs/routers/asr920/release/notes/ASR920_rel_notes/new_features.html

New Member

I did.

I did.

asr920-universalk9_npe.03.15.02.S.155-2.S2-std.bin
asr920-universalk9_npe.03.17.00.S.156-1.S-std.bin
asr920-universalk9_npe.03.16.01a.S.155-3.S1a-ext.bin

But does not help :/

Thanks for your help.

New Member

I've the same problem in

I've the same problem in asr900.

I use the image asr900rsp2-universalk9_npe.03.17.00.S.156-1.S-std.bin

I can partially solve it with the following configuration:

interface GigabitEthernet0/3/1
 description To Clients
 no ip address
 negotiation auto
 service instance 19 ethernet 19
  encapsulation untagged
  bridge-domain 19
 !        
!

And finally create pppoe server in the bdi interface:

interface BDI19
 pppoe enable group global
!

In my router pppoe-clients connects normally but I can reach any external address. I can ping only the assigned cisco ip address :(

The router is not forwarding public adress from pppoe clients :(

VIP Purple

It doesn't need the global

It doesn't need the global "ip routing" command added does it?

New Member

No. ip routing command apply

No. ip routing command apply "only" for switches.

Reachability is ok if I set a public ip address directly on the client interface (without use pppoe protocol).

New Member

I have a case open with TAC

I have a case open with TAC right now on the same issue. They are directed me to this http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/bbdsl/configuration/xe-3s/asr1000/bba-xe-3s-asr1000-book/bba-ppoe-enet-xe.html  except a few of the command don't seem to exist on the ASR920 and it still doesn't work.

I have had the case open since 3/17, but I will update this with any resolution that comes forth.

Highlighted
New Member

Hi @Natambu Obleton

Hi @Natambu Obleton

Did you get this fixed, am I now having the exact same issue?

New Member

If you guys didn't see my

If you guys didn't see my notes above, PPPoE server is not officially supported for the ASR920 (even though it mostly works). Only PPPoE as a client and PPPoE IA.

New Member

@Sysadmin - did you get this

@Sysadmin - did you get this resolved in the end? I am having the same exact problem, the ASR920 isn't seeing any PADI packets coming in (all PPP and PPPoE debug options are enabled but it doesn't seem to be doing anything), CPE is directly connected as this is in the lab and I can see the PADI's leaving the CPE.

I have the same config as you but as per @thsinformatica I am using a service instance with "encapsulation untagged" and PPPoE is enabled on the BDI.

I am running IOS-XE 3.16.4aS.

New Member

OK, so I was being an idiot

OK, so I was being an idiot and the ASR hadn't booted 3.16.4aS. but 3.16.0 image, after rebooting to 3.16.4aS this works fine for PPPoE sessions. I am aiming for Multilink PPP though and that isn't working.

New Member

Hi, can you elaborate on the

Hi, can you elaborate on the PPPoE functionality that is working on the ASR920 in your setup? Is the ASR920 functioning as a terminating PPPoE server? Are you sure that the session throughput is handled in hardware and not in a very limited CPU? Also what is the exact hardware model you use?

thanks!

New Member

Multilink PPP was not working

Multilink PPP was not working for me. I opened a TAC case and they have confirmed that MLPPP is not supported on the ASR920. In the IOS-XE release notes for the ASR920 it states that PPPoE is support (but this is supposed to mean as a client not server) and PPPoE IA is also support, just not PPPoE server. Having said that that vanilla PPPoE does work, I could use the config I have put below and a CPE could bring up a single PPPoE session just fine, with MLPPP the Multilink session would come up but the route to the CPE is was not being installed.

Debugs from the ASR920 acting as the PE/PPPoE MLPPP server:

*Nov 25 2016 10:28:50.829 GMT: Vi3 IPCP: Protocol configured, start CP. state[Initial]
*Nov 25 2016 10:28:50.829 GMT: Vi3 IPCP: Event[OPEN] State[Initial to Starting]
*Nov 25 2016 10:28:50.829 GMT: Vi3 IPCP: O CONFREQ [Starting] id 1 len 10
*Nov 25 2016 10:28:50.829 GMT: Vi3 IPCP:    Address 192.168.50.1 (0x0306C0A83201)
*Nov 25 2016 10:28:50.829 GMT: Vi3 IPCP: Event[UP] State[Starting to REQsent]
*Nov 25 2016 10:28:50.829 GMT: Vi5 PPP: Process pending ncp packets
*Nov 25 2016 10:28:50.829 GMT: Vi5 IPCP: Redirect packet to Vi3
*Nov 25 2016 10:28:50.829 GMT: Vi3 IPCP: I CONFREQ [REQsent] id 1 len 10
*Nov 25 2016 10:28:50.829 GMT: Vi3 IPCP:    Address 192.168.50.5 (0x0306C0A83205)
*Nov 25 2016 10:28:50.830 GMT: Vi3 IPCP: O CONFACK [REQsent] id 1 len 10
*Nov 25 2016 10:28:50.830 GMT: Vi3 IPCP:    Address 192.168.50.5 (0x0306C0A83205)
*Nov 25 2016 10:28:50.830 GMT: Vi3 IPCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
*Nov 25 2016 10:28:50.832 GMT: Vi3 IPCP: I CONFACK [ACKsent] id 1 len 10
*Nov 25 2016 10:28:50.832 GMT: Vi3 IPCP:    Address 192.168.50.1 (0x0306C0A83201)
*Nov 25 2016 10:28:50.832 GMT: Vi3 IPCP: Event[Receive ConfAck] State[ACKsent to Open]
*Nov 25 2016 10:28:50.856 GMT: Vi3 IPCP: State is Open
*Nov 25 2016 10:28:50.858 GMT: Vi3 Added to neighbor route AVL tree: topoid 0, address 192.168.50.5
*Nov 25 2016 10:28:50.858 GMT: Vi3 IPCP: Route not installed to 192.168.50.5

Putting the same config works fine on an ASR1K, MLPPPoE is working as expected. Again this was using IOS-XE 3.16.4aS.

aaa new-model

aaa authentication ppp default local

aaa authorization network default local

aaa policy interface-config allow-subinterface

username test-cpe privilege 15 password 0 test-cpe

! Not sure why this has to be priv level 15, just running this in the lab so haven't had time to sort that out yet...

bba-group pppoe global
 virtual-template 1
!
interface Loopback50
 ip address 192.168.50.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
!
interface GigabitEthernet0/0/0
 description 1941-Gi0/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 negotiation auto
 pppoe enable group global
!
interface GigabitEthernet0/0/1
 description 1941-Gi0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 negotiation auto
 pppoe enable group global
!
interface Virtual-Template1
 mtu 1492
 bandwidth 40000
 bandwidth receive 10000
 ip unnumbered Loopback50
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no logging event link-status
 no peer default ip address
 no snmp trap link-status
 no keepalive
 ppp authentication chap callin
 ppp multilink
!

The 1941 CPE is simply:

interface GigabitEthernet0/0
 description ASR1K-Gi0/0/0
 bandwidth 10000
 bandwidth receive 40000
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface GigabitEthernet0/1
 description ASR1K-Gi0/0/1
 mtu 1492
 bandwidth 10000
 bandwidth receive 40000
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface Dialer0
 mtu 1492
 bandwidth 20000
 bandwidth receive 80000
 ip address 192.168.50.5 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 load-interval 30
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname test-cpe
 ppp chap password 0 test-cpe
 ppp multilink
 no cdp enable

New Member

Thanks for your insights. I

Thanks for your insights. I had some succes with a fully terminating PPPoE server running on 920-12CZ as well. 

However: when doing a performance test it was limited to a couple of Mb/s, matching the throughput of the CPU. 

That's the reason why I'm curious to your throughput and model number?

New Member

Sadly I didn't run any

Sadly I didn't run any performance testing, I really needed MLPPPoE working so the fact that it isn't supported means that we moved on to the ASR1001.

559
Views
0
Helpful
14
Replies
CreatePlease login to create content