Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Problem with QinQ / same mac address on different inner vlans

We have a QinQ tunnel configured between two 7609.

The tunnel is used to connect two L2 switches (one 6509 and a 3750).

The problem that we have is with different inner vlans (vlan 501 and vlan 621) with same mac-addresses.

The moment we enable both vlans on the trunk, applications cease to operate.

I know from experience this shuld work fine in a pure L2 topology as long as every switch has a per-vlan-mac-address table.

But when it comes to QinQ Im not sure.

Any help or comment would be greatly appreciated.

Hardware description:

CISCO7609

WS-SUP720-3BXL

WS-X6748-SFP

Software description:

IOS s72033_rp-ADVIPSERVICESK9_WAN-M), Version 12.2(18)SXF8

Topology is the following

SW3750 = dot1q trunk = switchport mode dot1q-tunnel =7609 =vlan73= 7609= switchport mode dot1q-tunnel = dot1q trunk = 6509

7609 Configuration of QinQ Ports

interface GigabitEthernet1/5

description ##To 6509 ##

switchport

switchport access vlan 73

switchport mode dot1q-tunnel

mtu 9216

no ip address

logging event link-status

load-interval 30

l2protocol-tunnel cdp

l2protocol-tunnel stp

l2protocol-tunnel vtp

no cdp enable

spanning-tree portfast

spanning-tree bpdufilter enable

end

!

interface GigabitEthernet2/11

description ##To 3750 ##

switchport

switchport access vlan 73

switchport mode dot1q-tunnel

mtu 9216

no ip address

logging event link-status

load-interval 30

l2protocol-tunnel cdp

l2protocol-tunnel stp

l2protocol-tunnel vtp

no cdp enable

spanning-tree portfast

spanning-tree bpdufilter enable

end

2 REPLIES
Silver

Re: Problem with QinQ / same mac address on different inner vlan

Here is the URL for the configuaration for the QinQ VLAN.

http://www.cisco.com/en/US/docs/ios/12_2sb/feature/guide/sbseslt2.html

New Member

Re: Problem with QinQ / same mac address on different inner vlan

Thanks for your response but this is not the PPOE case.

Thank you anyway !

1039
Views
0
Helpful
2
Replies