Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Q-in-Q Vlan re-mapping on Metro 6524

Hi

does anybody experienced problems in vlan remapping on Metro 6524 ?

This is my machine

sh ver

Cisco Internetwork Operating System Software

IOS (tm) s6523_rp Software (s6523_rp-ADVIPSERVICESK9-M), Version 12.2(18)ZU2, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by cisco Systems, Inc.

Compiled Tue 30-Jan-07 03:51 by alnguyen

Image text-base: 0x40101040, data-base: 0x42D50000

ROM: System Bootstrap, Version 12.2(17r)SX3, RELEASE SOFTWARE (fc1)

BOOTLDR: s6523_rp Software (s6523_rp-ADVIPSERVICESK9-M), Version 12.2(18)ZU2, RELEASE SOFTWARE (fc2)

TSIswec0d uptime is 17 weeks, 6 days, 4 hours, 23 minutes

Time since TSIswec0d switched to active is 17 weeks, 6 days, 4 hours, 21 minutes

System returned to ROM by power-on (SP by power-on)

System image file is "sup-bootflash:s6523-advipservicesk9-mz.122-18.ZU2.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco ME-C6524GS-8S (R7000) processor (revision 1.3) with 458752K/65536K bytes of memory.

Processor board ID CAT1209C01F

R7000 CPU at 300Mhz, Implementation 0x27, Rev 3.3, 256KB L2, 1024KB L3 Cache

Last reset from power-on

SuperLAT software (copyright 1990 by Meridian Technology Corp).

X.25 software, Version 3.0.0.

Bridging software.

TN3270 Emulation software.

1 Virtual Ethernet/IEEE 802.3 interface

32 Gigabit Ethernet/IEEE 802.3 interfaces

1915K bytes of non-volatile configuration memory.

65536K bytes of Flash internal SIMM (Sector size 256K).

Configuration register is 0x2102

I try to explain my net config.

Basically I've a Huawei provider switch passing me the outer vlan as 726 on g1/31, my Juniper router is config on g1/25 with outer vlan 200 and inner 16 and 20.

Metro Ethernet

interface GigabitEthernet1/25

description towards router

switchport

switchport mode dot1q-tunnel

switchport vlan mapping enable

switchport vlan mapping 200 726

no ip address

no cdp enable

spanning-tree bpdufilter enable

!

!

interface GigabitEthernet1/31

description towards PROVIDER

switchport

switchport mode dot1q-tunnel

switchport vlan mapping enable

switchport vlan mapping 726 200

no ip address

no cdp enable

spanning-tree bpdufilter enable

Juniper

> show configuration interfaces ge-7/1/3

flexible-vlan-tagging;

mtu 1518;

unit 16 {

vlan-tags outer 200 inner 16;

family inet {

address 10.10.16.2/30;

}

}

unit 20 {

vlan-tags outer 200 inner 20;

family inet {

address 10.10.20.2/30;

}

}

Metro Ethernet should remap outer vlan incoming on g1/31 from 723 to 200 and on g1/25 from 200 to 723...

I'm pretty sure the Juniper firewall is config well, I'm not sure the Metro Ethernet is doing what expected.

Pls let me know if you have an idea.

Tks

Ric

6 REPLIES
New Member

Re: Q-in-Q Vlan re-mapping on Metro 6524

AFAIK, if you specify outer vlan on the Juniper side you should configure the port in the Cisco as a regular 802.1q trunk and allow that particular outer vlan.

On the other side, if you configure the Cisco with the "dot1q-tunnel" statement, you should define "switchport access vlan XXX" with your QinQ "transport" vlan. But in that case, the Juniper should not define an outer vlan (unless you are planning to do some sort of HVPLS).

HTH,

-W

New Member

Re: Q-in-Q Vlan re-mapping on Metro 6524

Hi

as far as I understand you are talking of putting a 3rd outer vlan at the provider interconnection, I'd like to swap the 2nd outer vlan at the interconnection, from 726 to 200..

Tks

Ric

Re: Q-in-Q Vlan re-mapping on Metro 6524

HI RIC,

Can you please help me with the exact Q-in-Q Configuation on Juniper Routers.

Kindly share if any useful documents available. Thanks in Advance for Help.

Best Regards,

Guru Prasad R

New Member

Re: Q-in-Q Vlan re-mapping on Metro 6524

Hi Guru

what do you exaclty need ?

In the juniper.net site you can easily find the documentation depending on your junos release.

Greetings,

Riccardo

Re: Q-in-Q Vlan re-mapping on Metro 6524

HI Riccardo,

Thanks for your response.

I am looking for a exact/good documentation on Juniper Routers J - Series.

Also, if you have a good Document on Q-in-Q deployments, please forward the same too.

Regards,

Guru Prasad R

New Member

Re: Q-in-Q Vlan re-mapping on Metro 6524

I never had a J series in my hands and I'm not sure that serie support vlan stacking and rewriting.

See on M series junos9.1 (pag 455):

http://www.juniper.net/techpubs/software/junos/junos91/swconfig-network-interfaces/swconfig-network-interfaces.pdf

Greetings

Riccardo

828
Views
0
Helpful
6
Replies