Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QinQ - VLAN injection

Hello,

we need to inject some traffic to QinQ tunnel carrying customers' traffic. I haven't found any paper describing this situation, so I was thinking about how to do it:

- customer has SP VLAN ID 100, encapsulation dot1q on SP backbone.

- when I configure some aceess port with VLAN 100, it will be member of customers' native VLAN

- when I do "cable loopback" between two interfaces of SP box like this, I'll be able to inject VLAN 200 and 300 to customers' QinQ tunnel:

interface FastEthernet0/23

switchport access vlan 100

switchport mode dot1q-tunnel

switchport nonegotiate

no cdp enable

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 200,300

switchport mode trunk

switchport nonegotiate

no cdp enable

I'm not sore about correctness of approach. Is there any other way how to do it?

Thanks for comment. Honza Klicka

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: QinQ - VLAN injection

3 REPLIES
Silver

Re: QinQ - VLAN injection

New Member

Re: QinQ - VLAN injection

Hello,

that's exactly, what I meant. The only problem is, that I need this kind of features on Cat 3750 or 6506.

Thank you

Honza Klicka

Hall of Fame Super Silver

Re: QinQ - VLAN injection

379
Views
0
Helpful
3
Replies
CreatePlease to create content