Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

10a versus 10b - how to configure it??

I've done all my reading, and I understand the difference between the two, but am at a loss to determine how to actually configure it?? We're using 7206VXR and 10K routers in the 12.2 Ent for both.

I know that RFC 2547bis was superceded by RFC 4364, and 4364 is where I found the desctiptions of this function.

Thanks, Jeff

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: 10a versus 10b - how to configure it??

Option 10a is nothing more than back to back VRF interfaces from one PE in one AS to another PE in another AS.

It could be a dedicated interface per VRF or one interface divided into many subinterface that could be shared between all VRF needing interAS capability.

Configuration should look something like this.

ASBR in AS1:

ip vrf one

rd 1:1

route-target both 1:1

int fa0/0.1

ip vrf forwarding one

ip address 192.168.1.1

router bgp 1

address-family ipv4 vrf red

neighbor 192.168.1.2 remote-as 2

ASBR in AS2:

ip vrf one

rd 2:1

route-target both 2:1

int fa0/0.1

ip vrf forwarding one

ip address 192.168.1.2

router bgp 2

address-family ipv4 vrf red

neighbor 192.168.1.1 remote-as 1

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
6 REPLIES
Cisco Employee

Re: 10a versus 10b - how to configure it??

Option 10a is nothing more than back to back VRF interfaces from one PE in one AS to another PE in another AS.

It could be a dedicated interface per VRF or one interface divided into many subinterface that could be shared between all VRF needing interAS capability.

Configuration should look something like this.

ASBR in AS1:

ip vrf one

rd 1:1

route-target both 1:1

int fa0/0.1

ip vrf forwarding one

ip address 192.168.1.1

router bgp 1

address-family ipv4 vrf red

neighbor 192.168.1.2 remote-as 2

ASBR in AS2:

ip vrf one

rd 2:1

route-target both 2:1

int fa0/0.1

ip vrf forwarding one

ip address 192.168.1.2

router bgp 2

address-family ipv4 vrf red

neighbor 192.168.1.1 remote-as 1

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: 10a versus 10b - how to configure it??

that's great, thank you for the example, but how does that differ from a 10b setup? From RFC4364, 10a sounds like it simply trade BGP routes between AS's whereas 10b is more private arrangement just between two providers.

Did I read it incorrectly?

Thank you,

-Jeff

Cisco Employee

Re: 10a versus 10b - how to configure it??

The difference is that with 10b you don't need a interface/subinterface per VRF that needs interAS capability.

Instead, you run VPNv4 eBGP between the ASBRs in each AS. It is my opinion more scalable. A single inetrface is required between the two ASes.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Bronze

Re: 10a versus 10b - how to configure it??

As harry states option B is far by more scalable tha having to configure back to back vrfs on subinterfaces. Option B is my choice within my old companies network. You have 2 options as to how you get the ASBR PE to actually hold the routing table for the vrf. 1. You can use the command no bgp default route-target filter which will make the ASBR hold every single vrf that is created on your network (a bit like your route reflector) OR you can just create the vrf on the ASB with only a RT import command. personally again I use the RT import as i dont see any point whatsoever for this ASBR to hold the routing tables of every vrf in the network when its not going to do anything with about 90% of them.

HTH

New Member

Re: 10a versus 10b - how to configure it??

Gotcha, thanks.

For me, the final piece of the puzzle was to understand what constitutes 10a and/or 10b because I have to know when to deploy each type and why.

Great discussion, you've been most helpful.

-Jeff

New Member

Re: 10a versus 10b - how to configure it??

that answered my question perfectly, thanks. I found my MPLS Architectures book (Cisco Press) the other afternoon, and couldn't find a single discussion on 10a and 10b until I really read the section on InterProvider communications. I had to read it 3 times and re-read RFC 4364 before I latched onto 10b, I've just never seen the actual commands to do it.

But, I don't now from your discussion, makes sense.

Thanks for your time, great discussion.

-Jeff

1356
Views
0
Helpful
6
Replies
CreatePlease login to create content