Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

7200 as BRAS

Hi All,

I have a 7200 router connected with ME3600 which further connected with other MEs in ring topology. I need the 7200 to waork as BRAS. the media in ring is ethernet and i want to use Layer 2 pseudowire to transport DSLAM data traffic to BRAS. can some one help me out Please?

Thanks.

14 REPLIES

7200 as BRAS

Hi

Is the ME3600 Ring enabled for MPLS ?

We can use MPLS L2 VPN to Transport the Customer PPPoE Frames from the DSLAM connecting to one the MPLS Access PE towards the BRAS connecting to another MPLS PE.

Are you using a simple Service VLAN based setup or Per DSLAM/Per Service VLAN Based setup.

Regards

Varma

Community Member

7200 as BRAS

Hi,

Thanks for reply.

The ring is enabled for MPLS. the only issue is about how we will configure 7200 to receive the sessions from MPLS PE. what configurational perameters are required on PE side and simlarly at 7200 interface. Also Its configuration to act as BRAS.

Thanks.

7200 as BRAS

Hi

The configuration of 7200 as BRAS would imply configuring dot1q sub-interfaces in accordance with those handed over by the MPLS PE on the BRAS Uplink..

Lets take an example of using VLAN 100 for DSLAM #1 for HSI Traffic..Now we follow the below network topology

User----Cu----DSLAM#1----Vlan 100-Trunk------PWE 100---ME3600#1-----MPLS---ME3600#2-----PWE100---dot1q100--7200

So here the ME3600#2 port towards BRAS is configured as dot1q sub-interface 100 with VLAN ID 100 with xconnect statement for PWE..

7200 BRAS Port connecting to ME3600#2 is also configured as dot1q sub-interface 100 with VLAN ID 100 and relevant PPPoE config  such as enabling PPPoE and definging the bba-group there

Below this link has some relavant config for 7200 BRAS which you can refer to get an idea of required config..

https://supportforums.cisco.com/thread/2017691

Regards

Varma

Community Member

7200 as BRAS

Hi,

suppose DSLAM is tagging the Data traffic with Vlan 200 and this Dslam is connected with PE1(ME3600 )gig0/24.

PE1 configuration connecting with DSLAM

Interface gigabitethernet 0/24

Description “Trunk port to receive DSLAM Traffic”

switchport mode trunk

switchport trunk allowed vlan all

Interface vlan 200

Xconnect (Loopback interface of PE1) 123 encapsulation mpls

Similarly please share the configuration of PE2s port connected with BRAS and BRAS port connected with PE2.

Thanks.

7200 as BRAS

Hi

I am not sure on the support of VLAN Based xconnect on ME3600..I have used dot1q based xconnect earlier in my network..Sample config for Transporting VLAN 200 would be as below:

Access Side: ME3600#1:PE1

Interface gigabitethernet 0/24.200

encpasulation dot1q 200

Xconnect (Loopback interface of PE2) 123 encapsulation mpls

Core Side: ME3600#2:PE2--Gi0/0 connects to BRAS 7200 on Gi0/0

Interface gigabitethernet 0/0.200

encpasulation dot1q 200

Xconnect (Loopback interface of PE1) 123 encapsulation mpls

7200 BRAS

bba-group pppoe dsl-pppoe-test

virtual-template 2

sessions per-vlan limit 6000

!

Interface gigabitethernet 0/0.200

encpasulation dot1q 200

pppoe enable group dsl-pppoe-test (group name )

!

interface Virtual-Template2

description Virtual int for dsl-pppoe-test

mtu 1492

ip unnumbered GigabitEthernet0/1 (Gi0/1 is the Upstream Public Interface towards Internet Gateway)

peer default ip address pool dsl-pppoe-test

ppp authentication pap

ppp timeout idle 600

!

ip local pool dsl-pppoe-test X.X.X.1 X.X.X.254 (Public IP Pool of /24 for e.g)

Hope this helps to answer your query.

Regards

Varma

Community Member

7200 as BRAS

thank you very much.

still one query left. what about the routing of DSLAM users. can we place a static route of DSLAM network pointing towards a null interface and further redistribute it in OSPF becasue in ring OSPF area 1 is ruunning and towards internet from BRAS area 0 is configured.

On BRAS.

Ip route 192.168.0.0 255.255.255.0 null 0

redistribute static OSPF

Also what about the routing of rest of the Vlans in netwrok other than DSLAM. should there be a seperate point to point layer 3 link from ME3600 to BRAS with its network advertised in area 1?

Thanks.

Re: 7200 as BRAS

Hi

Yes you are absolutely correct on both the points..Lets take them one by one:

1. Upstream Routing of DSL User Subnets..

On BRAS

Create a Null route and redistribute the same under OSPF PID

e.g

ip route 192.168.0.0 255.255.255.0 null 0

router ospf 1

redistribute static subnets ( without subnets keywords only classful networks are redistributed)

2. Upstream Routing of Non-DSL users handed off from ME3600#2 ie PE2 via separate Physical Link under ospf area 1..

router ospf 1

network 172.16.0.0 0.0.255.255 area 1

Regards

Varma

Community Member

7200 as BRAS

i really appreciate the way you guided me all the way.

What should be IOS of 7200. Because in 7609 with SIP 400 cisco sells subscriber awareness license. Is there any requirement on 7200 to be acted as a BRAS. Also i am sure it should work on 7200 with E1 cards for WAN connectivity and simple gig ethernet cards for the connectivity with ME3600. Please confirm.

Regards,

Awais

7200 as BRAS

Hi Awais

Not a problem..Glad that it helped you in your rquirement.

I am sorry but I am not aware from the IOS requirements exactly on the Licensing Part but Yes I do remember something about getting the Subscriber License on the HW for the BRAS functionality. I think the License is needed as the max number of PPPoE sessions supported are limited by the License on the HW.I would suggest to try browsing Cisco Online Documents to get clarified for same..

And yes the requirement from IOS side should be to support the basic IP Features Routing..From the other discussion link I posted in my first response the c7206 has below IOS

boot system disk2:c7200-advipservicesk9-mz.122-33.SRD4.bin

Regards

Varma

Community Member

Re: 7200 as BRAS

Dear Vaibhava,

Contenueing the discussion for just sake of information please advise if this is possible to assign Ip addresses from two different pools configured on BRAS to two different Vlans coming from two different DSLAMS and  should we need to configure it as following.

First Access Side: ME3600#1:PE1

Interface gigabitethernet 0/24.200

encpasulation dot1q 200

Xconnect (Loopback interface of PE2) 123 encapsulation mpls

Second Access Side: ME3600#2:PE3

interface gigabitethernet 0/24.300

encapsulation dot1q 300

xconnect(loopback interface of PE2) 124 encapsulation mpls

Core Side: ME3600#2:PE2--Gi0/0 connects to BRAS 7200 on Gi0/0

Interface gigabitethernet 0/0.200

encpasulation dot1q 200

Xconnect (Loopback interface of PE1) 123 encapsulation mpls

interface gigabitethernet 0/0.300

encapsulation dot1q 300

Xconnect (loopback interface of PE3) 124 encapsulation mpls

7200 BRAS

bba-group pppoe dsl-pppoe-PE1

virtual-template 2

sessions per-vlan limit 6000

!

bba-group pppoe dsl-ppoe-PE3

virtual-template 3

sessions per-vlam limit 6000

Interface gigabitethernet 0/0.200

encpasulation dot1q 200

pppoe enable group dsl-pppoe-PE1 (group name )

!

interface gigabitethernet 0/0.300

encapsulation dot1q 300

pppoe enable group dsl-pppoe-PE3

interface Virtual-Template2

description Virtual int for dsl-pppoe-PE1

mtu 1492

ip unnumbered GigabitEthernet0/1 (Gi0/1 is the Upstream Public Interface towards Internet Gateway)

peer default ip address pool dsl-pppoe-PE1

ppp authentication pap

ppp timeout idle 600

!

interface Virtual-Template3

description Virtual int fro dsl-pppoe-PE3

mtu 1492

ip unnumbered gigabitethernet 0/1

peer default ip address pool dsl-pppoe-PE3

ppp authentication pap

ppp timeout idle 600

ip local pool dsl-pppoe-PE1 X.X.X.1 X.X.X.254

ip local pool dsl-pppoe-PE3 X.X.X.1 X.X.X.254

Also now what about the routing of above two networks. Can we configure two null interfaces on 7200 and pint both routes to two null interfaces statically and redistribute them in OSPF.

Regards,

Awais

Re: 7200 as BRAS

Hi Awais

The configuration seems alright to me and should work the way its required to distribute different IP Pools to differet DSLAM VLANs.

Yes for the routing part 2 X Static Null Routes would be required and further redistributed under OSPF Process.

Regards

Varma

Community Member

Re: 7200 as BRAS

HI,

Also i forgot to mention one thing what if we dont need to perform the authentication of the DSLAM users. In that case only one command ppp authentication pap will be omitted from configuration and no AAA command will be in place. Am i right? Also verify the two dofferent static  null routes Pointing to NULL0.

Ip route 192.168.0.0 255.255.255.0 null 0 (first route)

Ip route (second network) null 0 (Second route)

Regards,

Awais

Re: 7200 as BRAS

Hi Awais

Yes if there is no authentication needed then you are right on omitting the authetication and AAA config..Is this is your test setup ?

Yes you have mentioned correctly on creating two null routes for two different pools.

Regards

Varma

Community Member

Re: 7200 as BRAS

No.. its not a test setup i am going to deploy it at one my client premises. And bundle of thanks fro your support.

Regards,

Awais

2015
Views
0
Helpful
14
Replies
CreatePlease to create content