Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

About AToM (pe to pe)

7304做MPLS配置:MPLS VPN三层没有问题,二层VPN建立VC有问题,无法解决!!!请求关注!!!

Router#sh run

Building configuration...

Current configuration : 1802 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

enable password xxxx

!

hostname Router

!

logging snmp-authfail

logging queue-limit 100

!

ip subnet-zero

no ip domain-lookup

ip cef

!

ip vrf xjccw

rd ....

route-target export ....

route-target import ....

!

mpls ldp logging neighbor-changes

!

interface Loopback0

ip address 10.254.254.200 255.255.255.255

no ip route-cache

no ip mroute-cache

!

interface FastEthernet0

no ip address

no keepalive

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/0

description connect to GSR

mtu 1800

ip address 10.4.10.201 255.255.255.252

negotiation auto

tag-switching ip

!

interface GigabitEthernet0/1

mtu 1800

no ip address

negotiation auto

!

interface GigabitEthernet0/1.2

description connect to xjccw

encapsulation dot1Q 2

ip vrf forwarding xjccw

ip address 192.168.100.1 255.255.255.0

!

interface GigabitEthernet0/1.100

description connect to test_3550

encapsulation dot1Q 100

mpls l2transport route 10.254.254.129 100

tag-switching ip

!

router ospf 1

log-adjacency-changes

network 10.4.10.200 0.0.0.3 area 0

network 10.254.254.200 0.0.0.0 area 0

!

router bgp 100

no bgp default ipv4-unicast

bgp log-neighbor-changes

neighbor 10.254.254.129 remote-as 100

neighbor 10.254.254.129 update-source Loopback0

!

address-family ipv4

no auto-summary

no synchronization

exit-address-family

!

address-family ipv4 multicast

no auto-summary

exit-address-family

!

address-family vpnv4

neighbor 10.254.254.129 activate

neighbor 10.254.254.129 send-community extended

no auto-summary

exit-address-family

!

address-family ipv4 vrf xjccw

redistribute connected

no auto-summary

no synchronization

exit-address-family

!

ip classless

no ip http server

!

line con 0

logging synchronous

line aux 0

line vty 0 4

password xjccw

exec-timeout 0 0

!

end

在GSR上做完MPLS L2TRANSPORT ROUTE 10.254.254.129 10时出现如下情况:

MPLS config error: 10.4.10.202 is not a valid LDP id, use 10.254.254.129 instead

09:22:10: %LDP-5-NBRCHG: TDP Neighbor 10.254.254.129:0 is UP

09:22:10: %TDP-4-PTCL: peer 10.254.254.129:0, bad PIE len

09:22:10: PDU HDR:

09:22:10: 0x00 0x01 0x00 0x3E 0x0A 0xFE 0xFE 0x81 0x00 0x00 0x04 0x00

09:22:10: PIE HDR:

09:22:10: 0x0B 0x96 0x01 0x00

09:22:10: %LDP-5-NBRCHG: TDP Neighbor 10.254.254.129:0 is DOWN

**************************************

  • MPLS
3 REPLIES
New Member

Re: About AToM (pe to pe)

刚开始在7206做实验,结果三层VPN和二层VPN都不通,郁闷中。。。。。。

升级其IOS,还是不行,只能在7304上做实验,结果。。。。。。。。

7206-test#sh run

Building configuration...

Current configuration : 1823 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 7206-test

!

boot-start-marker

boot-end-marker

!

!

ip subnet-zero

!

!

ip cef

no ip domain-lookup

ip vrf xjccw1

rd ...

route-target export ...

route-target import ...

!

!

!

interface Loopback0

ip address 10.254.254.201 255.255.255.255

no ip directed-broadcast

!

interface FastEthernet0/0

no ip address

no ip directed-broadcast

duplex half

speed auto

!

interface FastEthernet0/0.101

description connect to sitB1_vc101_GSR

encapsulation dot1Q 101

no ip directed-broadcast

tag-switching ip

no cdp enable

xconnect 10.254.254.129 101 encapsulation mpls

!

interface FastEthernet0/0.105

description connect to xjccw1

encapsulation dot1Q 105

ip vrf forwarding xjccw1

ip address 192.168.10.1 255.255.255.0

no ip directed-broadcast

!

interface FastEthernet0/1

no ip address

no ip directed-broadcast

shutdown

duplex half

speed auto

!

interface POS2/0

description connect to GSR

ip address 10.4.10.205 255.255.255.252

no ip directed-broadcast

tag-switching ip

fair-queue 64 256 0

!

router ospf 1

log-adjacency-changes

network 10.4.10.204 0.0.0.3 area 0

network 10.254.254.201 0.0.0.0 area 0

!

router bgp 100

no synchronization

bgp log-neighbor-changes

neighbor 10.254.254.129 remote-as 100

neighbor 10.254.254.129 update-source Loopback0

no auto-summary

!

address-family vpnv4

neighbor 10.254.254.129 activate

neighbor 10.254.254.129 send-community extended

exit-address-family

!

address-family ipv4 vrf xjccw1

redistribute connected

no auto-summary

no synchronization

exit-address-family

!

ip classless

!

line con 0

logging synchronous

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

no cns aaa enable

end

New Member

Re: About AToM (pe to pe)

7206-test#sh mpls l2transport vc de

Local interface: Fa0/0.101 up, line protocol up, Eth VLAN 101 up

Destination address: 10.254.254.129, VC ID: 101, VC status: down

Preferred path: not configured

Default path: path untagged

Output interface: unknown, imposed label stack {}

Create time: 01:11:49, last status change time: 01:11:19

Signaling protocol: LDP, peer 10.254.254.129:0 up

MPLS VC labels: local 16, remote 18

Group ID: local 0, remote 7

MTU: local 1500, remote 1500

Remote interface description: Site-A2-vc101-7206

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 0, send 0

byte totals: receive 0, send 0

packet drops: receive 0, send 0

Cisco Employee

Re: About AToM (pe to pe)

it seems that you are having a control plane problem specific to label setup

from show l2 mpls vc;

Output interface: unknown, imposed label stack {}

and from the debug, it seems that you have a problem with LDP/TDP misconfig, such as one neighbour talk LDP while other talks TDP

Also check the LDP router ID, but I think

(config-if)# mpls label protocol ldp

In the respective interfaces will solve your problem

Regards

Sanjeewa

239
Views
0
Helpful
3
Replies
This widget could not be displayed.