Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

About mpls l2 vpn interworking question!

Cisco's mpls l2 vpn support interworking,

but I don't understand,which do frame format changing, ingress lsr or egress lsr ?

thanks!

5 REPLIES
Bronze

Re: About mpls l2 vpn interworking question!

Accoring to L2vpn framework draft There are at least three different approaches to interworking:

1. One of the CEs may perform the interworking locally. For

example, if CE1 attaches to PE1 via ATM, but CE2 attaches to

PE2 via Ethernet, then CE1 may decide to send/receive Ethernet

frames over ATM, using the RFC2684 "LLC Encapsulation for

Bridged Protocols". In such a case, PE1 would need to know

that it is to terminate the ATM VC locally, and only

send/receive Ethernet frames over the PW.

2. One of the PEs may perform the interworking. For example, if

CE1 attaches to PE1 via ATM, but CE2 attaches to PE2 via Frame

Relay, PE1 may provide the "ATM/FR Service Interworking"

function. This would be transparent to the CEs, and the PW

would carry only Frame Relay frames.

3. IPLS could be used. In this case the "frames" carried by the

PW are IP datagrams, and the two PEs need to cooperate in order

to spoof various L2-specific procedures used by IP (see section

3.5).

http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-l2-framework-03.txt

Cisco has Ethernet and IP Interworking.Pls see the url for more details.

http://www.cisco.com/en/US/partner/products/sw/iosswrel/ps1829/products_feature_guide09186a00801b2407.html#43773

As per me the translation happens on the ingress PE,it would be nice if someone from Cisco can confirm this.

Bronze

Re: About mpls l2 vpn interworking question!

• IP mode—This mode requires that endpoints exchange traffic running IP at Layer 3. However, a mix of Layer 2 services can be in place at customer sites. Consider the case of exchanging traffic between one site running Frame Relay and another running Ethernet services across an MPLS network, for example.

In this scenario, a site with a Frame Relay router interface generates a packet with an IP payload. When the frame arrives at the service provider’s edge router, the router strips off the Frame Relay header and adds an outer MPLS label for switching and an innerlabel for demultiplexing. This is the standard encapsulation scheme for Cisco AToM.

The edge router then transmits the IP payload across an IP pseudo-wire; at the other end, the egress provider-edge (PE) router removes the outer label and inspects the inner label to determine the appropriate interface for forwarding. The PE adds an Ethernet header to the packet and forwards it out the proper interface to the customer site.

This mode requires no configuration changes to customer premises equipment (CPE). In addition, each end of an MPLS tunnel plays an active role in the interworking, fairly balancing the processing required to perform the translation.

In the case of using L2TPv3 in IP mode to achieve service interworking over a native IP network, a packet arrives from the customer, and the PE strips off the Frame Relay header. The PE node appends an L2TPv3 header and a delivery IP header, which identifies the appropriate L2TPv3 pseudo-wire for transmission.

• Ethernet mode—Here, one end of a tunneled connection currently must be running Ethernet. However, traffic running any protocol at Layer 3 can be passed. In this scenario, CPE requires route bridge encapsulation (RBE) or integrated routing and bridging (IRB) to be configured on it.

The WAN access router at the customer site accepts an Ethernet packet from the LAN and appends both a different Ethernet header and a Frame Relay header to it. The extra Ethernet header is called a shim header, or one that is sandwiched between two other headers. The RBE/IRB function makes sure the shim header is included.

The packet is then transmitted to the ingress PE device. That PE removes the Frame Relay header, establishes a pseudo-wire, and forwards the Ethernet payload to the other end of the pseudo-wire. From there, the egress PE forwards the packet across the local Ethernet interface.

New Member

Re: About mpls l2 vpn interworking question!

thanks,very pity,I have not a cco account,then I couldn't look at cisco's implementation!

Bronze

Re: About mpls l2 vpn interworking question!

Ethernet Interworking

PE1

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom-eth

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 8.8.8.8 255.255.255.255

!

interface FastEthernet1/0

xconnect 9.9.9.9 123 encapsulation mpls pw-class atom-eth

PE2

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom-eth

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 9.9.9.9 255.255.255.255

!

interface FastEthernet0/0

no ip address

!

interface FastEthernet0/0.3

encapsulation dot1Q 10

xconnect 8.8.8.8 123 encapsulation mpls pw-class atom-eth

IP Interworking

PE1

frame-relay switching

!

mpls label protocol ldp

mpls ldp router-id loopback0

mpls ip

!

pseudowire-class atom

encapsulation mpls

interworking ip

!

interface loopback 0

ip address 8.8.8.8 255.255.255.255

no shutdown

!

connect fr-vlan POS1/0 206 l2transport

xconnect 9.9.9.9 6 pw-class atom

PE2

mpls label protocol ldp

mpls ldp router-id loopback0

mpls ip

!

pseudowire-class atom

encapsulation mpls

interworking ip

!

interface loopback 0

ip address 9.9.9.9 255.255.255.255

no shutdown

!

interface FastEthernet1/0/1.6

encapsulation dot1Q 6

xconnect 8.8.8.8 6 pw-class atom

no shutdown

New Member

Re: About mpls l2 vpn interworking question!

Just to add to this discussion...

In the L2VPN Interworking implementation, as Aditya correctly pointed out, you can have either a routed/IP or bridged/Ethernet IW (Interworking) mode. So if the IW mode is IP, then the ingress LSR will strip the L2 encap (FR, ATM, Ethernet) and send only the underlying IPv4 packet. If the L3 packet is not IPv4 or an ARP packet, this model will not work.

Conversely, if the IW mode is Ethernet, then the Pseudowire is EoMPLS (VC Type 5). At the ingress LSR, the router will remove the L2 encap (FR, ATM) and send only the underlying SNAP bridged frame.

Also, note that you can do FR-AAL5 IW, but like Aditya noted, you will need to use IRB/RBE on the CE side to create the bridged frames.

Hope this helps...

--tamrat

350
Views
8
Helpful
5
Replies