Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

AT&T MPLS Network

Have 12 sites currently running over traditional frame-relay network with PVC's to/from all sites.

We are looking to move to AT&T's MPLS service.

We'll manage the CE portion.

Is it a true assumption that our routers do not need to do any tag-switching or be MPLS aware at all?

I am under the notion that we'll need to establish BGP with the AT&T PE and simply redistribute our local CE routes into BGP.

AT&T's PE will strip the label and deliver a IPv4 packet to our CE.

Please correct me if I'm mistaken.

Thanks!

9 REPLIES

Re: AT&T MPLS Network

Hello,

your assumption about the requirements towards the CE are absolutely right. There is no need for MPLS support on a CE in a normal MPLS L3VPN. The MPLS VPN will look like one big standard IP router to your CE.

To demonstrate the requirements: You could even attach a PC directly to a MPLS PE acting as default gateway.

There will be IP packets (data plane) and normal IP routing updates. BGP is an options the SPs prefer, technically there are also other options like OSPF or RIP. Just check with your provider, which option is supported and what it costs you.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: AT&T MPLS Network

The MPLS cloud will be transparent to you, you can use any dynamic routing protocol or static routes with AT&T..

New Member

Re: AT&T MPLS Network

This is looking good...

So, here's a sample config for two sites.

Looking for a sanity check to use this as a template for all 12 sites.

_____________________________________________________

CE FOR SITE A: COnfig sample below

_____________________________________________________

interface Loopback0

ip address 10.22.200.1 255.255.255.255

!

interface FastEthernet0/0

ip address 10.10.1.252 255.255.255.0

ip helper-address 10.10.1.20

!

interface Serial0/0

no ip address

encapsulation frame-relay

!

interface Serial0/0.123 point-to-point

description PVC to Boston

bandwidth 256

ip address 195.164.254.190 255.255.255.252

frame-relay interface-dlci 123

!

router bgp 65001

neighbor 195.164.254.189 remote-as 65001

network 10.10.1.0 mask 255.255.255.0

redistribute connected

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 195.164.254.189

_____________________________________________________

CE FOR SITE B: COnfig sample below

_____________________________________________________

interface Loopback0

ip address 10.22.200.2 255.255.255.255

!

interface FastEthernet0/0

ip address 10.10.2.252 255.255.255.0

ip helper-address 10.10.1.20

!

interface Serial0/0

no ip address

encapsulation frame-relay

!

interface Serial0/0.124 point-to-point

description PVC to New York

bandwidth 256

ip address 195.164.254.192 255.255.255.252

frame-relay interface-dlci 124

!

router bgp 65002

neighbor 195.164.254.193 remote-as 65002

network 10.10.1.0 mask 255.255.255.0

redistribute connected

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 195.164.254.194

New Member

Re: AT&T MPLS Network

In looking over my own template, I may be missing the logic behind MPLS.

I think that default route will do nothing for me.

We'd need static routes to all sites on each router, correct?

Or we could run an IGP like OSPF and use area 0 for all sites.

Purple

Re: AT&T MPLS Network

The default route is just fine (as long as all your sites are single-homed). If you had to configure static routes, that would defeat the purpose of this!

By using a default route, you are letting the MPLS VPN PE make the routing decision, since it will have specific routes to all your destinations. The key is to ensure that all your prefixes are advertised via BGP to the MPLS PE. The PEs will talk amongst themselves and work out what needs to go where. The CEs simply send them all the packets they have and let the PE forward them appropriately.

Paresh

Silver

Re: AT&T MPLS Network

Your need for default route would depend on your router configurations. If you are running a dynamic routing protocol, then your CE routers could pick the routes for the other sites (as well as the default route) via the routing protocol. Note that BGP is also a routing protocol. Hencem connecting via BGP to the provider could be sufficient for you. Although, your configuration showed the same AS number for you as well as the provider. This would most likely not be the case as this is an eBGP connection and the AS number for the CE should be different from the PE. Note also that by using different AS numbers at your site, the sites will be seen to be under different Autonomous system. Often, people use the same AS numbers and the provider has to configure an AS-override at her end.

If you are using static route configuration, then you could as well point the default route just as you have configured. This will simplify your configuration. However, if it is not optimal to point the default route here (maybe, the site get internet access from another provider), then you might have to statically define the various LAN prefixes of the remaining branches.

Hope this helps

Purple

Re: AT&T MPLS Network

Hi,

A couple of things:

- you would normally peer with the service provider's AS number, not your own, since this will be an EBGP peering.

- ensure that you use a different local AS number on each CE

- the network statement you have got under 'router bgp' is not really required since you are redistributing connected networks anyways.

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: AT&T MPLS Network

This is all really great info!

Another issue that has become apparent in hashing this out....

All sites will use a DS3 Internet Pressence at the datacenter core.

This makes things interesting.

How do I tell BGP and MPLS about this?

Re: AT&T MPLS Network

Hello,

internet access will be achieved like in a normal IP routing environment. originate a default route from your internet gateway(s) and redistribute this into your BGP. It will distribute the default route to all of your locations. In this case you do not even have to configure a static default in your locations. All traffic to the internet will follow the default route. All other traffic will follow the longest match route in the respective IP routing tables.

Hope this helps! Please rate all posts.

Regards, Martin

1265
Views
29
Helpful
9
Replies