Cisco Support Community
Community Member

AToMPLS in Vlan Mode


I am trying to configure ATOMPLS on catalyst 6500 with sup 720 3xlbs. I noticed something which i would like to discuss. I am trying to configure vlan mode.

1) This is the only config that works.

I have to create subinterfaces for every vlan that will be travered over the ldp tunnel otherwise the software does not seem to understand the dot1q tag.

interface GigabitEthernet3/15

no ip address


interface GigabitEthernet3/15.1

encapsulation dot1Q 925

xconnect 925 encapsulation mpls


Method2) This does not work:

interface GigabitEthernet1/22

description ## customer facing port ##

mtu 9216

no ip address


switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3040,3601-3604,3701

switchport mode trunk


interface Vlan3601

description ## Customer A SP vlan ##

mtu 9216

no ip address

xconnect <remote-PE IP > 3601 encapsulation mpls // targeted ldp setup for reaching the remote PE //

Would someone know why the second method does not work? why is it necessary to have subinterfaces for the software to recognise the dot1q tag in a catalyst 6500?


Hall of Fame Super Silver

Re: AToMPLS in Vlan Mode

Hello parwal.

First, EoMPLS using LDP targeted sessions is a point-to-point L2 transport service.

A Switched Virtual Interface like Vlan 3601 is thought to provide a default gateway to all users of a broadcast domain VLAN (L2 concept) connected to multiple L2 acces ports or L2 trunk ports.(point to multipoint !) on the same multilayer switch.

What if there are two L2 ports/ L2 trunks members/carrying VLAN 3601 ?

So a SVI is a L3 object that is linked to a L2 entity the VLAN with the same number.

I suppose that the dot1q tag might be stripped on the path to SVI VLAN in the current CEF forwarding implementation, so the SVI cannot see the 802.1Q tag. As a result of this the SVI cannot send frames over the LDP tunnel and they are silently discarded.

Probably you can get the ldp tunnel to be up but no frames can flow over it, ldp tunnel state is linked to the interface status of the interface with the xconnect command.

interface Vlan 3601 is up/up if at least a L2 port of VLAN 3601 is in forwarding state STP including trunk ports.

A VLAN subinterface is associated with only one physical port and is defined using the 802.1Q tag value!.

It is easier for the forwarding plane to perform the correct action in this case: take the frame with 802.1Q tag and send them over the ldp tunnel.

Hope to help


CreatePlease to create content