Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Basic MPLS , IGRP - Confused about Basic Routing Process

Hello Forum

As a beginner in mpls i am confused about the differnt routing processes.

In a lab we have 4 Backbone (MPLS speaking) 6509.

- Basic routing process is ospf where all the links between this boxes are in.

Configuration 1 6509 see below.

=>>> Where is the connector from the basic routing to the mp-bgp ? no redistribution ist configured. ist that somwhrer "implicit" ?

(Lab is working, but no one understand it )

....

!

ip vrf VPN_A

rd 65000:1

route-target export 65000:100

route-target import 65000:100

!

ip vrf VPN_B2

rd 65000:22

route-target export 65000:22

!

!

interface Loopback0

ip address 10.10.2.2 255.255.255.255

!

!

router ospf 100 vrf VPN_A

log-adjacency-changes

redistribute bgp 65000 subnets

network 10.0.27.1 0.0.0.0 area 0

network 10.0.28.1 0.0.0.0 area 0

!

!
ip vrf VPN_A
rd 65000:1
route-target export 65000:100
route-target import 65000:100
!
ip vrf VPN_B2
rd 65000:22
route-target export 65000:22
!

.....

mpls label protocol ldp

....

!
interface Loopback0
ip address 10.10.2.2 255.255.255.255
!

.....

!
router ospf 100 vrf VPN_A
log-adjacency-changes
redistribute bgp 65000 subnets
network 10.0.27.1 0.0.0.0 area 0
network 10.0.28.1 0.0.0.0 area 0
!

.....

!

router ospf 1

router-id 10.10.2.2

log-adjacency-changes

network 10.0.12.2 0.0.0.0 area 0

network 10.0.24.1 0.0.0.0 area 0

network 10.10.2.2 0.0.0.0 area 0

!

!

router bgp 65000

no bgp default ipv4-unicast

no bgp default route-target filter

bgp log-neighbor-changes

neighbor 10.10.1.1 remote-as 65000

neighbor 10.10.1.1 update-source Loopback0

neighbor 10.10.3.3 remote-as 65000

neighbor 10.10.3.3 update-source Loopback0

neighbor 10.10.4.4 remote-as 65000

neighbor 10.10.4.4 update-source Loopback0

neighbor 10.10.5.5 remote-as 65000

neighbor 10.10.5.5 update-source Loopback0

neighbor 10.10.6.6 remote-as 65000

neighbor 10.10.6.6 update-source Loopback0

!

address-family vpnv4

  neighbor 10.10.1.1 activate

  neighbor 10.10.1.1 send-community extended

  neighbor 10.10.3.3 activate

  neighbor 10.10.3.3 send-community extended

  neighbor 10.10.4.4 activate

  neighbor 10.10.4.4 send-community extended

  neighbor 10.10.4.4 route-reflector-client

  neighbor 10.10.5.5 activate

  neighbor 10.10.5.5 send-community extended

  neighbor 10.10.6.6 activate

  neighbor 10.10.6.6 send-community extended

  neighbor 10.10.6.6 route-reflector-client

exit-address-family

!

address-family ipv4 vrf VPN_SER1

  redistribute ospf 50 vrf VPN_SER1

  no synchronization

exit-address-family

!

address-family ipv4 vrf VPN_B2

  redistribute connected

  no synchronization

exit-address-family

!

address-family ipv4 vrf VPN_A

  redistribute connected

  redistribute ospf 100 vrf VPN_A

  no synchronization

exit-address-family

!

!
router ospf 1
router-id 10.10.2.2
log-adjacency-changes
network 10.0.12.2 0.0.0.0 area 0
network 10.0.24.1 0.0.0.0 area 0
network 10.10.2.2 0.0.0.0 area 0
!

- BGP with adress families for the vrf's

!
router bgp 65000
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.10.1.1 remote-as 65000
neighbor 10.10.1.1 update-source Loopback0
neighbor 10.10.3.3 remote-as 65000
neighbor 10.10.3.3 update-source Loopback0
neighbor 10.10.4.4 remote-as 65000
neighbor 10.10.4.4 update-source Loopback0
neighbor 10.10.5.5 remote-as 65000
neighbor 10.10.5.5 update-source Loopback0
neighbor 10.10.6.6 remote-as 65000
neighbor 10.10.6.6 update-source Loopback0
!
address-family vpnv4
  neighbor 10.10.1.1 activate
  neighbor 10.10.1.1 send-community extended
  neighbor 10.10.3.3 activate
  neighbor 10.10.3.3 send-community extended
  neighbor 10.10.4.4 activate
  neighbor 10.10.4.4 send-community extended
  neighbor 10.10.4.4 route-reflector-client
  neighbor 10.10.5.5 activate
  neighbor 10.10.5.5 send-community extended
  neighbor 10.10.6.6 activate
  neighbor 10.10.6.6 send-community extended
  neighbor 10.10.6.6 route-reflector-client
exit-address-family
!
address-family ipv4 vrf VPN_SER1
  redistribute ospf 50 vrf VPN_SER1
  no synchronization
exit-address-family
!
address-family ipv4 vrf VPN_B2
  redistribute connected
  no synchronization
exit-address-family
!
address-family ipv4 vrf VPN_A
  redistribute connected
  redistribute ospf 100 vrf VPN_A
  no synchronization
exit-address-family
!

Thanks for help !

Martin

1 ACCEPTED SOLUTION

Accepted Solutions

Basic MPLS , IGRP - Confused about Basic Routing Process

martin,

In order for BGP to form peering it needs to know the neighbor ip addresses right? so you achieve that layer 3 connectivity via some IGP when you have a couple of routers. Of course if they are directly connected then  its not necessary to run IGP( depends on how u peer).

BGP is needed for MPLS VPN's between the PE's as its the routing protocol to carry the VPNv4 routes which is an address family which is not your normal ipv4.

for the PE-CE, its up to you to choose whichever routing protocol you want RIP,ospf, BGP etc

Hope this helps

Kishore

8 REPLIES

Basic MPLS , IGRP - Confused about Basic Routing Process

Hi Martin,

this is the MP-BGP snippet:

address-family vpnv4

  neighbor 10.10.1.1 activate

  neighbor 10.10.1.1 send-community extended

  neighbor 10.10.3.3 activate

  neighbor 10.10.3.3 send-community extended

  neighbor 10.10.4.4 activate

  neighbor 10.10.4.4 send-community extended

  neighbor 10.10.4.4 route-reflector-client

  neighbor 10.10.5.5 activate

  neighbor 10.10.5.5 send-community extended

  neighbor 10.10.6.6 activate

  neighbor 10.10.6.6 send-community extended

  neighbor 10.10.6.6 route-reflector-client

exit-address-family

try to check 'sh ip bgp neighbor' - you'll see the address-families negotiated.

HTH,

Ivan.

New Member

Basic MPLS , IGRP - Confused about Basic Routing Process

Hi Ivan

This will be the output:

bl1s101#sh ip bgp neighbors

bl1s101#

Did I understand you correct ?

Regards, Martin

Basic MPLS , IGRP - Confused about Basic Routing Process

Hi Martin,

sorry my bad, you don't have IPv4 AF negotiated, you better look at:

sh ip bgp vpnv4 all neighbors

Ivan.

New Member

Basic MPLS , IGRP - Confused about Basic Routing Process

Thanks again,

here my output.

bl1s101#sh ip bgp vpnv4 all neighbors
BGP neighbor is 10.10.1.1,  remote AS 65000, internal link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Active
  Last read 2w6d, last write 2w6d, hold time is 180, keepalive interval is 60 seconds
  Message statistics:
    InQ depth is 0
    OutQ depth is 0

                         Sent       Rcvd
    Opens:                  0          0
    Notifications:          0          0
    Updates:                0          0
    Keepalives:             0          0
    Route Refresh:          0          0
    Total:                  0          0
  Default minimum time between advertisement runs is 0 seconds

For address family: VPNv4 Unicast
  BGP table version 88, neighbor version 0/0
  Output queue size : 0
  Index 2, Offset 0, Mask 0x4
  2 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:              31          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0

  Address tracking is enabled, the RIB does have a route to 10.10.1.1
  Connections established 0; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
  No active TCP connection

........

Sorry about my bad understanding but I can still not make the relationship between basic IGP Routing . OSPF 1 and the MPLS, MP-BGP.

Martin

Basic MPLS , IGRP - Confused about Basic Routing Process

Hi Martin,

For MPLS VPN's there are 3 things you need.

1. IGP- This is used between the PE-P-PE routers for full connectivity so that you can run bgp later on

2. BGP- for MP-BGP tranport safi

3. PE-CE routing protocol- could be ospf bgp, rip,eigrp etc

in your case ospf 1 is used as the tranport IGP which i mentioned in point 1.

router osp 50, 60 and all are used as PE-CE routing protocol

Does this help ? Let me know if u need more info

Kishore

New Member

Basic MPLS , IGRP - Confused about Basic Routing Process

Hi Kishore

Thank you - yes that helps.

What I still not understand ist HOW the BGP will learn the connectivity from the IGP ?

Other than with PE-CE there is no Redistribution.

Or I am totally false and there is no need for BGP to knowing that ?

Martin

Basic MPLS , IGRP - Confused about Basic Routing Process

martin,

In order for BGP to form peering it needs to know the neighbor ip addresses right? so you achieve that layer 3 connectivity via some IGP when you have a couple of routers. Of course if they are directly connected then  its not necessary to run IGP( depends on how u peer).

BGP is needed for MPLS VPN's between the PE's as its the routing protocol to carry the VPNv4 routes which is an address family which is not your normal ipv4.

for the PE-CE, its up to you to choose whichever routing protocol you want RIP,ospf, BGP etc

Hope this helps

Kishore

New Member

Basic MPLS , IGRP - Confused about Basic Routing Process

Thank you!

Martin

694
Views
5
Helpful
8
Replies
CreatePlease login to create content