Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Bronze

BGP isn't installing routes Nexus 7000

Hi

Routes are not installed in the routing table.

Se the following output:                

core# sh ip bgp 0.0.0.0 vrf vrf_bruker
BGP routing table information for VRF vrf_bruker, address family IPv4 Unicast
BGP routing table entry for 0.0.0.0/0, version 396
Paths: (1 available, best #0)
Flags: (0x080002) on xmit-list, is not in urib
  vpn: version 398, (0x100002) on xmit-list

  Path type: internal, path is invalid, imported same remote RD, no labeled nexthop
  AS-Path: NONE, path sourced internal to AS
    172.25.32.10 (metric 0) from 172.25.32.10 (172.25.32.10)
      Origin IGP, MED 0, localpref 100, weight 0
      Received label 1580
      Extcommunity:
          RT:65432:110

  VRF advertise information:

  VPN AF advertise information:


Has anyone an idea why ?

regards

bjornarsb

Everyone's tags (1)
8 REPLIES
Cisco Employee

BGP isn't installing routes Nexus 7000

Path type: internal, path is invalid, imported same remote RD

Hi seems you have the same RD configured on both end.

Bronze

BGP isn't installing routes Nexus 7000

Hi

The routes are in the BGP table:

core# sh ip bgp vrf vrf_bruker all
BGP routing table information for VRF vrf_bruker, address family IPv4 Unicast
BGP table version is 433, local router ID is 172.22.5.30
Status: s-suppressed, x-deleted, S-stale, d-dampened, h-history, *-valid, >-best
Path type: i-internal, e-external, c-confed, l-local, a-aggregate, r-redist
Origin codes: i - IGP, e - EGP, ? - incomplete, | - multipath

   Network            Next Hop            Metric     LocPrf     Weight Path
  i0.0.0.0/0          172.25.32.10             0        100          0 i

Cisco Employee

BGP isn't installing routes Nexus 7000

Hi

You are right but if you see that route is also not the best route, otherwise you would have seen a ">" sign before the prefix.

Can you give me the output of show ip route vrf vrf_bruker ?

Bronze

BGP isn't installing routes Nexus 7000

Here is the output:

-core# sh ip route vrf vrf_bruker
IP Route Table for VRF "vrf_bruker"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%' in via output denotes VRF

172.22.5.30/32, ubest/mbest: 2/0, attached
    *via 172.22.5.30, Lo5, [0/0], 14w4d, local
    *via 172.22.5.30, Lo5, [0/0], 14w4d, direct

Cisco Employee

BGP isn't installing routes Nexus 7000

Hi

You don't have the route for your next hop in the routing table 172.25.32.10. That is the reason this is not getting installed.

Bronze

BGP isn't installing routes Nexus 7000

Hi.

This is MBGP. I can ping 172.25.32.10 in the global routing table

core# ping 172.25.32.10

PING 172.25.32.10 (172.25.32.10): 56 data bytes

64 bytes from 172.25.32.10: icmp_seq=0 ttl=254 time=0.896 ms

64 bytes from 172.25.32.10: icmp_seq=1 ttl=254 time=0.567 ms

64 bytes from 172.25.32.10: icmp_seq=2 ttl=254 time=0.611 ms

64 bytes from 172.25.32.10: icmp_seq=3 ttl=254 time=0.549 ms

64 bytes from 172.25.32.10: icmp_seq=4 ttl=254 time=0.575 ms

Cisco Employee

BGP isn't installing routes Nexus 7000

Can you send me the configuration of both the PE routers ?

Bronze

BGP isn't installing routes Nexus 7000

Hi

Thanks for the help.

Here is the relevant config:

NEXUS:

interface loopback0
  ip address 172.25.32.11/32

router bgp 65432
  router-id 172.25.32.11
  log-neighbor-changes
  address-family ipv4 unicast
  neighbor 172.25.32.10
    remote-as 65432
    update-source loopback0
    address-family ipv4 unicast
      send-community extended
    address-family vpnv4 unicast
      send-community extended
  vrf vrf_bruker
    address-family ipv4 unicast
      network 172.22.5.30/32
    neighbor 172.22.5.26 remote-as 65103
      address-family ipv4 unicast

ip route 172.25.32.10/32 172.22.5.6


interface Ethernet6/1
  mpls ip
  mtu 8092
  ip address 172.22.5.5/30
  no shutdown


6500:
!
interface Loopback1
ip address 172.25.32.10 255.255.255.255
no ip redirects
!
interface Gig3/1
mpls ip
mtu 8092
ip address 172.22.5.6/30

router bgp 65432
bgp router-id 172.25.32.10
bgp log-neighbor-changes
neighbor 172.25.32.11 remote-as 65432
neighbor 172.25.32.11 update-source Loopback1

address-family ipv4
  neighbor 172.25.32.11 activate
  neighbor 172.25.32.11 send-community extended
  no auto-summary
  no synchronization
exit-address-family

address-family vpnv4
  neighbor 172.25.32.11 activate
  neighbor 172.25.32.11 send-community extended
   exit-address-family
!

ip route 172.25.32.11 255.255.255.255 172.22.5.5

2284
Views
0
Helpful
8
Replies
CreatePlease to create content