Cisco Support Community
Community Member

Can't connect sites in MPLS

Have a 4 site MPLS with provider-managed CE routers. Final configuration will be Internet provided to all sites through HQ, along with VoIP at all sites. Currently between HQ and RS1 is a p2p T1.

Was told by provider that all I'll need to do is connect the MPLS router to my core switch which didn't work. For now, just trying to get RS3 and RS4 up on MPLS. When they connect their network to their MPLS router nothing happens. I have the swtich at their location set to the MPLS router as the gateway. If I add an ip route to their network across the HQ MPLS router doesn't do anything.

Attached is my core switch config. I have the MPLS router connected to FE0/3.

Am I way off base or out of my leauge or what?


Hall of Fame Super Silver

Re: Can't connect sites in MPLS

Hello Ben,

if this is a L3 VPN MPLS service you need to configure f0/3 as a routed port

int f0/3

no switchport

ip address x.x.x.2


ip route x.x.x.1

or at least use a an SVI + an access port not a trunk port

Hope to help


Community Member

Re: Can't connect sites in MPLS

Thanks! Couldn't configure it with an IP (or at least the one I tried), and aren't sure what you meant by SVI. But, I changed the port from trunk to access and it worked. Now it's:


description AT&T MPLS

switchport access vlan 100

switchport mode dynamic desirable

switchport voice vlan 200

no ip address

spanning-tree portfast

And it's working for at least the data side of things. Haven't tackeled voice yet, but will this configuration be right for voice?

Hall of Fame Super Silver

Re: Can't connect sites in MPLS

Hello Ben,

you probably had a native vlan mismatch.

I don't think it is fine for voice too, because your current config is good for connecting to a VoIP phone to connect to the MPLS service you need a trunk to carry both vlans

Check with the service provider stuff how to configure.

SVI is for a VLAN layer 3 interface like vlan100.

Hope to help


CreatePlease to create content