Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can't find the problem

this is a topology that i'm working on, i'm trying to implement mpls on gns3 but finally i can't ping the destination router, please help me

Sans titre.jpg

my router's configuration :

CE1A, CE1B, CE2A, CE2B, CE3A, CE3B : (same configuration on all custumer routers, only addresses change)

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Serial0/0

ip address 10.1.1.1 255.255.255.252

serial restart-delay 0

clock rate 64000

!

router rip

version 2

network 1.0.0.0

network 10.0.0.0

no auto-summary

!

ip http server

no ip http secure-server

!

PE1, PE2, PE3 (same configuration on all PEs routers, only addresses change)

!

ip cef

!

!

ip vrf cust_a

rd 100:100

route-target export 100:100

route-target import 100:100

!

ip vrf cust_b

rd 100:200

route-target export 100:200

route-target import 100:200

!

!

interface Loopback0

ip address 172.16.1.1 255.255.255.255

!

interface Serial0/0

ip vrf forwarding cust_b

ip address 10.1.1.2 255.255.255.252

serial restart-delay 0

clock rate 64000

!

interface Serial0/1

ip vrf forwarding cust_a

ip address 10.1.1.2 255.255.255.252

serial restart-delay 0

clock rate 64000

!

interface Serial0/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial0/3

no ip address

shutdown

serial restart-delay 0

!

interface FastEthernet2/0

ip address 192.168.1.1 255.255.255.252

duplex auto

speed auto

mpls label protocol ldp

mpls ip

mpls mtu 1512

!

router ospf 1

log-adjacency-changes

network 172.16.1.1 0.0.0.0 area 0

network 192.168.1.0 0.0.0.3 area 0

!

router rip

!

address-family ipv4 vrf cust_b

  redistribute bgp 1

  network 10.0.0.0

  no auto-summary

  version 2

exit-address-family

!

address-family ipv4 vrf cust_a

  redistribute bgp 1

  network 10.0.0.0

  no auto-summary

  version 2

exit-address-family

!

router bgp 1

no synchronization

bgp log-neighbor-changes

neighbor 172.16.1.2 remote-as 1

neighbor 172.16.1.2 update-source Loopback0

neighbor 172.16.1.3 remote-as 1

neighbor 172.16.1.3 update-source Loopback0

no auto-summary

!

address-family vpnv4

  neighbor 172.16.1.2 activate

  neighbor 172.16.1.2 send-community extended

  neighbor 172.16.1.3 activate

  neighbor 172.16.1.3 send-community extended

exit-address-family

!

address-family ipv4 vrf cust_b

  redistribute rip

  no synchronization

exit-address-family

!

address-family ipv4 vrf cust_a

  redistribute rip

  no synchronization

exit-address-family

!

ip http server

no ip http secure-server

!

!

control-plane

!

P router

ip cef

!

!

interface FastEthernet0/0

ip address 192.168.1.6 255.255.255.252

duplex auto

speed auto

mpls label protocol ldp

mpls ip

mpls mtu 1512

!

interface FastEthernet1/0

ip address 192.168.1.9 255.255.255.252

duplex auto

speed auto

mpls label protocol ldp

mpls ip

mpls mtu 1512

!

interface FastEthernet2/0

ip address 192.168.1.2 255.255.255.252

duplex auto

speed auto

mpls label protocol ldp

mpls ip

mpls mtu 1512

!

interface FastEthernet3/0

no ip address

shutdown

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

network 192.168.1.0 0.0.0.3 area 0

network 192.168.1.4 0.0.0.3 area 0

network 192.168.1.8 0.0.0.3 area 0

!

ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

!

regards !

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Can't find the problem

Hello Mohamed,

Can you please confirm what you are unable to ping? CE-CE? Is PE-PE pingable (both vrf and LSP)?

If CE-CE is not pinging (but LSP is up and PE-PE vrf routes are pinging) then try this on PE:

router rip

!

address-family ipv4 vrf cust_b

  redistribute bgp 1 >>>>

  network 10.0.0.0

  no auto-summary

  version 2

exit-address-family

Regards,

Imran

Re: Can't find the problem

I agree with Imran (+5): Setting a seed-metric for the bgp-to-rip redistribution should fix the problem.

Alternatively you can use the metric transparent option:

PE_2(config-router-af)#redistribute bgp 1

RIP: received v2 update from 10.1.1.1 on Serial0/0

     10.255.2.0/24 via 0.0.0.0 in 16 hops  (inaccessible)

PE_2(config-router-af)#redistribute bgp 1 metric transparent

RIP: sending v2 update to 224.0.0.9 via Loopback1 (10.255.1.1)

RIP: build update entries

        10.255.2.0/24 via 0.0.0.0, metric 1, tag 0

Defining a seed-metric is important when the IGP is RIP or EIGRP.

Regards,

Rolf

4 REPLIES
Cisco Employee

Can't find the problem

Hello Mohamed,

Can you please confirm what you are unable to ping? CE-CE? Is PE-PE pingable (both vrf and LSP)?

If CE-CE is not pinging (but LSP is up and PE-PE vrf routes are pinging) then try this on PE:

router rip

!

address-family ipv4 vrf cust_b

  redistribute bgp 1 >>>>

  network 10.0.0.0

  no auto-summary

  version 2

exit-address-family

Regards,

Imran

Re: Can't find the problem

I agree with Imran (+5): Setting a seed-metric for the bgp-to-rip redistribution should fix the problem.

Alternatively you can use the metric transparent option:

PE_2(config-router-af)#redistribute bgp 1

RIP: received v2 update from 10.1.1.1 on Serial0/0

     10.255.2.0/24 via 0.0.0.0 in 16 hops  (inaccessible)

PE_2(config-router-af)#redistribute bgp 1 metric transparent

RIP: sending v2 update to 224.0.0.9 via Loopback1 (10.255.1.1)

RIP: build update entries

        10.255.2.0/24 via 0.0.0.0, metric 1, tag 0

Defining a seed-metric is important when the IGP is RIP or EIGRP.

Regards,

Rolf

New Member

Can't find the problem

Thank you Imran and Rolf, it works for me now.

Regards,

Mohamed

Cisco Employee

Can't find the problem

Thanks Rolf! :-)

Mohamed, I am glad issue is resolved now.

Regards,

Imran

281
Views
10
Helpful
4
Replies