Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Can't ISIS and OSPF v4 and v6 coexist?.

Hi All,

          I have a core network with four routers (R2,R7,R8 and R9). These routers must all run ISIS ipv4 and ipv6 on all their connected interfaces including the loopkbacks. This i achived without any hassle, (see the config and the routing table below).

The same four routers must also run OSPF v2 and v3, unfortunately once the OSPF is deployed, i can no longer see the ISIS routes, both for v4 and v6. Any idea what i might be doing wrong?. Please do study my configs well before response, as address-family ipv6 and multi-topology are in the right places. The configs seen here are the same on teh remaining router.

R2#sr int lo0

Building configuration...

Current configuration : 159 bytes

!

interface Loopback0

ip address 2.2.0.2 255.255.255.255

ip router isis 2789

ipv6 address 2002:2:2::2/128

ipv6 router isis 2789

ipv6 ospf 300 area 0

end

R2#sr int g0/0

Building configuration...

Current configuration : 229 bytes

!

interface GigabitEthernet0/0

ip address 2.2.29.2 255.255.255.0

ip router isis 2789

duplex full

speed 1000

media-type gbic

negotiation auto

ipv6 address 2002:2:2:29::2/64

ipv6 router isis 2789

ipv6 ospf 300 area 0

end

R2#sr int g1/0

Building configuration...

Current configuration : 187 bytes

!

interface GigabitEthernet1/0

ip address 2.2.28.2 255.255.255.0

ip router isis 2789

negotiation auto

ipv6 address 2002:2:2:28::2/64

ipv6 router isis 2789

ipv6 ospf 300 area 0

end

R2#sr int g2/0

Building configuration...

Current configuration : 187 bytes

!

interface GigabitEthernet2/0

ip address 2.2.27.2 255.255.255.0

ip router isis 2789

negotiation auto

ipv6 address 2002:2:2:27::2/64

ipv6 router isis 2789

ipv6 ospf 300 area 0

end

R2#

R2#sh isis dat

IS-IS Level-1 Link State Database:

LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL

R2.00-00            * 0x00000009   0x2CE7        1119              0/0/0

R7.00-00              0x00000008   0x4FA2        1111              0/0/0

R7.02-00              0x00000001   0x76C0        1063              0/0/0

R8.00-00              0x00000005   0x9C04        1101              0/0/0

R8.02-00              0x00000001   0x77BD        1094              0/0/0

R8.03-00              0x00000001   0xD45A        1098              0/0/0

R9.00-00              0x00000007   0x414F        1121              0/0/0

R9.02-00              0x00000001   0xDC51        1111              0/0/0

R9.03-00              0x00000001   0x71C0        1118              0/0/0

R2#

R2#sir isis

     2.0.0.0/8 is variably subnetted, 9 subnets, 2 masks

i L1    2.2.0.7/32 [115/20] via 2.2.27.7, GigabitEthernet2/0

i L1    2.2.0.8/32 [115/20] via 2.2.28.8, GigabitEthernet1/0

i L1    2.2.0.9/32 [115/20] via 2.2.29.9, GigabitEthernet0/0

i L1    2.2.78.0/24 [115/20] via 2.2.28.8, GigabitEthernet1/0

                    [115/20] via 2.2.27.7, GigabitEthernet2/0

i L1    2.2.79.0/24 [115/20] via 2.2.29.9, GigabitEthernet0/0

                    [115/20] via 2.2.27.7, GigabitEthernet2/0

R2#

R2#

R2#sh ipv6 route  isis

IPv6 Routing Table - Default - 13 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1

       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP

       EX - EIGRP external

       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

I1  2002:2:2::7/128 [115/20]

     via FE80::C811:15FF:FE78:8, GigabitEthernet2/0

I1  2002:2:2::8/128 [115/20]

     via FE80::C812:15FF:FE78:8, GigabitEthernet1/0

I1  2002:2:2::9/128 [115/20]

     via FE80::C813:FFF:FE0C:1C, GigabitEthernet0/0

I1  2002:2:2:78::/64 [115/20]

     via FE80::C811:15FF:FE78:8, GigabitEthernet2/0

     via FE80::C812:15FF:FE78:8, GigabitEthernet1/0

I1  2002:2:2:79::/64 [115/20]

     via FE80::C811:15FF:FE78:8, GigabitEthernet2/0

     via FE80::C813:FFF:FE0C:1C, GigabitEthernet0/0

R2#

R2#

R2#sr | sec router isis

ip router isis 2789

ipv6 router isis 2789

ip router isis 2789

ipv6 router isis 2789

ip router isis 2789

ipv6 router isis 2789

ip router isis 2789

ipv6 router isis 2789

router isis 2789

net 47.0002.0000.0000.0002.00

is-type level-1

metric-style wide

!

address-family ipv6

  multi-topology

exit-address-family

R2#sh clns nei

System Id      Interface   SNPA                State  Holdtime  Type Protocol

R9             Gi0/0       ca13.0f0c.001c      Up     8         L1   M-ISIS

R8             Gi1/0       ca12.1578.0008      Up     8         L1   M-ISIS

R7             Gi2/0       ca11.1578.0008      Up     9         L1   M-ISIS

R2#

R2#sr | sec router ospf

router ospf 200

log-adjacency-changes

network 2.2.0.0 0.0.255.255 area 0

ipv6 router ospf 300

router-id 2.2.0.2

log-adjacency-changes

R2#

Now i can only see OSPF v2 and v3 BUT ISIS is no longer seen.!!!

==============================================

R2#sir ospf

     2.0.0.0/8 is variably subnetted, 10 subnets, 2 masks

O       2.2.0.7/32 [110/2] via 2.2.27.7, 00:55:39, GigabitEthernet2/0

O       2.2.0.8/32 [110/2] via 2.2.28.8, 00:55:29, GigabitEthernet1/0

O       2.2.0.9/32 [110/2] via 2.2.29.9, 00:55:49, GigabitEthernet0/0

O       2.2.69.0/24 [110/2] via 2.2.29.9, 00:55:49, GigabitEthernet0/0

O       2.2.78.0/24 [110/2] via 2.2.28.8, 00:55:29, GigabitEthernet1/0

                    [110/2] via 2.2.27.7, 00:55:29, GigabitEthernet2/0

O       2.2.79.0/24 [110/2] via 2.2.29.9, 00:55:49, GigabitEthernet0/0

                    [110/2] via 2.2.27.7, 00:55:09, GigabitEthernet2/0

R2#

R2#sh ipv6 route  ospf

IPv6 Routing Table - Default - 13 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1

       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP

       EX - EIGRP external

       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

O   2002:2:2::7/128 [110/1]

     via FE80::C811:15FF:FE78:8, GigabitEthernet2/0

O   2002:2:2::8/128 [110/1]

     via FE80::C812:15FF:FE78:8, GigabitEthernet1/0

O   2002:2:2::9/128 [110/1]

     via FE80::C813:FFF:FE0C:1C, GigabitEthernet0/0

O   2002:2:2:78::/64 [110/2]

     via FE80::C812:15FF:FE78:8, GigabitEthernet1/0

     via FE80::C811:15FF:FE78:8, GigabitEthernet2/0

O   2002:2:2:79::/64 [110/2]

     via FE80::C813:FFF:FE0C:1C, GigabitEthernet0/0

     via FE80::C811:15FF:FE78:8, GigabitEthernet2/0

R2#

Please do let me know if further info is required to help you help me?.

Thanking you all in advance for your help,

O.A

3 REPLIES

Can't ISIS and OSPF v4 and v6 coexist?.

Hi O.A,

nice to see you managed to get ISIS v6 running, the reason for the current behavior is that OSPF has better AD, so once two protocols announce the same route/prefix, the one with better AD secures its place in the RIB.

New Member

Can't ISIS and OSPF v4 and v6 coexist?.

Hi Ivan,

           Your answer was super!!!!!! (i was laughing when i saw your reply), unknown to me i was struggling with configs not knowing it was only the AD issue. Now i have partly resolved the problem by increasing the OSPF Distance to 200 but what will be the solution if i want the two routing protocols in my RIB?. CIsco got it done without increasing any cost....."CCIE SP Sample LAB" by Vincent Zhou" SP PM.

I am sure you can grab a copy of his note to see that he never increased any cost, yet got the job done.....

Looking forward to your swift response as usual

O.A

Can't ISIS and OSPF v4 and v6 coexist?.

Hi O.A.,

i checked the docs available at https://learningnetwork.cisco.com/people/zhoujl?view=overview

there are two independent examples for OSPF and ISIS and no more than that.

You can have both(if not all) IGPs at the same time in the RIB, the only thing that needs to be accounted is that they will appear for different prefixes only, as soon as there is a tie between IGPs for the same prefix, the one with better AD will win and appear in the RIB. All other will kick in in case primary IGP will fail, but this is unlikely since the physical topology is the same and hence all other IGP will see that prefix as withdrawn.

967
Views
0
Helpful
3
Replies