Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CESoPSN (TDM) Pseudowire over MPLS via GRE Tunnel

I have two MWR2941's seperated by several routed hops in a non MPLS enabled core. I have a GPRS toycell on one side and a BSC on the other (this is not important) and need to configure an E1 CESoPSN (or SAToP -- I don't care) pseudowire. I realize that I need a GRE tunnel between the two MWR's in order to get MPLS to work properly. I have the GRE tunnel configured and the pseudowire is up, but I can only get one-way traffic on the CEM interface, even though the physical interface shows two-way traffic. The configs are fairly plain. Here is the BSC side -- the toycell side is identical with the IP addresses changed:

mpls label protocol ldp
xconnect logging pseudowire status
!
controller E1 0/0
clock source internal
cem-group 0 timeslots 1-31

pseudowire-class MPLS_EXP
encapsulation mpls
mpls experimental 5

interface Loopback0
ip address 172.21.0.65 255.255.255.255
!        
interface Tunnel10
ip unnumbered Loopback0
mpls ip
tunnel source Vlan306
tunnel destination 10.178.3.37
!        
interface GigabitEthernet0/0
switchport access vlan 306
switchport mode access

interface CEM0/0
no ip address
cem 0
  xconnect 172.25.112.1 360 encapsulation mpls pw-class MPLS_EXP

interface Vlan306
ip address 172.21.0.50 255.255.255.252
no ptp enable

ip route 0.0.0.0 0.0.0.0 172.21.0.49
ip route 172.25.112.1 255.255.255.255 Tunnel10

I have tried everything that I can think of. I can only guess that it is an MTU issue. I havce tried PMTUD and TCP MSS with no luck. Any help would be appreciated greatly.

thanks,

Paul

Everyone's tags (6)
1 REPLY
New Member

CESoPSN (TDM) Pseudowire over MPLS via GRE Tunnel

And..... it turns out that the problem was related to IOS rev. I rolled back from 15-1.3 to 15-1.1 and everything works.

670
Views
0
Helpful
1
Replies
CreatePlease to create content