Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuring CE Router for eBGP

Hi,

I'm configuring a CE router to connect to a PE router using eBGP as the PE-CE routing protocol. The site is a stub site. The LAN addresses are subnetted from the summary 10.1.0.0/16. The CE config as follows:

!

interface Serial0/0

description *** Connection to MPLS PE Router ***

ip address 1.1.1.2 255.255.255.252

!

interface Vlan10

description *** User Segment 1 ***

ip address 10.1.10.1 255.255.255.0

!

interface Vlan20

description *** User Segment 2 ***

ip address 10.1.20.1 255.255.255.0

!

interface Vlan30

description *** User Segment 3 ***

ip address 10.1.30.1 255.255.255.0

!

.

.

!

router bgp 64512

neighbor 1.1.1.1 description *** MPLS PE Router Peer ***

neighbor 1.1.1.1 remote-as 100

redistribute connected

no synchronization

no auto-summary

!

Alternatively, I'd configure as follows:

!

ip route 10.1.0.0 255.255.0.0 Null0

!

router bgp 64512

neighbor 1.1.1.1 description *** MPLS PE Router Peer ***

neighbor 1.1.1.1 remote-as 100

network 10.1.0.0 netmask 255.255.0.0

no synchronization

no auto-summary

!

Which of the above methods of configuration is more recommended as per best practices?

Please advise.

Thank you.

B.Rgds,

Lim TS

1 REPLY

Re: Configuring CE Router for eBGP

Hi,

As a best practice , static advertisement of subnets with a network and matching route ( a null route with 254 metric ) would always be used .

But it depends on the scenarios

1.If you consider a ISP , he might have subnetted a /24 and given to many customers , so he would not have a matching /24 route , so he would advertise with static advertisments.

2.ISP might have multiple /24 routes in the routing table , but in case of any igp fluctuation would result in bgp routes getting advertised and retreived from internet and may result in bgp dampening , so a static advertisement would not disturb the bgp advertisements eventhough you have a igp fluctuation

In your case , you can go for any method ,

1.Advertisement of the subnet depends on your status of the vlan

2.Advertisment of route happens eventhough any one of your vlan is down and traffic would come and drop in your router .

Hope this helps

regards

vanesh k

115
Views
0
Helpful
1
Replies