Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuring LSP

Hi All,

     I need to know the set of commands which are needed to create new LSP in Cisco Router.

I  tried searching other docs available on Cisco Support forums, and came  across the below set of commands, please help me know if these are  correct and sufficient .

Also please guide me to know commands needed to create Explicit Path LSP.

switch# configure terminal

switch(config)#

switch(config)# feature mpls traffic-engineering

switch# configure terminal

switch(config)#

switch(config)# feature isis

switch(config)# router isis 200

switch(config-router)#

switch(config-router)# mpls traffic-eng level-1

switch(config-router)# mpls traffic-eng router-id loopback0

switch# configure terminal

switch(config)#

switch(config)# feature ospf

switch(config)# router ospf 200

switch(config-router)#

switch(config-router)# mpls traffic-eng area 1

switch(config-router)# mpls traffic-eng router-id loopback0

switch# configure terminal

switch(config)#

switch(config)# interface ethernet 2/1

switch(config-if)#

switch(config-if)# mpls traffic-eng tunnels

switch(config-if)# mpls traffic-eng bandwidth 1000

switch(config-if)# no shut

switch# configure terminal

switch(config)#

switch(config)# interface tunnel-te 1

switch(config-if-te)#

switch(config-if-te)# ip unnumbered loopback 0

switch(config-if-te)# destination 10.3.3.3

switch(config-if-te)# path-option 10 explicit name Link5

switch(config-if-te)# no shutdown

switch# configure terminal

switch(config)#

switch(config)# mpls traffic-eng configuration

switch(config-te)#

switch(config-te)# explicit-path name Link5

switch(config-te-expl-path)# index 10 next-address 10.3.3.3

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Re: Configuring LSP

Hello Ayush,

To form the LSP using MPLS Traffic Engineering, folowing is the checklist:

++ CEF should be enabled on all the routers

config t

ip cef

++ Loopback should be configured on the routers (which will also be used as router-id)

++ End to end loopback reachability should be fine via ISIS or ospf

++ "mpls traffic-eng tunnel" should be configured globally

++ "mpls traffic-eng tunnel" and "ip rsvp bandwidth" should be configured under all the core interfaces. By default rsvp reserves 75% bandwidth

++ mpls traffic-engineering should be configured under the ospf or isis process (as seen in the output of your question)

switch(config)# router ospf 200

switch(config-router)#

switch(config-router)# mpls traffic-eng area x

switch(config-router)# mpls traffic-eng router-id loopback0

++ Configure the explicit path on 2 end points

Suppose you have 3 routers:

A---------B---------C

so the config on A will be:

ip explicit-path name ABC

next-address

next-address

next-address

Similarly, configure the explicit path on C in reverse direction.

++ Finally, configure the tunnel on 2 end points.

config t

int tunnel x

ip unnumbered loop0

tunnel mode mpls traffic-eng

tunnel destination x.x.x.x >> This is the loopback IP of remote end

tunnel mpls traffic-eng path-option 1 explicit name abc

After this, it is upto you if you want to send the traffic on this tunnel via this options:

1. static

2. PBR

3. Autoroute Announce

4. Forwarding Adjacency

5. Load Sharing

6. Automatic Bandwidth Adjustment

Seems like the command line you used above is for Nexus (NX-OS). I have explained it for IOS.

Hope This Helps!!

Regards,

Imran

Cisco Employee

Re: Configuring LSP

Hello Ayush,

You need to configure the LSP in each direction as LSP is unidirectional. I have provided details of only 1 side.

Regards,

Imran

11 REPLIES
Cisco Employee

Re: Configuring LSP

Hello Ayush,

To form the LSP using MPLS Traffic Engineering, folowing is the checklist:

++ CEF should be enabled on all the routers

config t

ip cef

++ Loopback should be configured on the routers (which will also be used as router-id)

++ End to end loopback reachability should be fine via ISIS or ospf

++ "mpls traffic-eng tunnel" should be configured globally

++ "mpls traffic-eng tunnel" and "ip rsvp bandwidth" should be configured under all the core interfaces. By default rsvp reserves 75% bandwidth

++ mpls traffic-engineering should be configured under the ospf or isis process (as seen in the output of your question)

switch(config)# router ospf 200

switch(config-router)#

switch(config-router)# mpls traffic-eng area x

switch(config-router)# mpls traffic-eng router-id loopback0

++ Configure the explicit path on 2 end points

Suppose you have 3 routers:

A---------B---------C

so the config on A will be:

ip explicit-path name ABC

next-address

next-address

next-address

Similarly, configure the explicit path on C in reverse direction.

++ Finally, configure the tunnel on 2 end points.

config t

int tunnel x

ip unnumbered loop0

tunnel mode mpls traffic-eng

tunnel destination x.x.x.x >> This is the loopback IP of remote end

tunnel mpls traffic-eng path-option 1 explicit name abc

After this, it is upto you if you want to send the traffic on this tunnel via this options:

1. static

2. PBR

3. Autoroute Announce

4. Forwarding Adjacency

5. Load Sharing

6. Automatic Bandwidth Adjustment

Seems like the command line you used above is for Nexus (NX-OS). I have explained it for IOS.

Hope This Helps!!

Regards,

Imran

New Member

Configuring LSP

Similarly, configure the explicit path on C in reverse direction.

++ Finally, configure the tunnel on 2 end points.

     This is for configuring another LSP from C to A. As LSP are unidirectional , we need to provide one side details alone. Am I right here ?

Cisco Employee

Re: Configuring LSP

Hello Ayush,

You need to configure the LSP in each direction as LSP is unidirectional. I have provided details of only 1 side.

Regards,

Imran

New Member

Configuring LSP

Thank you Imran, Do you have any idea, which SNMP Mibs exposes these (LSP) information ?

Cisco Employee

Re: Configuring LSP

Hello Ayush,

I am sorry. I really dont have any much idea about the SNMP MIBs. But, just in case, you can see some details here:

http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/te_mib17.html

Regards,

Imran

New Member

Re: Configuring LSP

Does the above commands are IOS dependand. or they can be used for latest/other IOS Version too.

Cisco Employee

Re: Configuring LSP

Hello Ayush,

The command line that I have mentioned is for IOS, can be used under any latest IOS only.

For IOS-XR and NX-OS, command line is slightly different.

Regards,

Imran

New Member

Re: Configuring LSP

Hi Imran,

As per my understanding, the LDP protocol such as RSVP or BGP generate the the label and distribute it to other routers. Hence the database gets updated at each Router about the mapping between incoming label and the respective outgoing label.

This has create a way (path) to take the incoming packet to final destinaltion with the help of label, created during LDP session created between two router. Hence the path is availble, and below are my questions:

1. when the path is been derived with the help of Label, why we need to create LSP.

2. Does this path is know as promary path, and with LSP we need to create secondry/backup path

3. Label are associated with each interface, hence when a VPN service is created in PE, we need it to associated with all the interfaces configured with ldp ?

Thanks,

Ayush

New Member

Re: Configuring LSP

I have got answer to some of the question I have asked.

1. Since the Label Forwarding table is created in each Hop, which have the label entries for all incoming and respective outgoing packets. So the label is across all the routers, and to know which hop it need to select, it is decided by RSVP dynamic protocol. RSVP is the one whcih establlish the LSP and maintain it.

2. LSP are unidirectional and are create from source to destinaltion. If there is another secondary LSP is created as a backup, which comes in effect, when ever there is issue in primary LSP. the fastReroute will swtich the traffic to backup LSP.

Cisco Employee

Re: Configuring LSP

Hello Ayush,

sorry for the delay I was on leave.

3.  Label are associated with each interface, hence when a VPN service is   created in PE, we need it to associated with all the interfaces   configured with ldp ?

>> You do not need to enable the ldp on core interfaces if you are running mpls TE.

Using its signaling element, RSVP-TE sets up an LSP end-to-end  (ingress-to-egress). So label distribution is coordinated among all the  LSRs along a path. LDP, on the other hand, has no signaling element. It sets up LSPs hop-by-hop, and labels can be distributed between neighbors independently of what other LSRs along the path are

doing. Because it has no signaling element, LDP depends on the  network's IGP to determine the path an LSP must take, whereas RSVP-TE  can set up paths independently of what the IGP determines to be the  optimal path to a destination - hence the Traffic Engineering part of  the protocol.

When you use the TE tunnel  starting from PE, make sure to use "autoroute announce". This will make  sure that the outgoing interface is tunnel. Since the outgoing interface  is tunnel, mpls should be enabled on it, so use "mpls ip" on tunnel.

int tunnel x

tunnel mpls traffic-eng autoroute announce

mpls ip

end

HTH,

Imran

New Member

Re: Configuring LSP

Thank you Imran .

I have tried looking all the MIB's to find the appropriate OIDs which can get me

1. LSP/Tunnel configured on P routers. (Please correct me, the LSP are configured in Provider routers, not in PE)

2. Interfaces which are assocuated with each VPN (VRF) in PE.

If you can help me to find these, it will be great help to me.

Thanks,

Ayush

1017
Views
0
Helpful
11
Replies