Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DHCP with vrf

Hi

I need to allocate ip addresses to clients connected to different VRFs. I have allocated the DHCP pool to respective VRF but no success. Can somebody let me know if I am missing something

ip vrf green

rd 1:1

!

ip vrf blue

rd 1:2

ip dhcp pool green

vrf green

network 192.168.1.0 255.255.255.0

!

ip dhcp pool blue

vrf blue

network 192.168.2.0 255.255.255.0

!

interface FastEthernet3/0

no ip address

duplex auto

speed auto

!

interface FastEthernet3/0.100

encapsulation dot1Q 100

ip vrf forwarding green

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet3/0.200

encapsulation dot1Q 200

ip vrf forwarding blue

ip address 192.168.2.1 255.255.255.0

!

Also I need to exclude some ip addresses from the range, but I believe this feature is not supported.

Could someone please guide me on this

1 REPLY
New Member

Re: DHCP with vrf

You will need to add the following line to your configuration:

ip dhcp use vrf connected

In regards to excluded addresses, you're correct. To my knowledge Cisco has yet to release an IOS which overcomes this issue.

If you use vrf's with DHCP it ignores the ip dhcp excluded-address. It further prevents you from assigning static IP's based on MAC addresses.

Please also note that using the vrf command will mean the first assigned IP is normally .1, unless your router is using this address.

Hope this helps clear things up.

465
Views
0
Helpful
1
Replies
CreatePlease to create content