Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Display Exp value in an MPLS cloud

Hi,

Is there a specific command that display's the Exp-value of packets while traveling an MPLS network ?

I want to show that voice-traffic which is marked at the edge with ToS=5 will keep it's Exp (5) while traveling to it's destination.

Best regards,

Peter

10 REPLIES
Bronze

Re: Display Exp value in an MPLS cloud

mpls accounting experimental input

configure the above on the interfaces you are interested in (btw you can also do output). Then to see what is flowing do

show int pos3/0(for example) mpls-exp

HTH

New Member

Re: Display Exp value in an MPLS cloud

Hi Robert,

I tried the command given by you in both in/out direction but its not showing any thing,

but the fact is i am generating ingress traffic with prec-bit 4 and is being carried over my mpls core as mpls-exp bit 4 traffic ( i can see the same in outgoing-core facing que )

You can see in below output that traffic is there in MPLS exp bit 4 class also ..

Class-map: Multimedia (match-any)

10393 packets, 15563834 bytes

30 second offered rate 40000 bps, drop rate 0 bps

Match: mpls experimental topmost 3 4

Match: ip precedence 3 4

Queueing

queue limit 16384 (packets)

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts queued/bytes queued) 10393/15563834

bandwidth remaining 53% (397500 kbps)

(bandwidth parameter is rounded to 396078 kbps due to granularity)

Exp-weight-constant: 13 (1/8192)

Mean queue depth: 0

class Transmitted Random drop Tail drop Minimum Maximum Mark

pkts/bytes pkts/bytes pkts/bytes thresh thresh prob

0 0/0 0/0 0/0 0 0 1/10

1 0/0 0/0 0/0 0 0 1/10

2 0/0 0/0 0/0 0 0 1/10

3 594/893208 0/0 0/0 32 52 1/1

4 9799/14670626 0/0 0/0 39 58 1/1

5 0/0 0/0 0/0 0 0 1/10

6 0/0 0/0 0/0 0 0 1/10

7 0/0 0/0 0/0 0 0 1/10

Other way i tried confirming the same was using access list on the egress interface to see whether my mpls-exp bits ( as set ) are being copied into prec bits on the egress direction towards custwomer.

ACL config was as below

Extended IP access list 102

10 permit ip any any precedence flash log (3719 matches)

20 permit ip any any precedence flash-override log (368228 matches)

30 permit ip any any precedence immediate log

40 permit ip any any precedence priority log

50 permit ip any any (2002 matches)

peter, i hope this helps u too.. you can modify acl with appropriate source-destinaiton ip to see if your class is getting matched or not..

hope it helps ...

raj

New Member

Re: Display Exp value in an MPLS cloud

Hi,

I'm using vlan-based qos on interface vlan30, which marks all TDMoIP-data with IPP=5. Interface vlan30 is part of vrf VOIP-netwerk. This trafic should be forwarded in a high-priority queue of Gigabit2/2 (WS-X6516-GBIC) of this 6509. This value should remain unused while traveling over the MPLS-cloud.

The command you suggest doesn't include any mpls-exp 5 values. Is my config correct ?

Is it correct that the PFC3B on the sup-720 internaly maps precedence 5 to dscp 5 and then automaticaly maps dscp 5 to exp 5 or do I have to configure more ?

This is my configuration:

class-map match-all TOS30-5

match access-group name TOS30-5

!

policy-map QOS-IN-30

class TOS30-5

set precedence 5

!

ip access-list extended TOS30-5

permit ip 10.2.240.0 0.0.0.255 10.1.240.0 0.0.0.255

!

interface Vlan30

ip vrf forwarding VOIP-netwerk

ip address 10.2.240.2 255.255.255.0

service-policy input QOS-IN-30

!

interface GigabitEthernet2/2

description FO-RING -> COREIBVST002

bandwidth 1000000

ip address 10.254.3.134 255.255.255.252

logging event link-status

udld port

mpls accounting experimental input

mpls accounting experimental output

tag-switching mtu 1600

tag-switching ip

!

Re: Display Exp value in an MPLS cloud

Hello,

that should do it, you could still add:

policy-map QOS-IN-30

class TOS30-5

set precedence 5

set mpls experimental 5

This will visualize the behaviour you would like to have to your operation people and you do not need to rely on default behaviour in the IOS.

The other question I would have is: what is the access-list TOS30-5 doing. Make sure it grabs the desired traffic. In case there are problems NBAR would be an alternative (like "match protocol rtp audio").

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Display Exp value in an MPLS cloud

Hi Martin,

Thanks for your input. The access-list TOS30-5 grabs traffic sourced from the local vlan 30 (10.2.240.0/24)

to it's destination (10.1.240.0/24). Both subnets host the TDMoIP multiplexers for the transmission of a 2MB DPNSS connecion between two Phillips PBX-es in IP. This traffic will have to be marked with ToS=5, Exp=5 when it enters the MPLS VPN and remain unchanged as it travels to it's destination. All other traffic wil not be marked (ToS=0).

The problem no is that I would like to see packets marked with mpls exp. 5. But the commands I used do not show any packets marked with exp.5.......

int gig2/2

mpls accounting experimental input

mpls accounting experimental output

show int gig2/2 mpls-exp

ip access-list extended TOS30-5

permit ip 10.2.240.0 0.0.0.255 10.1.240.0 0.0.0.255

Re: Display Exp value in an MPLS cloud

Well,

afaik the most easy check would be to use a policy-map with only class class-default and WFQ with WRED (fair-queue, random-detect). This policy would cound all packets with different markings. You used this already in a specific class and saw exp 3+4.

In the default class you could then easily check the proper marking of the voip traffic.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Display Exp value in an MPLS cloud

Hi Martin,

set mpls experimental 5 is not supported on vlan interface 30 but with ip accounting precedence input / output configured on it I can see matched packets coming from the set precedence 5 statement.

But I still cannot see if this precedence value is automaticically converted to mpls-exp on the outgoing tag-switching interface.

Show policy-map int vlan 30 shows this:

Vlan30

Service-policy input: QOS-IN-30

class-map: TOS30-5 (match-all)

Match: access-group name TOS30-5

set precedence 5:

Earl in slot 5 :

1527101524 bytes

5 minute offered rate 2403720 bps

aggregate-forwarded 1527101524 bytes

Class-map: class-default (match-any)

70986 packets, 20269534 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

Since it is not possible to configure a class-default on interface vlan 30 (fair-queue command is not supported in input direction for this interface

Configuration failed on: Vlan30) I can't get more info out of that command.

Is it necessary to configure mls qos mapings for prec-dscp-exp or can I leave them default ?

Is it necessary to configure some queuing parameters on the outgoing tag-switching interfaces. At this moment I configured the following on all tag-switching interfaces:

interface GigabitEthernet2/2 (WS-X6516-GBIC)

bandwidth 1000000

ip address

logging event link-status

udld port

mpls accounting experimental input

mpls accounting experimental output

tag-switching mtu 1600

tag-switching ip

If I issue the command: sh queue gigabitEthernet 2/2

'Show queue' not supported with FIFO queueing.

Do you have any suggestions ?

Peter

Re: Display Exp value in an MPLS cloud

Hello Peter,

I have to admit that I have missed the part, where you stated to use VLAN based QoS.

Anyhow, are you able to configure the suggested policy-map on GE2/2 output?

In case this is impossible you could still use your VLAN service-policy and check on the next switch, whether it receives labeled packets with proper exp bits.

To get the info you could add a class TOS30-exp5

class-map match-all TOS30-exp5

match mpls experimental 5

to your policy. this should count the arriving exp5 traffic. You can then conclude, whether the labels contain the desired values. Exception would be using PHP so that only unlabeled traffic would arrive.

You could still use a similar policy on a transit switch.

Hope this helps!

Regards, Martin

New Member

Re: Display Exp value in an MPLS cloud

Hi Martin,

I'm not able to configure a service-policy on Gig2/2 of module WS-X6516-GBIC that set's anything. If I don't set anything, I can see no matching packets also.

I now configured this:

class-map match-any TOS30-exp5

match precedence 5

match mpls experimental topmost 5

class-map match-all TOS30-5

match access-group name TOS30-5

!

policy-map QOS-IN-30

class TOS30-5

set precedence 5

class class-default

policy-map EXP

class TOS30-exp5

set mpls experimental topmost 5 (which is not possible on gig2/2)

!

interface Vlan30

ip vrf forwarding VOIP-netwerk

ip address

service-policy input QOS-IN-30

The marking with precedence 5 works fine. But I still can't see any mpls exp. 5 packets on the outgoing Gig2/2 tag-switching interface

int gig2/2

service-policy output EXP

set mpls exp topmost cannot be configured in output direction for this interface

Configuration failed on:

GigabitEthernet2/2

%this feature is not supported on GigabitEthernet2/2

Another strange thing is this one:

sh queue gig2/2

'Show queue' not supported with FIFO queueing.

This module should have Tx-1p2q2t queuing ??!!

I get sick of it.....

Do you have any suggestions.

Re: Display Exp value in an MPLS cloud

Hello,

just one more idea, is there any possibility to set up a SPAN/RSPAN port and simply use a packet analyzer like ethereal?

Hope this helps!

Regards, Martin

495
Views
22
Helpful
10
Replies