Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EoMPLS on campus MAN

Hello,

I have Layer-2 communication problem to solve to let 2 servers communicate over a routed core. My core and distribution switches are 6500 with sup720-3b. I figured out that the only way I could do that without having to pull a physical link in between was to use EoMPLS.

That's how it's configured

DIST_1-G1/1 <--> G1/1-CORE-G1/2 <--> G1/1-DIST_2

DIST_1 configuration:

mpls label protocol ldp

interface Loopback0

ip address 10.1.1.3 255.255.255.255

interface GigabitEthernet1/1

ip address 192.168.1.2 255.255.255.252

tag-switching ip

interface Vlan174

no ip address

mpls l2transport route 10.1.1.4 174

DIST_2 configuration:

mpls label protocol ldp

interface Loopback0

ip address 10.1.1.4 255.255.255.255

interface GigabitEthernet1/1

ip address 192.168.1.6 255.255.255.252

tag-switching ip

interface Vlan174

no ip address

mpls l2transport route 10.1.1.3 174

CORE configuration:

mpls label protocol ldp

interface GigabitEthernet1/1

ip address 192.168.1.1 255.255.255.252

tag-switching ip

interface GigabitEthernet1/2

ip address 192.168.1.5 255.255.255.252

tag-switching ip

the VLAN 174 is created on both distributions and all 3 have OSPF configured and I can ping loopbacks.

Attached are a few show commands

Can anyone tell me what is wrong with my setup?

Thanks,

Antoine

1 REPLY

Re: EoMPLS on campus MAN

Hello,

It looks as if no labels are assigned, which often is because CEF is not enabled. Can you additionally post

show ip cef 10.1.1.3

show ip cef 10.1.1.4

show mpls forwarding-table

One issue could be CEF not working correctly, but it should be enabled on the 6500 by default (Router(config)#ip cef).

Hope this helps! Please rate all posts.

Regards, Martin

120
Views
0
Helpful
1
Replies
CreatePlease to create content