Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

EOMPLS QOS help needed

Any one can guide me how to make qos in EOMPLS L2VPN. After making tunnel between two client end devices how to make QOS between each other bidirectional.how to make qos in core of mpls backbone with uniform mode. i also want the configs if possible. I think any core service provider engineer can better help me.

CE1------>PE1------>P------->PE2------->CE2(how to make qos from ce1 to ce2 and also core of mpls backbone.

Specifically i am having problem in mapping the layer 2 qos to layer 3 qos(cos to dscp and dscp to exp mapping). how to do qos mapping on CE and PE.

how to apply qos mapping on CE and PEspecifically with cos.

Waiting for replies.

11 REPLIES
Cisco Employee

EOMPLS QOS help needed

Hi Rasheed,

The default behavior for the EoMPLS is to use a value of “0” in the EXP bits of the VC and tunnel labels. Ingress packet classification can be COS or DSCP/Prec. Default behavior can be changed by using “set mpls experimental imposition ” at ingress

On the PE, you need to match packet with classification and mark it with MPLS EXP bit value, and on egress side, mark with original value.

There is a section for EoMPLS QoS on below document, you may need to go through it for detailed understanding

http://www.cisco.com/en/US/docs/switches/metro/catalyst3750m/software/release/12.2_25_seg_seg1/configuration/guide/swmpls.pdf

Regards,

Sandip

New Member

EOMPLS QOS help needed

Hi Sandip,

First of all i would like to say thanks for you reply and help. Really appreciated.

I also would like to request all cisco members to kiindly guide me on this case. I am stuck on this qos issue of eompls. Requesting to all CCIE's, kindly guide me.

Sandip, i have already checked with the things you mentioned.

I have already checked with below commands on PE with classification of cos for port based eompls

On PE:

int fastEthernet 0/0

no ip address

xconnect 5.5.5.5 100 encapsulation mpls

service-policy input foo

no shutdown

!

Class-map cos

match cos 5

Policy-map foo

class cos

set mpls experimental imposition 5

Because PE router will get frame not IP packet. we need to match cos but ccos is not working on PE router.I am uanble to see traffic with cos5, just see traffic value of 0 with EXP.

I am getting error, you can match cos on this interface.

any conversion needed for cos to exp or cos to dscp or dscp to exp ?

Also any need to enable qos globally with mls qos or mls qos trust cos on interface of customer facing port. any need to configure port of client port also for msl qos trust cos.Also 3725 routers not supported mls qos trust cos or mls qos  or mls qos trust.Need some high end routers. I have also checked with 6503 classification of cos is also not working.

Also which routers i can check with. mean ios.

waiting for replies.

New Member

EOMPLS QOS help needed

Hi Sandeep & all other members,

Kindly reply me and guide me how to fix this issue.

Replies will be appreciated.

Cisco Employee

EOMPLS QOS help needed

Hi Ahsan,

Match CoS to QoS and then QoS to Exp bits.

Regards,

Sandip

New Member

EOMPLS QOS help needed

Hi Sandeep,

Thanks for reply. Can you elaborate your answer in detail with some example. Because i have already checked cos to exp mapping on PE and its not working. I only see traffic in class-default mean with 0 exp which is by default behaviour.

On PE:

int fastEthernet 0/0

no ip address

xconnect 5.5.5.5 100 encapsulation mpls

service-policy input foo

no shutdown

!

Class-map cos

match cos 5

Policy-map foo

class cos

set mpls experimental imposition 5

New Member

EOMPLS QOS help needed

Hi Sandeep,

I have used this scenario. kindly check it below. Using 5 routers. CE1(router with sub int dot1q), PE1(router), P(router), PE2(router), CE2(router with sub int Dot1q). i have made policy and classification of ip dscp on PE routers but see only class-default traffic not with exp 5 or dscp ef. is there any mistake on config or any changes need to be made.

CE1--->PE1---->P------>PE2------->CE2

PE1#show policy-map interface

FastEthernet0/0

  Service-policy output: mpls_exp

    Class-map: exp (match-all)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: mpls experimental topmost 5

      Queueing

        Strict Priority

        Output Queue: Conversation 264

        Bandwidth 30 (%)

        Bandwidth 2250 (kbps) Burst 56250 (Bytes)

        (pkts matched/bytes matched) 0/0

        (total drops/bytes drops) 0/0

    Class-map: class-default (match-any)

      3880 packets, 322434 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

FastEthernet0/1.455

  Service-policy input: foo

    Class-map: dscp (match-all)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp ef (46)

      QoS Set

        mpls experimental imposition 5

          Packets marked 0

    Class-map: class-default (match-any)

      48 packets, 5745 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

===============================================================

PE1(configuration):

class-map match-all dscp

match ip dscp ef

class-map match-all exp

match mpls experimental topmost 5

!

!

policy-map mpls_exp

class exp

  priority percent 30

policy-map foo

class dscp

  set mpls experimental imposition 5

!

!

!

!

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface FastEthernet0/0

ip address 192.168.23.2 255.255.255.0

ip ospf network point-to-point

duplex auto

speed auto

mpls ip

service-policy output mpls_exp

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.455

encapsulation dot1Q 455

xconnect 5.5.5.5 455 encapsulation mpls

service-policy input foo

!

router ospf 1

log-adjacency-changes

network 3.3.3.3 0.0.0.0 area 0

network 192.168.23.2 0.0.0.0 area 0

!

==============

CE1 ping to CE2:

R10#p

Protocol [ip]:

Target IP address: 172.16.15.2

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: 172.16.15.1

Type of service [0]: 0xb8

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.15.2, timeout is 2 seconds:

Packet sent with a source address of 172.16.15.1

!!!!!

Cisco Employee

EOMPLS QOS help needed

Hi Ahsan,

1) Make sure you are sending traffic from CE with DSCP EF, Can you also post output for the same

2) Can you try with removing "service-policy input foo" from subinterface to main interface - Fa0/0/1

3) mls qos is enabled ?

Which image are you using on PE1 router ?

Regards,

Sandip

New Member

EOMPLS QOS help needed

Hi Sandeep,


I really appreciated your help and i am really thankful of you. I am stuck on two things. can you guys can guide me how to solve this issue, need to correct any config on PE2 or PE1.

CE1---->PE1------->P-------->PE2--------->CE2(all four router i am using with image

3700 Software (C3725-ADVENTERPRISEK9-M), Version 12.4(15)T7. not using mls qos command because not supported on this ios.


1)I am unable to see any traffic on PE2 router on output interface although i can see traffic on input interface of PE2 router.this is the major issue of not seeing traffic on output interface.



2)After configuring PE2 configuration of qos, I am unable to see traffic on PE1 output interface although i can see traffic on input interface.


Kindly guide me how to fix these two issues.



-------------------------------------------------------------------------------

PE2 config:


class-map match-all EXP_5

match mpls experimental topmost 5

class-map match-all QOS_GROUP_5

match qos-group 5

!

!

policy-map mpls2ip

class QOS_GROUP_5

  set cos 5

policy-map IN_FROM_R4

class EXP_5

  set qos-group 5

!

interface FastEthernet0/0.455

encapsulation dot1Q 455

xconnect 3.3.3.3 455 encapsulation mpls

service-policy output mpls2ip

!

interface FastEthernet1/0

ip address 192.168.34.4 255.255.255.0

ip ospf network point-to-point

duplex auto

speed auto

mpls ip

service-policy input IN_FROM_R4


PE2#show policy-map interface

FastEthernet0/0.455


  Service-policy output: mpls2ip


    Class-map: QOS_GROUP_5 (match-all)


      0 packets, 0 bytes


      5 minute offered rate 0 bps, drop rate 0 bps


      Match: qos-group 5


      QoS Set


        cos 5


          Packets marked 0



    Class-map: class-default (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

FastEthernet1/0


  Service-policy input: IN_FROM_R4


    Class-map: EXP_5 (match-all)

      5 packets, 700 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: mpls experimental topmost 5

      QoS Set

        qos-group 5

          Packets marked 5


    Class-map: class-default (match-any)

      355 packets, 28066 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

PE2#

----------------------------------------------------------------------

PE1 config:


class-map match-all QOS_G_5

match qos-group 5

class-map match-any cos3

match cos  3

class-map match-all qos3

match qos-group 3

class-map match-any LOO1

match cos  5

!

policy-map EF

class LOO1

  set qos-group 5

policy-map QOS_G_5

class QOS_G_5

  set mpls experimental topmost 5

!

interface FastEthernet0/0

ip address 192.168.23.2 255.255.255.0

ip ospf network point-to-point

duplex auto

speed auto

mpls ip

service-policy output QOS_G_5

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.455

encapsulation dot1Q 455

xconnect 5.5.5.5 455 encapsulation mpls

service-policy input EF


PE1#show policy-map interface

FastEthernet0/0


  Service-policy output: QOS_G_5



    Class-map: QOS_G_5 (match-all)


      0 packets, 0 bytes


      5 minute offered rate 0 bps, drop rate 0 bps


      Match: qos-group 5


      QoS Set


        mpls experimental topmost 5


          Packets marked 0



    Class-map: class-default (match-any)

      10 packets, 1386 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any



FastEthernet0/1.455


  Service-policy input: EF


    Class-map: LOO1 (match-any)

      9 packets, 1062 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: cos  5

        9 packets, 1062 bytes

        5 minute rate 0 bps


    Class-map: class-default (match-any)

      4 packets, 256 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

--------------------------------------------------------------------------

CE1 config:


class-map match-all EF

match access-group 1

!

!

policy-map EF

class EF

  set cos 5

!


interface FastEthernet0/0.455

encapsulation dot1Q 455

ip address 172.16.15.1 255.255.255.0

service-policy output EF

!

access-list 1 permit 172.16.15.1


CE1# show policy-map interface

FastEthernet0/0.455


  Service-policy output: EF


    Class-map: EF (match-all)

      9 packets, 1062 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: access-group 1

      QoS Set

        cos 5

          Packets marked 9


    Class-map: class-default (match-any)

      4 packets, 256 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

CE1#

New Member

EOMPLS QOS help needed

Anyone cisco enginner or ccie engineer can guide me on this issue.

Waiting for replies. Replies will be appreciated.

Thanks

Cisco Employee

EOMPLS QOS help needed

Hi Rasheed,

Sorry for delay as yesterday occuiped with lots of stuff.

First on PE1, I do not see any QoS action set on output policy-map, can you please check this ?

Service-policy input: EF


Class-map: LOO1 (match-any)

9 packets, 1062 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: cos 5

9 packets, 1062 bytes

5 minute rate 0 bps

On PE2 output policy you don;t see any traffic match.

If there is no traffic match on QOS_GROUP_5, atleast we should see traffic match on class-default. or if its dropped, we should see match against drop, but we don;t see any packet match against any classe on PE2 output policy

Do you see traffic coming on PE2 output interface ?

Service-policy output: mpls2ip


Class-map: QOS_GROUP_5 (match-all)


0 packets, 0 bytes


5 minute offered rate 0 bps, drop rate 0 bps


Match: qos-group 5


QoS Set


cos 5


Packets marked 0



Class-map: class-default (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: any

From configuration persective it looks, ok, I would suggest check step by step on each interface

1) Traffic on CE1 output interface, it's matching against cos 5, working perfectly

2) Match cos5 and set qos on PE1 intput interface

3) match qos and set mpls on PE1 output interface

4) match mpls and set qos on PE2 input interface

5) match qos and set cos on PE2 output interface

And vice versa for reverse traffic, if you still face issue I would suggest to raise TAC case, there might be some BUG

Regards,

Sandip

New Member

EOMPLS QOS help needed

Hi Sandeep,

Thanks for your reply. i really appreciated.Can you or other guys guide me i am stuck in one major issue.


you know i was using this topology in eompls qos CE1(2811router)------->PE1(2811router)--------->P(2811router)---------->PE2(2811router)--------->CE2(2811router).When i am using this topology i can see and mark the traffic on each router.


when i am using this topology(CE1(2811router)------->PE1(2811router)--------->P(6523 layer3 switch)---------->PE2(2811router)-------------->CE2(2811router)with 6523 layer3 switch i am unable to see any traffic mark with exp5 or exp, see traffic on class-default with exp0.


0n 6523 switch config:


class-map exp5

match mpls experimental topmost 5


policy-map foo

class exp5



int gi1/1

ip 192.168.23.3

mpls ip

mtu 1546

service-policy output foo





int gi1/2

ip 192.168.34.4

mpls ip

mtu 1546

service-policy output foo



i can see traffic marked on ce1, pe1 but no traffic marked or seen on router P, PE2 and CE2.

I have triedon 6523 switch, mls qos command globally on 6523.also tried on interface trust command: mls qos trust cos , mls trust mpls exp topmost. but still no success.


Any additional configuration needed on 6523 switch?

628
Views
0
Helpful
11
Replies