Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

EoMPLS with Mismatch VLAN ID ?

I have topology like this for EoMPLS

CE1--------PE1------P-------PE2---------CE2

here Ce1-PE1 in VLAN200

CE2 and PE2 in VLAN100

In this case is CE1 will communicate to CE2 ?

3 REPLIES

Re: EoMPLS with Mismatch VLAN ID ?

Hi,

depending on your PE hardware and IOS version you can get connectivity between the two CE routers. Example config:

interface Loopback0

ip address 1.1.1.x.255.x.255

!

interface GigabitEthernet0/0

no ip address

!

interface GigabitEthernet0/0.100

encapsulation dot1Q 100

mpls l2transport route 2.2.2.2 10

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface GigabitEthernet0/0

no ip address

!

interface GigabitEthernet0/0.200

encapsulation dot1Q 200

mpls l2transport route 1.1.1.1 10

Hope this helps! Please rate all posts.

Regards, Martin

Silver

Re: EoMPLS with Mismatch VLAN ID ?

Yes this is possible. It is not necessary to use the same VLAN ID's at either end, if the xconnect is on a sub interface

New Member

Re: EoMPLS with Mismatch VLAN ID ?

I think if it is a point point link that you are having, then following will be config

At PE1:

1) you will create a vlan 200 :-

(config)# vlan 200

(config-vlan)#exit

2) then you will configure SVI for vlan 200: (config)# int vlan 200

(config-if)# no ip address

(config-if)# xconnect x.x.x.x (IP add of other end PE) 1000 (vcid)

Here x.x.x.x is IP add of other end PE and 1000 is vcid being used for this circuit. and this vcid should be same on both PE's configured this L2 circuit.

At PE2 you will have:

1) you will create a vlan 100 :-

(config)# vlan 100

(config-vlan)#exit

2) then you will configure SVI for vlan 100: (config)# int vlan 100

(config-if)# no ip address

(config-if)# xconnect x.x.x.x (IP add of other end PE) 1000 (vcid)

Now its clear from above example that only VCID that is being used in xconnect command should be same on both PEs, vlan ids can be different, but these vlan ids must be mapped in SVI to the same VCID at both end.

Hope it helps you.

Thanks

Shailendra

TCS

245
Views
0
Helpful
3
Replies
CreatePlease to create content