Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Community Member

EoMPLSoGRE - Web Browsing Problem


I have an interesting, yet hard to identify problem, that I would like to get some feedback on.

I have been experimenting with EoMPLS L2VPN over the internet, using GRE tunnels to establish my directed LDP sessions, currently I am using a cisco 1841 on both sides.

This started out as experimental, and testing throughput capabiliites on the 1841 platform running this scenario, and it turned out pretty well.  One side of the 1841 sits at an office location, WAN facing port with a public IP, and the LAN side connected to our internal network, and the port is configured on the router as port mode mpls x-connect.  Remote side is same way, but at a home office, so just a laptop connected to the router LAN interface.

The setup works, the remote laptop gets a DHCP address from the office pool etc, and I am essentially directly attached to the office network, sure there amy be some security concerns, but it is all lab environment at this time.

I have been using this for about 2 weeks now, until I an into the interesting problem.  Again, all types of applications have been tested over this, and worked just fine, including web browsing.

Last week, I reformed my laptop at the home office I was testing with, and install a fresh copy of Windows 7.  The interesting problem I am having is, after a fresh install of windows 7 (have not tried any other opporating system yet) I connect the laptop to the router at the remote office, and procede to get a DHCP address etc, and all seems well, except the fact that you can not browse the web.  DNS resolves, remote desktop works, telnet, ssh etc, but for some reason, internet explorered will not load any sites.

I did not actually do anything to fix this issue, but after taking the laptop back to the office and using for a day of work, and then coming back to the home office with it, things "majically" seemed to work, meaning web browser was working again.

I could never pinpoint why this happenened, but I decided to take it a step further, and reformat a new laptop, completely different model and series with a fresh copy of windows 7, and I have had the same issue.  I have just reformated this one, about 1 hour ago, so the "majically" started working has not taken affect yet, but it seems to be some weird problem, that I can not pinpoint, so was hoping to get ideas.  Again, with this new laptop, every other application I try works just fine, except for web browsing, which is very strange.  I will likely try another operatin system soon, to see if it seems to be limited to windows 7, but any thoughts and idea's are helpful.


Hall of Fame Super Silver

Re: EoMPLSoGRE - Web Browsing Problem

Hello Jason,

the PC with windows 7 can perform file transfers with FTP protocol?

have you tried to use a different browser like mozilla firefox?

Is your company using forms of authentication for web access that requires PCs to be associated to a MS domain?

Hope to help


Community Member

Re: EoMPLSoGRE - Web Browsing Problem


Thanks for the reply.

I have tried using firefox, same problem.

As for FTP, I thought it did work, but it does not work fully, I can connect to an external server, and list the file directory (both client and server are filezilla) but can't actually transfer any files, the data connection fails.

Using a seperate internet connection on this laptop, everything works fine, so do not believe any issues on the laptop itself.

No web restrictions, such as needing to join a MS domain etc.

Will be continueing to look into this on my end.


CreatePlease to create content