Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Getting Started with MPLS

Hello, I work for a small service provider that wants to offer its users MPLS and MPLS-VPN.

What considerations should I consider for deploying MPLS?

For examples i see that MPLS is configured on physical interfaces, but our network design have all virtual interfaces, I should consider or take into account the configuration?

I've also read that it is important the value of MTU, what is the proper value?

we have the following equipment: Cisco 3750 metro, Cisco 7606, Cisco catalyst 3500XL switch, Cisco Ubr7246, Cisco 1800 router.

Much appreciate your considerations.

thanks

6 REPLIES
Cisco Employee

Getting Started with MPLS

Hi Ramon,

There is not straightforward answer to this question. You may need to check best practice recommendation for deploying MPLS.

You Configure MPLS either on Physical or subinterface.

Every Lable add 4 bytes of MTU, so if you just have MPLS, it will add additional 4 byte of interface MTU, if you have MPLS TE, it will add another 4 byte, for MPLS L3 VPN, another 4 byte, so you need to consider how many label stack you will be having when packet enter into service provider edge router.

Let me know if you need more clarification

HTH

Regards,
Sandip

Community Member

Getting Started with MPLS

Sandip Thanks for responding.

If you add 12 bytes to the MTU, this would be for each label and each prefix?

So if I have 50 prefixes would be 12 bytes x 50 total for the MTU?

Currently I have configured a cisco 3750 metro  against a cisco 7606, my question is regarding the MTU on the cisco 3750, this is correct MTU value?

On 7606

interface Vlan472

mtu 1530

ip address ....

ip ospf network point-to-point

mpls ip

vlan 472

mtu 1530

interface GigabitEthernet2/10

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 472,703,715

switchport mode trunk

mtu 9216 (mtu one that can be set)

On 3750 metro

interface Vlan472

ip address ....

ip ospf network point-to-point

  mpls ip

vlan 472

mtu 1530

interface GigabitEthernet1/1/1

switchport trunk allowed vlan 472,703,715

switchport mode trunk

System MTU size is 1530 bytes

System Jumbo MTU size is 9000 bytes

System Alternate MTU size is 1530 bytes

Routing MTU size is 1500 bytes

on the other hand, i not sure what the requirements for cisco equipment that perform the  function of PE or P, that equipment is suitable for these functions and  what IOS?

Regards

Cisco Employee

Getting Started with MPLS

Hi Ramon,

MTU is maximum size of the packet that can be sent over the link without any fragmentation, it doesn;t have to relate with prefixes, default MTU size for ethernet frame is 1500, so if any packet comes above 1500, and if there is no fragmentation it will get dropped.

Configure mpls mtu on interface, u can also confirm mpls mtu value via below show command

show mpls interfaces detail

1530 MTU value should be enough in MPLS network. Generally we

Can you please elaborate more on your last question

"

on the other hand, i not sure what the requirements for cisco equipment that perform the function of PE or P, that equipment is suitable for these functions and what IOS?

"

Regards,

Sandip

Community Member

Getting Started with MPLS

Hi Sandip,

With respect to the last query in this link (http://www.cisco.com/en/US/tech/tk436/tk428/technologies_q_and_a_item09186a00800949e5.shtml # QA10)

What platforms and Cisco IOSes support MPLS?

The Cisco 2691 Series, 3640, 3660, 3725, 3745, 6400-NRP-1, NRP-2SV-6400, NSP-6400, Catalyst 5000 with Route Switch Module (RSM), 7200, 7301, 7400, 7500, Catalyst 6500 / Cisco 7600 Series with WS-SUP720-3B and WS-SUP720-3BXL, Gigabit Switch Router (GSR), Route Processor Module (RPM), Universal Broadband Router (UBR) 7200, AS5350, and IGX8400-URM all support MPLS.

What is not shown is what can be PE or P? is for business environment or supplier? I'm testing a 2801 supports MPLS is not on the list, the list is probably out of date.

So I should take into account to know that I can serve as a platform P or PE? if I want to provide all the services that MPLS offers. (MPLS-VPN, EoMPLS, AToM, MPLS-TE, QoS, etc.).

Thanking for your kind comments.

Cisco Employee

Getting Started with MPLS

Hi Ramon,

Typically SP use, 7600, ASR1K, ASR9K as a PE or P router. 7200 is End of Sale

You can check on feature navigator for devices support MPLS or not

http://tools.cisco.com/ITDIT/CFN/

Now, you need to know which router you should choose as PE or P, is all depend on your requirement

1) Identify what are the feature you need to deploy on PE or P router

2) What memory it will be consumed

3) Required Flash

4) Scaling

5) High Availability

May be in your LAB 7200 is ok for PE or P router but not on Service Provider network due to scalability issue, there are lots other thing need to consider while deploying any device on Service Provider network.

I would first collect the requirement, and then see what is the best router fits.

BTW, are you looking this for your LAB or for any customer ?

Regards,

Sandip

Community Member

Getting Started with MPLS

At the moment I am in a test environment, but the goal is to implement in a network service provider.

I'm testing with Cisco 7606 and 3750 metro.

Sandip, Thanks for all your insightful comments.

675
Views
0
Helpful
6
Replies
CreatePlease to create content