Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Gre tunnel in a vrf

Hello,

I'm trying to setup a gre tunnel over my mpls network in a VRF called Intra. Here is my conf. It's weird because the tunnel protocol is up on one side, down on the other side.

I can ping the destination ip address on each side.

interface Loopback30

ip vrf forwarding Intra

ip address 192.168.252.80 255.255.255.255

interface Tunnel1

ip vrf forwarding Intra

ip unnumbered Loopback30

keepalive 3 3

tunnel source Loopback30

tunnel destination 10.10.40.1

sh int tunnel 1

Tunnel1 is up, line protocol is down

Hardware is Tunnel

Interface is unnumbered. Using address of Loopback30 (192.168.252.80)

MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive set (3 sec), retries 3

Tunnel source 192.168.252.80 (Loopback30), destination 10.10.40.1, fastswitch TTL 255

Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled

Tunnel TTL 255

Checksumming of packets disabled, fast tunneling enabled

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 421

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

L2 Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes

L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast

L3 out Switched: ucast: 0 pkt, 0 bytes mcast: 0 pkt, 0 bytes

443 packets input, 21700 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

-------------------

interface Tunnel1

ip vrf forwarding Intra

ip unnumbered FastEthernet0/1

keepalive 3 3

tunnel source FastEthernet0/1

tunnel destination 192.168.252.80

tunnel vrf Intra

interface FastEthernet0/1

ip vrf forwarding Intra

ip address 10.10.40.1 255.255.255.0

duplex full

speed 100

sh int tunnel 1

Tunnel1 is up, line protocol is up

Hardware is Tunnel

Interface is unnumbered. Using address of FastEthernet0/1 (10.10.40.1)

MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive set (3 sec), retries 3

Tunnel source 10.10.40.1 (FastEthernet0/1), destination 192.168.252.80

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255

Fast tunneling enabled

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input never, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 7

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

556 packets output, 31180 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

5 REPLIES

Re: Gre tunnel in a vrf

one command is missing

"tunnel vrf Intra" on the first device.

Community Member

Re: Gre tunnel in a vrf

The command does not exist on that one (6500 12.2)

Re: Gre tunnel in a vrf

You should upgrade IOS on the 6500

I have such command with 12.2(33)SXH2

Community Member

Re: Gre tunnel in a vrf

Ok thank you, i'm in 12.2(18), that should be the problem !

Community Member

Re: Gre tunnel in a vrf

If you can't put "tunnel vrf" command in router A tunnel , that's not works , "tunnel vrf" command for it uses the tunnel destination and source addresses from the routing table of VRF

is not set the tunnel destination is unreachable, tunnel use backbplane routing table..

1068
Views
0
Helpful
5
Replies
CreatePlease to create content