Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

Silver

GRE with EIGRP

Hi guys anyone has got a sample config of having to run GRE between two CE routers(I am having an MPLS network). Would like some EIGRP running inside this GRE tunnel, so that all my LAN network gets its routing via EIGRP.

Any help would be appreciated :)

-Hoogen

3 REPLIES

Re: GRE with EIGRP

Hi Hoogen,

It should be normal GRE configuration, as the source and destination IPs of the tunnel should be reachable over the MPLS cloud between the CE routers, after configuring the GRE tunnel, run the EIGRP over it.

interface tunnel 0

ip address #

tunnel source #

tunnel destination #

keepalive #

router eigrp x

network

network

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Silver

Re: GRE with EIGRP

Lets say my network is like this(Hope you understand that my second branch router is also connected to my MPLS cloud and not directly to my router. Some problem while posting the diagram)

Lan-RouterCE---MPLSCloud---BranchRouterCE1--Lan

|

|

-------BranchRouterCE2--Lan

My Lan at Router CE is 10.1.1.0/24 Wan is 20.20.20.1/24, BranchRouterCE1 is 10.1.2.0/24

Wan is 20.20.20.2, Branch RouterCE2 is 10.1.3.0/24 Wan is 20.20.20.3.

Then my configuration would look like

!

hostname routerce

!

int fa0/0

ip add 10.1.1.1 255.255.255.0

!

int Se0/0

ip add 20.20.20.1 255.255.255.0

!

int tunn 0

ip unnumbered fa0/0

tunnel source fa0/0

tunnel destination 10.1.2.0

ip mtu 1440

!

int tunn 1

ip unnumbered fa0/0

tunnel source fa0/0

tunnel destination 10.1.3.0

ip mtu 1440

!

router eigrp 100

network 10.1.1.0

!

BranchrouterCE1

!

hostname branchrouterce

!

int fa0/0

ip add 10.1.2.1 255.255.255.0

!

int Se0/0

ip add 20.20.20.2 255.255.255.0

!

int tunn 0

ip unnumbered fa0/0 !My tunnel ip can only be my Lan or WAN ip i wouldn't be able to use any other ip.

tunnel source fa0/0

tunnel destination 10.1.1.0

ip mtu 1440

!

router eigrp 100

network 10.1.2.0 !If i add my tunnel ip as unnumbered ethernet this network statement is ok, but if i have my wan as tunnel ip i don't want it to be eigrp.

!

Do you think by the above config I would be able to get my LAN routes via Eigrp

Also my second branch router should recieve the Lan of the other branch router through the Hub router. Am i doing it right here.

Thank you for your help.

Hoogen

Re: GRE with EIGRP

Hi,

Your configuration should work fine in theory, but i've not used ip unnumbered under the tunnel interface in this manner, please let me test it for you and get back to you.

HTH,

Mohammed Mahmoud.

210
Views
0
Helpful
3
Replies
CreatePlease to create content