Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Head End Build between MPLS and standard IP network

Hi,

I'm a bit new to MPLS to please excuse my ignorance if I'm completely wrong here, but here goes.

We provide standard IP services to our customers. We have recently gone into an agreement with an MPLS wholesale provider, where they supply our customers with MPLS connections. We then supply IP services to these customers such as SMTP POP and Web browsing etc.

We have a pipe into the MPLS providers MPLS cloud that provides such connectivity. This circuit is terminated on a 7206VXR on our network.

Each customer has their own DLCI on this circuit with a /30 subnet. There is then a BGP session for each customer using the /30 from our Head End Router to the MPLS Provider's P router.

The MPLS provider announces the customers subnets that are connected to the MPLS cloud to our Head End Router using BGP.

My issue is that I want routes announced from each BGP session to be injected into their own, per customer VRF table so that the routes are kept seperate from other customers routes.

I've setup a lab to simulate the above, but cannot seem to get it to work.

I suppose my question is does the MPLS provider's P router that our Head End connects to have to announce the BGP routes to us using VRF also or can it just use standard BGP and I can use a route map to place routes announced from a specific BGP peer IP into a per Customer VRF table?

Is this actually possible?

Any advice would be greatly appreciated

6 REPLIES
Silver

Re: Head End Build between MPLS and standard IP network

From your explanation, I understand that for each customer you have a seperate interface and a seperate BGP session. If so, you can simply create vrfs for each customer on your headend router. The customer interfaces will now be out in their respective VRFs. In this situation, the BGP session will be created under the IPv4 vrf family. This will create a seperate table for each customer.

If there is only one BGP session and Interface for all the customers, you might want to create an MP-BGP session with the provider. This could then look like an Inter-AS setup.

New Member

Re: Head End Build between MPLS and standard IP network

Hi there,

Thanks for your response.

You are correct in saying that each customer has their own interface on the Head end Router (in this case it's a vlan on a /30 subnet).

We would run one BGP process between the Head end router and the MPLS providers PE router, but each customer does have their own BGP session using the /30 subnet that has been allocated to them.

It's just I can't seem to get the routes that are advertised from the MPLS providers PE router via normal BGP to be "injected" into the customers individual vrf table on the Head end router.

Any help would be great!

Re: Head End Build between MPLS and standard IP network

Hello,

you probably would need a config like this on the Head end router:

ip vrf Cust1

rd 65000:1

interface Vlan10

description Customer1

ip vrf forwarding Cust1

ip address 10.1.1.1 255.255.255.252

router bgp 65000

address-family ipv4 vrf Cust1

neighbor 10.1.1.2 remote-as 60000

neighbor 10.1.1.2 description ISP PE for Customer1

Adjust the interface names, IP addresses, RD, RT, etc. for your environment.

This would insert the routes learned from the mpls Provider into your VRFs. The scenario, by the way, is described in RFC2547bis section 10a.

You could off course also place filters and other stuff into BGP for security reasons depending on your requirements.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Head End Build between MPLS and standard IP network

Hi,

Thanks for the reply.

We will be using the same private AS between the Headend and MPLS provider PE to in effect iBGP.

I see that in your example you've used eBGP.

Will iBGP work in the same manner?

Thanks,

Silver

Re: Head End Build between MPLS and standard IP network

No iBGP will not work. iBGP has a requirement for full mesh of all iBGP routers (unless you are using route reflectors or confederation). Therefore, BGP routes from other iBGP routers aside the one you are peering with will not show up on your BGP table.

Silver

Re: Head End Build between MPLS and standard IP network

"We would run one BGP process between the Head end router and the MPLS providers PE router, but each customer does have their own BGP session using the /30 subnet that has been allocated to them." - Can you explain that statement better, maybe by giving your configs.

If you only have one IPv4 BGP session with the Provider, then all your routes enter into routing table. However, if the session is VPNv4 session, the scenario is an Inter-AS setup, and the routes can be seperated.

Do you have vrfs on your headend router? I think a look at the config on your headend router and the SP router will give us an insight into what is happening.

326
Views
0
Helpful
6
Replies
CreatePlease to create content