cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12321
Views
5
Helpful
9
Replies

InterAS MPLS Option C (BGP IPv4 + Labels) IOS XR with eBGP multihop session

jbaraona
Level 1
Level 1

Hello,

Right now we have InterAS MPLS Option C configured between 2 autonomous systems.

Now we need to add more bandwith and would like to add another interface between the two routers establishing a multihop session using loopbacks to load share traffic.

I know that IOS-XR does not automatically learn directly connected host routes so for the XR router to assign labels you'll need to configure a static host route to ensure MPLS forwarding to the neighboring AS.

This works with directly connected neighbors but when I try to enable the multihop session, the XR does not assign labels even configuring the staic host route.

Does anybody has a configuration like that working?

Thanks!!

Jose.

9 Replies 9

Vinit Jain
Cisco Employee
Cisco Employee

Hello Jose

There are basically two options in Option C L3VPN setup. I will discuss the first option for Multihop.

Following are the key points that distinguish the InterAS Option C from previous options.

1) External Multihop BGP address families are invoked between two different autonomous systems; however, these eBGP sessions are invoked between the route reflectors in each AS and not on the ASBR. The route reflector in each AS thus passes labeled ipv4 unicast VPN routes to the other AS. Note:- The route reflector in this case will have PE clients in the vpnv4 address family within that Autonomous System.

2) ASBRs facilitate the creation of InterAS LSP by providing labeled /32s for PE and Route Reflector loopback.

3) This option enhances scalability because ASBRs do not handle VPNv4 routes in fact this option gets rid of the extra L3VPN LFIB that is created as a result of option B . The LFIB size is minimal as we control the redistribution to the only 2 needed loopback addresses (remote ASBR and remote RR)

Sample config of the RR:

router bgp 102

address-family ipv4 unicast

!

address-family vpnv4 unicast

  !

neighbor-group ibgp

  remote-as 102

  update-source Loopback0

  address-family ipv4 unicast

   route-reflector-client

  !

  address-family vpnv4 unicast

   route-reflector-client

  !

neighbor 192.168.253.3

  remote-as 101

  ebgp-multihop 255

  description eBGP-RR-PEER-AS101

  update-source Loopback0

  address-family vpnv4 unicast

   route-policy allow-all in

   route-policy allow-all out

   next-hop-unchanged

  !

!

neighbor 192.168.254.1

  use neighbor-group ibgp

!

neighbor 192.168.254.3

  use neighbor-group ibgp

!

neighbor 192.168.254.4

  use neighbor-group ibgp

On the PE router, the config will look something like this:

router bgp 102

address-family ipv4 unicast

  redistribute ospf 1 metric 3333 route-policy interAS-optionc-out

  allocate-label route-policy interAS-optionc-out

!

neighbor 65.10.20.1

  remote-as 101

  address-family ipv4 labeled-unicast

   route-policy interAS-optionc-in in

   route-policy interAS-optionc-out out

  !

!

neighbor 192.168.254.2

  remote-as 102

  update-source Loopback0

  address-family ipv4 unicast

  !

router static

address-family ipv4 unicast

  65.10.20.1/32 TenGigE0/0/0/1

  192.0.2.0/24 Null0 tag 10

!

!

route-policy interAS-optionc-in

  if destination in remote-RR-PE then

    pass

  else

    drop

  endif

end-policy

!

route-policy interAS-optionc-out

  if destination in local-RR-PE then

    pass

  else

    drop

  endif

end-policy

!

prefix-set local-RR-PE

  192.168.254.2/32,

  192.168.253.6/32,

  192.168.253.5/32

end-set

!

prefix-set remote-RR-PE

  192.168.253.2/32,

  192.168.253.3/32,

  192.168.253.3/32

end-set

!

Just for your clarification, 192.168.253.0/24 is the Remote AS networks and 192.168.254.0/24 is the local AS networks.

Hope this clarifies your doubts.

Cheers ... !!!

Vinit

Thanks
--Vinit

Hello Vinit

Thanks for your response but I think I didn't explain the problem correctly. What you explained is correct as a matter of fact, I do have the configuration exactly that way.

Actually my problem is I need to add more bandwidth between Autonomus Systems. When I try to add another TenGig interface between ASBRs and configure the IPv4 session as multihop (to loadshare between de two TenGig interfaces), the 12k XR router does not assign labels to the 7609 on the remote AS.

I will let you know if I find a solution.

Thanks for your help.

regards,

Jose.

Hello Jose,

Thanks for the prompt reply. Let me know if you are not able to get anything on it. I shall be able to help you fix the issue.

let me know if you need any help related to XR or any other issue related to your setup.

Regards

Vinit

Thanks
--Vinit

Thanks Vinit!

I'll keep you posted.

best,

Jose

prdpvaghela
Level 1
Level 1

Hi ,

In Option-C, how many labels are assigned to prefixes & what are they?

Regards

Pradip Vaghela

Hello Pradip,

In Option C, there are two methods:

1) PE loopbacks of the other AS are advertised in local AS via IGP ROUTES (redistributed from eBGP)

In this method two labels will be used:

     a) 1 for the VPN

     b) 1 for the PE loopback (like regular MPLS-VPN)

2) PE loopbacks of other AS are advertised in local AS via iBGP ROUTES

In this method three labels used

      a) 1 for the VPN

      b) 1 for destination PE (next-hop)

      c) 1 to get to the local ASBR

I am not mentioning about the local mpls ldp or TE labels (if present)

Hope this answers your question.

Regards

Vinit

Thanks
--Vinit

gotcha

- Pradip

Jose

You may  find some useful information about Inter-AS Option C Multipath Load Balance Options here (Page 17):

http://blog.uruhu.su/sites/default/files/Cisco_I-AS-MPLS.pdf

HOSTNAME ASBR

!

interface e0/0

ip address 168.192.0.2 255.255.255.252

mpls bgp forwarding

! Enable BGP forwarding on connecting interfaces

!

interface e2 /0

ip address 168.192.2.2 255.255.255.252

mpls bgp forwarding

!

router bgp 2

neighbor 10.10.10.10 remote-as 1

neighbor 10.10.10.10 disable-connected-check

neighbor 10.10.10.10 update-source Loopback0

!

!

address-family ipv4

neighbor 10.10.10.10 activate

neighbor 10.10.10.10 send-label

!

ip route 10.10.10.10 255.255.255 e0/0 168.192.0.1

ip route 10.10.10.10 255.255.255 e2/0 168.192.2.1

!

Configure /32 static routes to the eBGP neighbor loopback address

But they only talk about IOS, may be you can visit this site, to convert IOS commands to IOX

http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.5/xr12000_conversion/reference/guide/cn35main.html#wpmkr1183423

Kind regards

Gustavo

Hi Vinit

When I deploy the Option C (BGP ipv4+label) on XR,  the VPNV4 routes can be learned by each router in two AS, beside the next-hops are reachable. But there is a problem with the Label assignments on CN-ASBR(XR). 

sh cef vrf OAM 10.204.64.13

next hop 10.204.92.13 via 24004/0/21
 next hop 10.0.0.2/32 Gi0/0/0/0 labels imposed {ImplNull 24007}  ImplNull----issued place

sho bgp vpnv4 unicast 

*> 10.204.64.13/32    10.204.92.13                           0 65160 i

sho bgp vpnv4 unicast labels 

*> 10.204.64.13/32    10.204.92.13    24007           nolabel

sho bgp ipv4 un label  

*> 10.204.92.3/32     10.0.0.2        3               24002

I addressed this issue on  ImplNull and don't know why the top label 3 can't be attached. Can you give me some suggestion on this troubleshooting?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: