Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IOS version for MPLS command

What is the minimum software version for Cisco 2620XM to execute mpls?

I am running Version 12.2(24)but enable to run mpls command.

1)Router(config)#tag-switching advertise-tags

2)Router(config)# interface e0/1

Router(config-if)# tag-switching ip

Pls help!!

8 REPLIES
ft
New Member

Re: IOS version for MPLS command

2620XM try

12.2.15T17 Enterprise Basic

c2600-j1s3-mz.122-15.T17.bin

or

12.3.18 Enterprise Basic

c2600-j1s3-mz.123-18.bin

or

12.3.18 Telco Feature

c2600-telco-mz.123-18.bin

New Member

Re: IOS version for MPLS command

Regarding the 2600XM, is MPLS supported going forward? It looks like it disappears in 12.4 code.

Best Regards,

Rich

New Member

Re: IOS version for MPLS command

How about cisco 3660?

I can't enter the cmd as well

Version 12.4(4)T1

Any idea?

ft
New Member

Re: IOS version for MPLS command

12.3(18) ENTERPRISE PLUS c3660-js-mz.12.3-18.bin

12.3(18) TELCO FEATURE SET c3660-telco-mz.12.3-18.bin

12.2.15T17 ENTERPRISE PLUS c3660-js-mz.12.2-15.T17.bin

12.2.15T17 SERVICE PROVIDER c3660-p-mz.12.2-15.T17.bin

12.2.15T17 TELCO FEATURE SET c3660-telco-mz.12.2-15.T17.bin

New Member

Re: IOS version for MPLS command

On versions upper than 12.25 tag swicthing changes to : mpls label protocol ldp

You can activate MPLs whit de next configuration:

ip cef distributed

mpls ip

mpls label protocol ldp

over OSPF or IS-IS

Cisco Employee

Re: IOS version for MPLS command

Unless there is a requirement for MPLS TE, you can configure MPLS over any IGP (or static) not just ISIS or OSPF.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: IOS version for MPLS command

1: You can check flash and memory of your router (you can get this information with "show version")

2: Any SP (service provider) version upper than 12.3 works with MPLS.

I think that you can work with :

c2600-spservicesk9-mz.123-3i.bin with: flash (MB):32 Mem (MB):96

c2600-spservicesk9-mz.123-18.bin with: flash (MB):32 Mem (MB):96

c2600-spservicesk9-mz.124-1c.bin with: flash (MB):32 Mem (MB):128

c2600-spservicesk9-mz.124-7a.bin with: flash (MB):32 Mem (MB):128

New Member

Re: IOS version for MPLS command

It looks like MPLS really does disappear in 12.4 code for the 2651XM (see below). It's too bad because I could use the features and would rather not have to replace a bunch of routers.

PE#show ver

System returned to ROM by reload

System image file is "flash:c2600-spservicesk9-mz.123-18.bin"

PE#

PE#conf t

Enter configuration commands, one per line. End with CNTL/Z.

PE(config)#int fa0/0

PE(config-if)#mpls ip

PE(config-if)#tag-switching ip

PE(config-if)#end

PE#

PE#show version

System returned to ROM by reload

System image file is "flash:c2600-spservicesk9-mz.124-7a.bin"

PE#

PE#config t

Enter configuration commands, one per line. End with CNTL/Z.

PE(config)#int fa0/0

PE(config-if)#mpls ip

^

% Invalid input detected at '^' marker.

PE(config-if)#tag-switching ip

^

% Invalid input detected at '^' marker.

PE(config-if)#end

PE#

1260
Views
0
Helpful
8
Replies
CreatePlease to create content