Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

IP Fast Reroute

Hi all,

Can any one tell me if ip fast retoute is suported on cisco 7200/7600

Thanks

22 REPLIES
Cisco Employee

Re: IP Fast Reroute

Hi,

Unfortunately no.

Regards,

Laurent.

Community Member

Re: IP Fast Reroute

Hi Laurent,

Many thanks

Community Member

Re: IP Fast Reroute

What about this?

http://www.cisco.com/en/US/docs/ios/mpls/configuration/guide/mp_te_frr_node_prot.html#wp1477142

Actually i tried to lab FRR using RSVP hellos on a c7200 running 12.4(20)T and the tunnel is not coming up.

VB4990-CPE-1-1#sh mpls traffic-eng tunnels brief

Signalling Summary:

LSP Tunnels Process: running

Passive LSP Listener: running

RSVP Process: running

Forwarding: enabled

Periodic reoptimization: every 3600 seconds, next in 1619 seconds

Periodic FRR Promotion: Not Running

Periodic auto-bw collection: every 300 seconds, next in 119 seconds

TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT

VB4990-CPE-1-1_t0 10.100.240.3 - unknown up/down

VB4990-CPE-1-1_t100 10.100.240.3 - unknown up/down

Displayed 2 (of 2) heads, 0 (of 0) midpoints, 0 (of 0) tails

VB4990-CPE-1-1#

Do you know if there is any sample config to use for MPLS TE FRR tunnel protection available?

Cisco Employee

Re: IP Fast Reroute

Giulio,

This is MPLS fast reroute. The original post was referring to IP fast reroute.

As for the issue you run into is concerned, here is a couple of things you should had to the configuration for the tunnel to come up:

1. mpls traffic-eng tunnels on all the physical interface used to setup the tunnel (fa1/0 and fa1/1 in the config you provided)

2. For rsvp hello to work, you need to configure "ip rsvp signalling hello" on fa1/0 and fa1/1.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Community Member

Re: IP Fast Reroute

Thanks a lot, its all ok now.

Community Member

Re: IP Fast Reroute

Hi,

I have heard that IP FRR and in latest IOS-XR MPLS FRR ( per link LFA) features with BGP PIC EDGE and CORe can give SDH kind of convergance and one don't need ot use normal TE and FRR.

This all will be avilable going forward in IOS-XR 12k/CRS etc.

Is that correct ?

Cisco Employee

Re: IP Fast Reroute

Hi,

IP FRR will allow you to have same convergence time as MPLS-TE FRR but on an IP only backbone.

BGP PIC allows you to converge at the IGP speed regardless of the number of BGP prefixes.

BGP PIC Core is already available on IOS-XR and IOS (7600 and GSR both with some restrictions).

BGP PIC Edge will be available in IOS-XR and IOS for 7600.

HTH

Laurent.

Community Member

Re: IP Fast Reroute

Do you know when will MPLS FRR ( i.e. LDP FRR) will be avilable for MPLS backbone ? I know it is only going to avilable in IOS-XR first but any idea on release ?

Regards,

Chintan

Cisco Employee

Re: IP Fast Reroute

Chintan,

For such question, the best entry point is your Cisco account team.

Laurent.

Community Member

Re: IP Fast Reroute

Hi Laurent,

From latest 2011 Cisco Networkers, I got to know that IP FRR with LDP support for say IS-IS is now avilable in 4.0.1 for both per-link and per-prefix.

Is that correct ? if so, Do i need to configure any specfic under LDP or it is with in software once you enable ip frr under IS-IS.

Also if you can direct to any good CCO link to verify show commands for IP FRR to see which is backup path etc .

Thanks,

Chintan

Cisco Employee

Re: IP Fast Reroute

http://www.cisco.com/en/US/docs/routers/crs/software/crs_r4.0/mpls/configuration/guide/gc40crs1book_chapter1.html#reference_063CBD50AC624F28B69D6B2173B53A75

HTH

Laurent.

Community Member

Re: IP Fast Reroute

Hi Laurent,

I read that 3.9.x onwards ther eis BGP PIC Edge support with unipath and before that it was must to use multipath.

What is difference between unipath vs multipath  ? Do I get any advantage of memory utilization etc ?

Regards,

Chintan

Cisco Employee

Re: IP Fast Reroute

Hi,

Multipath means you selected two BGP path to do load-balancing so both path are programmed in hardware by default so it's very easy to achieve BGP PIC Edge.

Unipath means you selected only the Best path. By default only this one is programmed in hardware so you can't achieve BGP PIC Edge in this case. The feature has been enhanced so a backup path is selected and also programmed in addition to the Best one.

HTH

Laurent.

Community Member

Re: IP Fast Reroute

Thanks for clarification Laurent.

So What I understand is this new enhancment in 3.9.x will keep now backup path also in FIB and will be programmed in HW.

And here we can have primary/backup link concept if customer wish to have and still provide better convergance should primaly link/PE fails....

If we use multipath then traffic will be loadbalanced than having primary/backup link but we can achieve....

Now When it comes to BGP PIC EDGE , I guess with above feature , BGP PIC provides only Hirerichal FIB so that it updates prefix very quickly compare to Flat table...

Am I correct in understanding ?  I am trying to understand that if I have eibpg multipath support in box , can I have convergance still faster if say no BGP PIC Edge in software and if not what BGP PIC Edge will provide me further.....

Sorry if I am askign same question again but i am really trying to understand BGP PIC Edge advantage as other vendor doesn't support this and claim that we still support multipath and you can achieve same convergance...like Juniper :-)

Regards,

Chintan

Cisco Employee

Re: IP Fast Reroute

Hi Chintan,

BGP PIC (either Core or Edge) allows you to have a convergence time based only on the IGP or link failure detection for external neighbors having 10 or 300k BGP prefixes.

Your understanding is correct and the implementation is based on a hierarchical FIB. I don't see any restriction between PIC Edge and eiBGP multipath but I never tested it.

If you have a lot of BGP prefixes to converge , the difference with and without this feature is significant.

HTH

Laurent.

Community Member

Re: IP Fast Reroute

Hi Laurent,

Thanks for further clarification.

Regards,

Chintan

Bronze

IP Fast Reroute

Hi,

I am configuring IP FRR for OSPF on IOS-XR 4.0.3. I found some cisco documents and it looks like that IP FRR is working. There are some 7600 RSP 720 with 15.1.3 which supports IP FRR, too.

My question is what are the show commands for IP FRR with OSPF on IOS-XR. I can not find on the router nor on any documents.

There are some show commands fos IP FRR ISIS though-

On IOS 15.1.3 is sh ip ospf fast-reroute (prefix-summary) with the output is really poor. I need more info.

And how can see the reconvergnece time. With ICMP I do not lose any packets with timeout 1, but I would like to see the convergence time.

BFD is used too with the min timers (50msec because of 7600).

IP Fast Reroute

Hi,

I'd recommend to have a look at this command:

sh mpls traffic-eng fast-reroute database

HTH,

Ivan.

Bronze

IP Fast Reroute

Hi,

I am not using MPLS TE FRR but IP FRR which is a new feature that does not need MPLS and RSVP signaling.

Cisco Employee

IP Fast Reroute

Hi,

Simple ping will not help you to have an accurate idea of the convergence time. In your case, the only thing you can say is it takes less than a second.

You need a traffic generator where you control the number of pps transmitted and can check the number of pps received. The higher of pps you transmit the more accurate convergence time you will be able to estimate as the time between 2x packets decrease.

For IP FRR, show route / should give you the backup path. For OSPF you can also try show ospf route backup-path

HTH

Laurent.

Community Member

IP Fast Reroute

Hi,

I agree with Laurent, ICMP is not right way to test.

You need traffic generator with multiple stream may be iMIX + various packet size to take care of all type of traffic.

I have recently tested LFA for IS-IS along with BFD - with 3K IGP prerfix + 400K BGP Internet prefix + 100K VPN prefix together to verify convergance in P-PE link failure for both Internet and VPN traffic. Result was good - less than 1 sec thanks to BGP PIC Core

But I faced one issue where if LFA is not enabled, even with BGP PIC Core and optimized IOS-XR SPF parameter, convergance jumped to 8 sec - I am any way working with my account team on this since issue is not always reproduciable.

But if you intend to have BFD+LFA, that will take care of less than 1 sec for any core link failure on IOS-XR 4.0.3

you may have to see whether your network topology is well enough to take care through per-link LFA or you need per-prefix ( although CPU supposed to be taking here but i didn't see much on 12K).

HTH,

Chintan

Bronze

IP Fast Reroute

Thank you Laurent for the show command

Without IP FRR

O    10.1.32.4/30, metric 2

       10.1.0.6, from 10.255.0.64, via TenGigE0/0/0/1, path-id 2

       10.1.0.2, from 10.255.0.64, via TenGigE0/0/0/0, path-id 1

With IP FRR

O    10.1.32.4/30, metric 2

       10.1.0.6, from 10.255.0.64, via TenGigE0/0/0/1, path-id 2

           Backup path:

              10.1.0.2, from 10.255.0.64, via TenGigE0/0/0/0, protected bitmap 0x2

       10.1.0.2, from 10.255.0.64, via TenGigE0/0/0/0, path-id 1

           Backup path:

              10.1.0.10, from 10.255.0.64, via TenGigE0/6/0/0, protected bitmap 0x1

@Chintan-shah

Thank you for the info.

Is there a free packet generator on the web? I know about cisco packet generator but I is not possible to get one.

And what is iMAX? I googled it but could not find out what it is.

Is it possible that you provide me the config for LFA and BGP PIC? Here is my topology. The IGWs and R2 and R4 are CRS router. The others are 7600 RSP 720 with 15.1.3 IOS.

here is an example of my OSPF/IPFRR/BFD config on IOS-XR

router ospf 1

nsr

bfd minimum-interval 50

bfd fast-detect

bfd multiplier 3

mpls ldp sync

mpls ldp auto-config

timers throttle lsa all 0 20 5000

timers throttle spf 24 24 5000

timers lsa min-arrival 20

area 0

  bfd minimum-interval 50

  bfd fast-detect

  bfd multiplier 3

  fast-reroute per-link enable

bfd

interface TenGigE0/0/0/0

  echo

!

interface TenGigE0/0/0/1

  echo

!

interface TenGigE0/1/0/0

  echo

!

interface TenGigE0/1/0/1

  echo

!

interface TenGigE0/6/0/0

  echo

!

echo ipv4 source 10.255.0.1

IOS

router ospf 1

auto-cost reference-bandwidth 10000

fast-reroute per-prefix enable area 0 prefix-priority low

fast-reroute keep-all-paths

timers throttle spf 24 24 5000

timers throttle lsa 0 20 5000

timers lsa arrival 20

interface TenGigabitEthernet1/21

mtu 9164

ip address 10.1.0.6 255.255.255.252

ip ospf hello-interval 1

ip ospf bfd

carrier-delay msec 0

bfd interval 50 min_rx 50 multiplier 3

5635
Views
0
Helpful
22
Replies
CreatePlease to create content