Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Join VPLS and EoMPLS circuit together

Hi All,

 

I have ASR1006 IOS-XE as PE router at that have connected to other PE with same model. And I have VPLS established to provide E-LAN service. Multiple GE interface at both site have joined this VPLS group. Now that we have another PE(ISR G2 Router, for small scale use) that need to join this VPLS group. Since ISR G2 IOS do not support VPLS , we can only achieve EoMPLS(E-LINE) service. 

Is there any way to Interconnect VPLS and EoMPLS.  Referring to below configuration example, can I make Service-Instance 110 as member in Bridge-Domain 10 ? Is that would eventually interconnect EoMPLS to VPLS ? All router currently in production. Any idea would be much appreciated. 

 

l2vpn vfi context VFI-TEST                                        // VPLS
 vpn id 10
 member 10.166.10.2 encapsulation mpls

 

bridge-domain 10 
 member GigabitEthernet0/0/0 service-instance 101
 member GigabitEthernet0/0/0 service-instance 102
 member GigabitEthernet0/0/0 service-instance 103
 member vfi VFI-TEST

interface GigabitEthernet0/0/0
 service instance 101 ethernet
  encapsulation dot1q 101
  rewrite ingress tag pop 1 symmetric
 !
 service instance 102 ethernet
  encapsulation dot1q 102
  rewrite ingress tag pop 1 symmetric
 !
 service instance 103 ethernet
  encapsulation dot1q 103
  rewrite ingress tag pop 1 symmetric
 !
 service instance 110 ethernet
  encapsulation dot1q 110
  rewrite ingress tag pop 1 symmetric
  xconnect 10.200.149.110 10 encapsulation mpls                 // EoMPLS 
 !

 

 

Regards, Nagis
Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

I haven't tested this but I

I haven't tested this but I think it should work. We can have both Eompls/VPLS in a hub and spoke topology. However since this topology is not fully meshed you  need to disable split horizon for PE2 and PE3 to talk with each other.

PE2---VPLS---PE1---EOMPLS---PE3.

 

PE1:

l2 vfi VPLS-10 manual

 vpn id 10

bridge-domain 10

neighbor 102.102.102.102 encapsulation mpls

neighbor 103.103.103.103 encapsulation mpls no-split-horizon

 

PE2:

l2 vfi VPLS-10 manual

 vpn id 10

bridge-domain 10

neighbor 101.101.101.101 encapsulation mpls

 

PE3:

interface GigabitEthernet0/0/2

no ip address

negotiation auto

xconnect 101.101.101.101 10 encapsulation mpls

 

Best Regards,

Bheem

7 REPLIES
Cisco Employee

I haven't tested this but I

I haven't tested this but I think it should work. We can have both Eompls/VPLS in a hub and spoke topology. However since this topology is not fully meshed you  need to disable split horizon for PE2 and PE3 to talk with each other.

PE2---VPLS---PE1---EOMPLS---PE3.

 

PE1:

l2 vfi VPLS-10 manual

 vpn id 10

bridge-domain 10

neighbor 102.102.102.102 encapsulation mpls

neighbor 103.103.103.103 encapsulation mpls no-split-horizon

 

PE2:

l2 vfi VPLS-10 manual

 vpn id 10

bridge-domain 10

neighbor 101.101.101.101 encapsulation mpls

 

PE3:

interface GigabitEthernet0/0/2

no ip address

negotiation auto

xconnect 101.101.101.101 10 encapsulation mpls

 

Best Regards,

Bheem

New Member

Hi, Thanks for reply. Does it

Hi,

 

Thanks for reply. Does it mean, I do no need to do xconnect in PE2  as in my Configuration above? 

Regards, Nagis
Cisco Employee

In my example, PE1 and PE2

In my example, PE1 and PE2 represent your existing PE routers in VPLS domain and PE3 would be acting as ISRG2 with eompls. ISRG2 has xconnect only towards PE1 and P1 see ISRG2 as a member on VFI.

 

Best Regards,

Bheem

New Member

Hi,I cant fine "neighbor"

Hi,

I cant fine "neighbor" command under bridge-domain nor l2vpn vfi. If the "neighbor" command replace by "member" , it should be type under VFI or Bridge-domain ?

Btw, I noticed my VFI configuration and yours different.  

 

My config

l2vpn vfi context VFI-TEST                                        // VPLS
 vpn id 10
 member 10.166.10.2 encapsulation mpls

 

Your Config

l2 vfi VPLS-10 manual

 vpn id 10

 

Regards, Nagis
Cisco Employee

Both are valid configuration.

Both are valid configuration. Please see link below.

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mp_l2_vpns/configuration/xe-3s/asr1000/mp-l2-vpns-xe-3s-asr1000-book/mp-vpls.html#GUID-9C91269F-949C-4A41-8B54-FC6D354369C3

 

Best Regards,

Bheem

New Member

Hi , Thank you. That works

Hi ,

 

Thank you. That works like charm. Btw, based on my testing, If I configure member under VFI, the VC is UP but traffic cant pass through. But if configure member under Bridge-domain , then VC is UP and traffic can pass through. 

Regards, Nagis
New Member

Trying to do the same thing.

Trying to do the same thing. Any chance you could PM me/copy up your final configs from the PE1 and PE3 equivalent?

305
Views
0
Helpful
7
Replies