Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

L2VPN LDP session source IP issue

Hello all,

The L2VPN between PE1 and PE2, both PE need use loopback1(just for L2 VPN) as peering.
PE1----MPLS backbone----PE2

The L2 VPN is working without problem. I expect use loopback1 to establish LDP neighbor, but LDP neigbor established between PE1 loopback0 and PE2 loopback1. Why not is loopback 1 to loopback 1(192.168.1.33(LDP Id) -> 192.168.1.34)? The command "mpls ldp discovery transport-address 192.168.1.34" force to use loopback1 as soruce seem not work under L2 interface?
And suggestion will be appreciated.

sho mpls l2transport vc  detail       
Local interface: Te4/2 up, line protocol up, Ethernet up
  Destination address: 192.168.1.34, VC ID: 30, VC status: up
    Output interface: Te4/1, imposed label stack {449 837}
    Preferred path: not configured 
    Default path: active
    Next hop: 10.10.10.138
  Create time: 00:20:13, last status change time: 00:04:39
  Signaling protocol: LDP, peer 192.168.1.117:0 up
    Targeted Hello: 192.168.1.32(LDP Id) -> 192.168.1.34, LDP is UP--------------->PE1 loopback0---->PE2 lookback1
    Status TLV support (local/remote)   : enabled/supported
      LDP route watch                   : enabled
      Label/status state machine        : established, LruRru
      Last local dataplane   status rcvd: No fault
      Last local SSS circuit status rcvd: No fault
      Last local SSS circuit status sent: No fault
      Last local  LDP TLV    status sent: No fault
      Last remote LDP TLV    status rcvd: No fault
      Last remote LDP ADJ    status rcvd: No fault
    MPLS VC labels: local 582, remote 837
    Group ID: local 0, remote 0
    MTU: local 1500, remote 1500
    Remote interface description: L2 MPLS
  Sequencing: receive disabled, send disabled
  Control Word: Off (configured: autosense)
  VC statistics:
    transit packet totals: receive 51, send 105873366
    transit byte totals:   receive 4875, send 91751356572
    transit packet drops:  receive 0, seq error 0, send 0

This is PE1 router configuration:

mpls ldp router-id Loopback0 force
interface Loopback0
ip address 192.168.1.32 255.255.255.255
interface Loopback1
description For L2VPN
ip address 192.168.1.33 255.255.255.255

interface TenGigabitEthernet4/2
mpls ldp discovery transport-address 192.168.1.33
xconnect 192.168.1.34 30 pw-class L2-VPN

PE2 router configuration:

mpls ldp router-id Loopback0 force
interface Loopback0
ip address 192.168.1.117 255.255.255.255
interface Loopback1
description For L2VPN
ip address 192.168.1.34 255.255.255.255

interface TenGigabitEthernet4/1
mpls ldp discovery transport-address 192.168.1.34
xconnect 192.168.1.33 30 pw-class L2-VPN

Thank You

Jeffery

3 REPLIES
New Member

L2VPN LDP session source IP issue

Hi Jeffery,

Share

sho mpls l2transport vc  detail 

  from PE2 also

Try to do "no mpls ip" and "mpls ip" from global - to restart mpls service. Then share

sho mpls l2transport vc  detail  from both PE1 and PE2

New Member

L2VPN LDP session source IP issue

Hello,

Here is PE2 show vc.

I can not restart MPLS servcie, there are lot's of L3 VPN used and used loopback0 as source.

I had restart this l2 VPN many time, but the LDP seesion source not work, always take loopback0.

sho mpls l2transport vc detail

Local interface: Te4/1 up, line protocol up, Ethernet up

  Destination address: 192.168.1.33, VC ID: 30, VC status: up

    Output interface: Te4/2, imposed label stack {352 804}

    Preferred path: not configured 

    Default path: active

    Next hop: 192.168.10.129

  Create time: 00:20:05, last status change time: 00:20:05

  Signaling protocol: LDP, peer 192.168.1.32:0 up

    Targeted Hello: 192.168.1.117(LDP Id) -> 192.168.1.33

--------------->PE2 loopback0---->PE1 lookback1

    Status TLV support (local/remote)   : enabled/supported

      Label/status state machine        : established, LruRru

      Last local dataplane   status rcvd: no fault

      Last local SSS circuit status rcvd: no fault

      Last local SSS circuit status sent: no fault

      Last local  LDP TLV    status sent: no fault

      Last remote LDP TLV    status rcvd: no fault

    MPLS VC labels: local 707, remote 804

    Group ID: local 0, remote 0

    MTU: local 1500, remote 1500

    Remote interface description: For L2VPN

  Sequencing: receive disabled, send disabled

  VC statistics:

    packet totals: receive 98815422, send 46

    byte totals:   receive 87440996674, send 4025

    packet drops:  receive 0, seq error 0, send 0

New Member

L2VPN LDP session source IP issue

Hello

My question is why below command not works under layer 2 interface.

PE1:

mpls ldp discovery transport-address 192.168.1.33 (lookback1)

PE2:

mpls ldp discovery transport-address 192.168.1.34 (lookback1)

PE1

sh mpls ldp discovery | b Targeted Hellos:

     Targeted Hellos:

        192.168.1.32 -> 192.168.1.34 (ldp): active, xmit/recv

            LDP Id: 192.168.1.117:0

PE2

sh mpls ldp discovery | b Targeted Hellos:

    Targeted Hellos:

        192.168.1.34 -> 192.168.1.32 (ldp): passive, xmit/recv

            LDP Id: 192.168.1.32:0

        192.168.1.117 -> 192.168.1.33 (ldp): active, xmit   

Thank You

Jeffery

955
Views
0
Helpful
3
Replies