Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

L2VPN Local Switching VLAN to VLAN issue on 7200VXR/NPE-G1

I've been working with a client trying to get this working. We tried 12.2(31)SB6, 12.4(15)T1 IP Services and 12.4(15)T1 Advanced IP Services.

It works fine for Ethernet to Ethernet, or Ethernet to VLAN, but it doesn't work for VLAN to VLAN either on the same interface or on different interfaces. We've tried this on both a Cat5505 as well as a Cat294XL thinking that maybe there would be some issues with one platform or the other.

Here's an example:

! VXR (12.4(15)T1 Adv. IP Services)

!

interface GigabitEthernet0/1

no ip address

duplex full

speed 100

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/1.202

encapsulation dot1Q 202

!

interface GigabitEthernet0/1.203

encapsulation dot1Q 203

!

connect test GigabitEthernet0/1.202 GigabitEthernet0/1.203

! Cat 5505

!

set vlan 202 9/1

set vlan 203 9/2

set port name 9/1 PC1

set port name 9/2 PC2

set port name 9/3 VXR-G0/1TRUNK

clear trunk 9/3 1-201,204-999

set trunk 9/3 on dot1q 202-203,1000-1005

!

We seem to be able to sequeeze a few packets through every once in awhile - like 1 or 2 every 20 or 30 packets:

64 bytes from 192.168.1.1: icmp_seq=10 ttl=64 time=0.604 ms

64 bytes from 192.168.1.1: icmp_seq=18 ttl=64 time=0.638 ms

64 bytes from 192.168.1.1: icmp_seq=40 ttl=64 time=0.621 ms

64 bytes from 192.168.1.1: icmp_seq=48 ttl=64 time=0.608 ms

64 bytes from 192.168.1.1: icmp_seq=70 ttl=64 time=0.605 ms

64 bytes from 192.168.1.1: icmp_seq=78 ttl=64 time=0.630 ms

As you can see from the below show interface, the interface is receiving lots more packets than it's sending:

Router#show int g0/1

GigabitEthernet0/1 is up, line protocol is up

Hardware is BCM1250 Internal MAC, address is 001c.b0fa.101b (bia 001c.b0fa.101b)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set

Keepalive set (10 sec)

Full Duplex, 100Mbps, RJ45, media type is RJ45

output flow-control is unsupported, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:00:15

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1000 bits/sec, 2 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

40 packets input, 2836 bytes, 0 no buffer

Received 36 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 19 multicast, 0 pause input

8 packets output, 672 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

Router#

Does L2VPN Local Switching VLAN to VLAN not work on VXRs or something?

This link seems to indicate that E-E VLAN is supported in 12.4(11)T.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s27/fslocal.htm#wp1149105

What am I missing?

193
Views
0
Helpful
0
Replies
CreatePlease login to create content