Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

label problem

I have a mpls environment like following:

PE1 tdp<-->tdp P1 tdp<--->tdp P2 ldp<-->ldp PE2

PE1 can't establish the correct LSP to PE2. I use the command"sho mpls forwarding-table x.x.x.x"

x.x.x.x is the loopback address of PE2.

as following____>

M-FZY-7206-0A#sho mpls forwarding-table x.x.x.x

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

130 Untagged x.x.x.x/32 0 PO1/0 point2point

I can't see the tag used in outgoing. how to solve it?

Sincerely

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: label problem

I assume the command was run on PE1, right? This shows that you are receiving a routing advertisement for 211.92.128.50/32 and this is why you generate a local label for it. But you don't receive a label from PE1 for this prefix.

Is is possible you are doing label filtering on PE1

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
7 REPLIES
Cisco Employee

Re: label problem

Could you please do a "sh mpls ldp dis" and "sh mpls ldp nei" on P1 and P2 to make sure your TDP and LDP sessions are up.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: label problem

Strangely, both P1 and P2 can see the lable of outgoing about PE2 through the commmand"sho mpls forwording-table x.x.x.x". In addition, P2 can establish the ldp neighbor well to the PE2. what's problem about this issue?

Sincerely

Cisco Employee

Re: label problem

The problem is either that PE1 doesn't have a TDP neighbor relationship with P1 or it doesn't receive a routing update for the PE2 loopback address. If the problem is the latter, you should still get a label on PE1 for PE2 loopback. Do a "sh mpls ldp binding" to find out if it is the case.

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: label problem

PE1 should have the good TDP neighbor relationship with P1 because other PE not PE2 can communicate with PE1 in mpls environment.

Question is how to analyze the display by using command"sh mpls ldp binding". My display is following:

M-GJSH-7206-0A#sho mpls ldp bind 211.92.128.50 32

tib entry: 211.92.128.50/32, rev 1550

local binding: tag: 82

M-GJSH-7206-0A#sho mpls for

M-GJSH-7206-0A#sho mpls forwarding-table 211.92.128.50

Local Outgoing Prefix Bytes tag Outgoing Next Hop

tag tag or VC or Tunnel Id switched interface

82 Untagged 211.92.128.50/32 0 PO1/0 point2point

211.92.128.50 is the loopback address of PE2.

Could you give me any suggestion about my issue?

Thanks

Sincerely

Cisco Employee

Re: label problem

I assume the command was run on PE1, right? This shows that you are receiving a routing advertisement for 211.92.128.50/32 and this is why you generate a local label for it. But you don't receive a label from PE1 for this prefix.

Is is possible you are doing label filtering on PE1

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: label problem

There was not label filtering on PE1. I just add these configurations on PE1:

no mpls ldp logging neighbor-changes

no tag-switching advertise-tags

tag-switching advertise-tags for 80

tag-switching tdp router-id Loopback0

access-list 80 permit 211.92.128.0 0.0.0.63

the 7200's version is System image file is "disk0:c7200-js-mz.122-12.bin"

New Member

Re: label problem

Hi,thank you very much. I have solved my problem.

P1 have limited the tag advertising for PE1. so I removed the limit from P1. everything is ok.

Sincerely

206
Views
0
Helpful
7
Replies
CreatePlease login to create content