Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Match Class Qos GSR

Hello,

I'm planning QoS to GSR Routers, this moment I have 7500 routers working, and QoS is configured. Now I need to change to GSR and this routers does not support "match class-map ...".

Does anyone help with material to study about QoS in GSR or a solution to this case?

Thanks

CLRGomes

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Match Class Qos GSR

Hi,

this might be interesting for you:

"Unified QoS - Locally Generated Packet Prioritization on Cisco 12000 Series Router, Integrated Services Engine (ISE) Line Cards"

http://www.cisco.com/en/US/products/sw/iosswrel/ps1829/products_feature_guide09186a00805e8fc9.html

Regards, Martin

6 REPLIES

Re: Match Class Qos GSR

Hi Cassio,

May be you can paste out samples of your Edge & Core QOS Configs.

We would try to help you implement the equivalent on a GSR.

HTH-Cheers,

Swaroop

New Member

Re: Match Class Qos GSR

Hi Swaroop,

Thanks your post.

of course, I'm copying the old configuration, on 7500 router to you see.

!

class-map match-all CLASS_1_NOTIP

match not protocol ip

match not mpls experimental topmost 4

match not mpls experimental topmost 3

match not mpls experimental topmost 2

match not mpls experimental topmost 1

match not mpls experimental topmost 0

match not protocol clns

class-map match-any CLASS_1

match ip precedence 5

match mpls experimental topmost 5

match ip precedence 6

match mpls experimental topmost 6

match ip precedence 7

match mpls experimental topmost 7

match class-map CLASS_1_NOTIP

class-map match-any CLASS_3

match ip precedence 3

match mpls experimental topmost 3

class-map match-any CLASS_2

match ip precedence 4

match mpls experimental topmost 4

class-map match-any CLASS_4

match ip precedence 2

match mpls experimental topmost 2

!

!

policy-map qos_policy

class CLASS_1

priority percent 75

class CLASS_2

bandwidth percent 10

class CLASS_3

bandwidth percent 10

class CLASS_4

bandwidth percent 4

class class-default

bandwidth percent 1

!

I configured a new script to GSR 12400, and it is working only to traffic that is crossing the router GSR. Now I need to configure anything to priorize the traffic generated by itself, for example, telnet or snmp.

Thanks a lot

CLRGomes

Re: Match Class Qos GSR

Hi,

prioritizing local traffic is supported. One example config (not from a GSR though) would be:

class-map match-all NMS

match ip precedence internet ! 6

!

!

policy-map Test

class NMS

bandwidth percent 10

class class-default

fair-queue

random-detect precedence

!

interface Serial0/0

service-policy output Test

!

ip local policy route-map LocalIPP6

!

ip access-list extended NMS

10 permit tcp any any eq telnet

20 permit tcp any eq telnet any

30 permit tcp any any eq ssh

40 permit tcp any eq ssh any

50 permit udp any any eq domain

60 permit udp any any eq tftp

70 permit udp any any eq snmptrap

80 permit udp any eq snmp any

!

route-map LocalIPP6 permit 10

match ip address NMS

set ip precedence internet

Here I am marking everything locally originated and considered "useful" with IP precedence 6. You could also mark it with experimental bits in the same step, but it should be done automatically (copy IP precedence to mpls exp bits).

Of course you have to adjust the exp bits, ACLs and so on to your environment. The important command for marking local traffic in the config above is: "ip local policy route-map LocalIPP6".

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: Match Class Qos GSR

my friend, thanks again,

I know this example, and I use this oin 7500 router, but in GSR 12400 this config is not supported.

look this example:

Router(config)#ip local policy route-map LocalIPP6

^

% Invalid input detected at '^' marker.

Router(config)#do sh ver

Cisco Internetwork Operating System Software

IOS (tm) GS Software (C12KPRP-K4P-M), Version 12.0(32)S4, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by cisco Systems, Inc.

Compiled Wed 16-Aug-06 18:45 by leccese

Image text-base: 0x00010000, data-base: 0x05178000

ROM: System Bootstrap, Version 12.0(20041021:161156) [wdai-v120_30_s 1.15] RELEASE SOFTWARE

BOOTLDR: GS Software (C12KPRP-K4P-M), Version 12.0(32)S4, RELEASE SOFTWARE (fc1)

Router uptime is 1 day, 54 minutes

Uptime for this control processor is 1 day, 54 minutes

System returned to ROM by reload at 16:59:06 UTC Tue Aug 29 2006

System image file is "disk0:c12kprp-k4p-mz.120-32.S4.bin"

cisco 12410/PRP (MPC7450) processor (revision 0x00) with 524288K bytes of memory.

MPC7450 CPU at 665Mhz, Rev 2.1, 256KB L2, 2048KB L3 Cache

Last reset from sw reset

1 Route Processor Card

2 Clock Scheduler Cards

5 Switch Fabric Cards

1 Quad-port Edge-Engine OC3 ATM controller (4 ATM).

1 16-port OC3 POS controller (16 POS).

1 Four Port Gigabit Ethernet/IEEE 802.3z controller (4 GigabitEthernet).

2 Ethernet/IEEE 802.3 interface(s)

4 GigabitEthernet/IEEE 802.3 interface(s)

4 ATM network interface(s)

16 Packet over SONET network interface(s)

2043K bytes of non-volatile configuration memory.

62720K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).

65536K bytes of Flash internal SIMM (Sector size 256K).

Configuration register is 0x2102

I think there is another config to mark local traffic, but I'm not sure.

Thanks

CLRGomes

Re: Match Class Qos GSR

Hi,

this might be interesting for you:

"Unified QoS - Locally Generated Packet Prioritization on Cisco 12000 Series Router, Integrated Services Engine (ISE) Line Cards"

http://www.cisco.com/en/US/products/sw/iosswrel/ps1829/products_feature_guide09186a00805e8fc9.html

Regards, Martin

New Member

Re: Match Class Qos GSR

Hi Martin,

I saw this document and solve my problem, I could understand how it works, very well. My QoS is done!

Thanks everybody

CLRGomes.

255
Views
0
Helpful
6
Replies