Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MED gets lost over EBGP

Hi,

I can see a router (Cisco) propogating MED value to ebgp neighbor (ERX Juniper) but cannot see MED value in ERX..

I used this command to see if Cisco advertises MED

CISCO#sh ip bgp vpnv4 vrf XXXX neighbor ERX_IP advertised-route

I can see the MED value here

BUT I dont see any MED when I do

ERX# sh ip bgp neigh CISCO routes

everything ok just MED is lost.

can any body comment.

Assume Config is good as there are other routers (Cisco) sending MED to ERX it fine in that case..

Any help..

G

regards,

Gaurav

11 REPLIES
Cisco Employee

Re: MED gets lost over EBGP

Gaurav,

Any possibility of setting up a sniffer trace between the two boxes and verifying that the MED is being sent in the BGP update.

Thanks,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: MED gets lost over EBGP

I guess Cisco must be sending it as it shows in the sh ip bgp nei..ERX advertise command ...any other guess for the moment as right now it is not possible..

Cisco Employee

Re: MED gets lost over EBGP

Oh well, I tried ;o) Can you provide a "show ip bgp x.x.x.x" for one of the prefixes showing this issue.

Thanks,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Silver

Re: MED gets lost over EBGP

Just thinking, is the MED getting reset ? So where is the origin of the prefix, are you receiving it over a ebgp session and sending it out through another ?

Cisco Employee

Re: MED gets lost over EBGP

Good point. I assumed the MED was originated by the advertising router but if it was received from another AS, it will not propagate beyond the local AS.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: MED gets lost over EBGP

The prefix is being learnt by this Cisco ( in question) via iBGP session from other cisco.

Can you explain your above point..

Thx in adv

G

Cisco Employee

Re: MED gets lost over EBGP

The question is, is the MED being inserted by a router in the AS where the router in question is or by a router in a peer AS?

If the answer is the latter then it explains why the MED is not being propagated to the ERX, which resides in an another AS.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
New Member

Re: MED gets lost over EBGP

Thx ..

MED is being inserted by a router in the same AS where the CISCO in question is...through iBGP...

Regards,

G

Silver

Re: MED gets lost over EBGP

Just to probe further, how are injecting the route in the other PE into IBGP? Redistributing static or some routing protocol ? Also what does the equivalent of 'sh ip bgp' for the prefix on the juniper give you ?

New Member

Re: MED gets lost over EBGP

CISCO1(AS XXX) ------ibgp---CISCO2(AS XXX)---eBGP----ERX_2 (AS YYY)

1.CISCO1 redistributes rip to BGP and this is the source of MED and gets propogated to CISCO2 (iBGP)..

2. CISCO1 has eBGP with ERX_1 (AS YYY) and there I can see MED .

3. BUT on ERX_2 connected to CISCO2 ( router in question) I see MED not present..even if I do sh ip bgp neighbour CISCO2 recieved-routes on ERX_2. ALso CISCO2 is connected to ERX_1 , same problem here..CISCO2 sends MED to ERX1 but I cannot see MED on ERX1..even..

BOTH ERX in AS (YYY) & both CISCO in AS(XXX).

rest everything is ok..this problem is not route specific..something to do with CISCO2 + ERX setup ..may be some IOS issue...wild guess..

Cisco Employee

Re: MED gets lost over EBGP

Gaurav,

The best way to make sure whether the metric is sent or not would be to do the following:

- create an access-list to permit one of the prefixes showing the problematic behavior as follow.

access-list 1 permit 192.168.1.0

- issue the "deb ip bgp update 1"

- issue a "clear ip bgp soft out" to force the updates to be resent.

This should give you an output similar to that:

r1#clear ip bgp 192.168.12.2 soft out

00:18:07: BGP(0): 192.168.12.2 send UPDATE (format) 192.168.1.0/24, next 192.168.12.1, metric 0, path

This will tell you exactly what MED is sent to the ERX. If you see the MED is sent correctly you can then turn to the ERX and troubleshoot from there.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
186
Views
0
Helpful
11
Replies
CreatePlease login to create content