Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

MPLS and GRE tunnel

Hi All,

I have lab configured like the diagram.my problem is when i configure a tunnel interface on ce1 with tunnel source interface s1/0 which is connected to PE1 and tunnel destination is the ip address of Ce2 which is connected to PE2.

OSPF is used for CE-PE connectivity and PE to PE it is running BGP.

error message which comes in the both router is tunnel interface going down because of recurcive lookup.

please help.

Kamlesh

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: MPLS and GRE tunnel

This is the link for sham-links

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087ce2.html

But really your topology is suprising. What exactly are you trying to do ?

8 REPLIES
Silver

Re: MPLS and GRE tunnel

The most likely reason for a tunnel going down is recursive lookup. This happens when the route for the tunnel destination is via the tunnel itself.

Check

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094690.shtml

In your situation, I think OSPF adjacency is formed across the tunnel interfaces as well, when the tunnels comes up, and the address for CE2 is not learnt via the tunnel.

Try to change the mask in your OSPF configuration to ensure that the tunnel is not part of the ospf process. If it is a requirement, for OSPF to be formed across the tunnel interfaces, then you might want to use static host routes to ensure that the route for the tunnel destinations is never through the tunnel.

HTH

Community Member

Re: MPLS and GRE tunnel

thanks for reply

But my question why it happens if bandwidth of the tunnel interface is less than serial interface than it should always prefer the serial interface not tunnel.

?????

Thanks Kamlesh

Silver

Re: MPLS and GRE tunnel

It will be hard to answer the question without seeing your configuration. However, note that OSPF actually uses a cost for metric calculation. So while the bandwidth on the tunnel interface might be less than the serial, the cost associated with the prefix is not neccessarily so.

Let me try and explain further.

If the tunnel interface is configured for a bandwidth of 1Mb, then the OSPF cost will be 100/1 or 100. Since the tunnel is like a point to point link to CE2, then CE2 local prefixes will have a cost of 100 from the tunnel interface.

If serial interface is configured for 2Mb, then the cost is 100/2 or 50. This cost is added to the advertised one from the PE. If the PE advertises a cost of 100, then cost for prefixes from CE2 will now be 150. Therefore the prefixes from the tunnel will be preferred and entered into the routing table.

Community Member

Re: MPLS and GRE tunnel

thanks again for your reply here i am posting my config according to your colculation it is possibe reason. but in my configuration ospf is in area 0 only and what i am thinking is when PE advertises the routing update to

PE device it comes as inter-area OIA whatever it is.

it my situation it is happening 55.55.55.5/32 route is coming as OIA in routing table but there i don't have any area other than backbone area 0. just have a look at the configuration and suggest me.

hostname RA

ip cef

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

ip address 202.41.3.1 255.255.255.252

interface FastEthernet0/0

ip address 11.11.11.1 255.255.255.0

!

interface Serial1/0

ip address 10.1.12.1 255.255.255.252

!

router ospf 100

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.1.12.0 0.0.0.255 area 0

network 11.11.11.0 0.0.0.255 area 0

!

------

hostname RB

ip cef

ip vrf vpan

description VPNA for customer A

!

ip vrf vpna

rd 1:100

route-target export 1:100

route-target import 1:100

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface Serial1/0

ip vrf forwarding vpna

ip address 10.1.12.2 255.255.255.252

!

interface Serial1/1

ip address 10.1.23.2 255.255.255.0

mpls ip

!

router ospf 100 vrf vpna

log-adjacency-changes

redistribute bgp 1 metric 20 subnets

network 10.1.12.0 0.0.0.255 area 0

!

router ospf 1

log-adjacency-changes

network 2.2.2.2 0.0.0.0 area 0

network 10.1.23.0 0.0.0.255 area 0

!

router bgp 1

bgp log-neighbor-changes

neighbor 4.4.4.4 remote-as 1

neighbor 4.4.4.4 update-source Loopback0

!

address-family ipv4

neighbor 4.4.4.4 activate

no auto-summary

no synchronization

exit-address-family

!

address-family vpnv4

neighbor 4.4.4.4 activate

neighbor 4.4.4.4 send-community extended

exit-address-family

!

address-family ipv4 vrf vpna

redistribute ospf 100 vrf vpna

no auto-summary

no synchronization

exit-address-family

!

address-family ipv4 vrf vpan

no auto-summary

no synchronization

exit-address-family

!

------

hostname RC

ip cef

!

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface Loopback1

ip address 202.41.2.1 255.255.255.0

!

interface Serial1/0

ip address 10.1.34.3 255.255.255.0

mpls ip

!

interface Serial1/1

ip address 10.1.23.3 255.255.255.0

mpls ip

!

router ospf 1

log-adjacency-changes

network 3.3.3.3 0.0.0.0 area 0

network 10.1.0.0 0.0.255.255 area 0

network 202.41.2.0 0.0.0.255 area 0

------

hostname RD

ip cef

!

ip vrf vpna

rd 1:100

route-target export 1:100

route-target import 1:100

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

!

interface Serial1/0

ip address 10.1.34.4 255.255.255.0

mpls ip

!

interface Serial1/1

ip vrf forwarding vpna

ip address 10.1.45.4 255.255.255.0

!

router ospf 100 vrf vpna

log-adjacency-changes

redistribute bgp 1 metric 20 subnets

network 10.1.45.0 0.0.0.255 area 0

!

router ospf 1

log-adjacency-changes

network 4.4.4.4 0.0.0.0 area 0

network 10.1.34.0 0.0.0.255 area 0

!

router bgp 1

bgp log-neighbor-changes

neighbor 2.2.2.2 remote-as 1

neighbor 2.2.2.2 update-source Loopback0

!

address-family ipv4

neighbor 2.2.2.2 activate

no auto-summary

no synchronization

exit-address-family

!

address-family vpnv4

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 send-community extended

exit-address-family

!

address-family ipv4 vrf vpna

redistribute ospf 100 vrf vpna

no auto-summary

no synchronization

exit-address-family

------

hostname Re

ip cef

!

interface Loopback0

ip address 5.5.5.5 255.255.255.255

!

interface FastEthernet0/0

ip address 55.55.55.5 255.255.255.0

!

interface Serial1/1

ip address 10.1.45.5 255.255.255.0

!

router ospf 100

log-adjacency-changes

network 5.5.5.5 0.0.0.0 area 0

network 10.1.45.0 0.0.0.255 area 0

network 55.55.55.0 0.0.0.255 area 0

Silver

Re: MPLS and GRE tunnel

Seeing the route as an O IA is normal behaviour as in MPLS-VPN the MPLS core will act as a super backbone and hence O routes in one PE will appear as O IA after it crosses the MPLS backbone. To override this behaviour, configure OSPF sham-links between the PEs which will retain the routes as the O routes. I think in this case the tunnel is acting as a backdoor link and hence it learns the prefixes as O routes instead of the O IA from the Serial. Configure sham-links and i think it will work fine.

Community Member

Re: MPLS and GRE tunnel

Hi Gautam,

Thanks for your reply.

It's true in my topology route are coming OIA from physical interface and and O from tunnel interface. so i think your suggestion will be great to solve thins problem.

could you please give me the configuration according to my setup given above.

Thanks

kamlesh

Silver

Re: MPLS and GRE tunnel

This is the link for sham-links

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080087ce2.html

But really your topology is suprising. What exactly are you trying to do ?

Community Member

Re: MPLS and GRE tunnel

Hi Gautam,

Thanks for your reply.

Link is very usefull. about my topology it is just for study purpose nothing else.

Thanks

186
Views
15
Helpful
8
Replies
CreatePlease to create content