Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MPLS ATM

Hi guys,

I need your help on checking my mpls atm configuration. I'm not sure if I configure it

and understand the terms using to call each mpls atm scenario correctly. (it's working though)

#1. Frame Based MPLS ATM

ls1010

interface atm3/0/0

atm pvc 1 50 interface atm3/0/1 1 100

PE1

interface loopback0

ip address 11.11.11.11 255.255.255.255

interface atm1/0

no shut

interface atm1/0.1 point-to-point

ip address 10.1.1.1 255.255.255.252

mpls label protocol tdp

mpls ip

pvc 1/50

protocol ip 10.1.1.2 broadcast

router ospf 1

router-id 11.11.11.11

network 10.1.1.1 0.0.0.0 area 0

network 11.11.11.11 0.0.0.0 area 0

PE2

interface loopback0

ip address 22.22.22.22

interface atm1/0

no shut

interface atm1/0.1 point-to-point

ip address 10.1.1.2 255.255.255.252

mpls label protocol tdp

mpls ip

pvc 1/100

protocol ip 10.1.1.1 broadcast

router ospf 1

router-id 22.22.22.22

network 10.1.1.2 0.0.0.0 area 0

network 22.22.22.22 0.0.0.0 area 0

#2. Cell Based MPLS ATM

ls1010

interface loopback0

ip address 33.33.33.33 255.255.255.255

interface atm3/0/0

ip address 10.1.1.2 255.255.255.252

atm vpi 2-4

tag-switching ip

interface atm3/0/1

ip address 10.2.2.2 255.255.255.252

atm vpi 2-4

tag-switching ip

router ospf 1

network 10.1.1.2 0.0.0.0 area 0

network 10.2.2.2 0.0.0.0 area 0

network 33.33.33.33 0.0.0.0 area 0

PE1

interface loopback0

ip address 11.11.11.11 255.255.255.255

interface atm1/0

no shut

interface atm1/0.1 mpls

ip address 10.1.1.1 255.255.255.252

mpls label protocol tdp

mpls ip

mpls atm vpi 2-4 vci-range 33-65535

router ospf 1

router-id 11.11.11.11

network 10.1.1.1 0.0.0.0 area 0

network 11.11.11.11 0.0.0.0 area 0

PE2

interface loopback0

ip address 22.22.22.22 255.255.255.255

interface atm1/0

no shut

interface atm1/0.1 mpls

ip address 10.2.2.1 255.255.255.252

mpls label protocol tdp

mpls ip

mpls atm vpi 2-4 vci-range 33-65535

router ospf 1

router-id 22.22.22.22

network 10.2.2.1 0.0.0.0 area 0

network 22.22.22.22 0.0.0.0 area 0

#3. VP TUNNEL MPLS ATM

ls1010

interface atm3/0/0

atm pvp 3 interface atm3/0/1 4

PE1

interface loopback0

ip address 11.11.11.11 255.255.255.255

interface atm1/0

no shut

interface atm1/0.1 mpls

ip address 10.1.1.1 255.255.255.252

mpls label protocol tdp

mpls ip

mpls atm vp-tunnel 3 vci-range 33-65535

router ospf 1

router-id 11.11.11.11

network 10.1.1.1 0.0.0.0 area 0

network 11.11.11.11 0.0.0.0 area 0

PE2

interface loopback0

ip address 22.22.22.22 255.255.255.255

interface atm1/0

no shut

interface atm1/0.1 mpls

ip address 10.1.1.2 255.255.255.252

mpls label protocol tdp

mpls tdp

mpls atm vp-tunnel 4 vci-range 33-65535

router ospf 1

router-id 22.22.22.22

network 10.1.1.2 0.0.0.0 area 0

network 22.22.22.22 0.0.0.0 area 0

Some SP workbook ask you to configure MPLS Cell Based ATM

but their answer is as in #3 which I call VP Tunnel.

Now , I confused. Please clarify.

Thank You

1 REPLY

Re: MPLS ATM

Dear

VP is designed to connect tow ATM (Switches) domains across public ATM network

The public ATM network switch based on the VPI value only

anyway take care that, To enable Cell-mode MPLS across VP the control-VC should use the same VPI of the VP

Best Regards,

Mounir Mohamed

117
Views
0
Helpful
1
Replies