Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS Between Cisco and Juniper Not Working

Hi,

MPLS is not really my thing but I am trying to get it working between a cisco 7200 and a third parties juniper. We can't get the 2 to see each other as MPLS neighbours. I am probably doing something fundamentally wrong but don't know what. Here is the revelant parts of the config

Cisco

mpls label protocol ldp

mpls ldp logging neighbor-changes

!

ip address x.x.x.x y.y.y.y

duplex auto

speed auto

media-type rj45

no negotiation auto

mpls label protocol ldp

tag-switching ip

no cdp enable

Juniper (relevant int is 3/0/7) config attached

Any help or example of configs (cisco and Juniper would be good)

5 REPLIES
Cisco Employee

Re: MPLS Between Cisco and Juniper Not Working

On the Cisco config you have pasted in, I don't see where you've defined an LDP router id.

Make sure you define an LDP router-id if you haven't already done so.

mpls ldp router-id Loopback0 or whatever interface you want to be the LDP router-id

New Member

Re: MPLS Between Cisco and Juniper Not Working

Jay,

Thanks, There was no route to router id. Which now I think about it was exactly the same problem I had last time I played with MPLS

New Member

Re: MPLS Between Cisco and Juniper Not Working

Based on my experience, we find Juniper ENET MTU is 14 bit higher than Cisco. So, in my configuration, if we want to support MPLS MTU up to 1628 in Cisco, we have to set MTU 1642 in Juniper.

interface GigabitEthernet0/3

mtu 1628

ip address x.x.x.x y.y.y.y

load-interval 30

duplex full

speed 1000

media-type gbic

negotiation auto

mpls label protocol ldp

tag-switching ip

end

ge-1/0/0 {

mtu 1642;

unit 0 {

family inet {

address x.x.x.x/30;

}

family mpls;

}

}

Hope it helps.

Brgds,

Dili

New Member

Re: MPLS Between Cisco and Juniper Not Working

It looks like their rate-limiter is blocking ldp. Ask them to remove it temporarily to see if you can peer or do add the following.

set firewall filter Synetrix-Rate-Limit term my-ldp from source-port ldp

set firewall filter Synetrix-Rate-Limit term my-ldp then accept

set firewall filter Synetrix-Rate-Limit term ldp-to-me from destination-port ldp

set firewall filter Synetrix-Rate-Limit term ldp-to-me then accept

New Member

Re: MPLS Between Cisco and Juniper Not Working

Hi ,

A quick look at the juniper config is fine.

Can you enable the traceoptions under protocols ldp and view the log file (run file show /var/log/ldp-trace (ldp-trace.0, ldp-trace.1 etc) to see whether the ldp hello packets are sent / received on the interface or any errors in the log.

set protocols ldp traceoptions file ldp-trace size 1m files 10

set protocols ldp traceoptions flag packet

set protocols ldp traceoptions flag error

Also post the ldp-trace log here so that i can help you.

Thanks

Venu

2814
Views
0
Helpful
5
Replies