Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

MPLS configuration example

I 'm looking for a simple configuration of MPLS between 3 routers (or 2 routers).

Somebody can help me ?

Best regards.

10 REPLIES

Re: MPLS configuration example

Dear stephtchoko,

MPLS is a great technologies it’s easy to take and running script from the internet and post it on your router then everything gone be working but it’s very nice to understand how it’s working because your life gone be under control (I mean you have to understand the technologies how it’s works to troubleshoot your network in any case)

Here is a simple configuration to get mpls working with 2 routers

Topology: Router1 Serial0 connected with Router2 via Serial2

Router1 S0/0  Router2 S0/0

((Router1))

Router1(config)# ip cef

Router1(config)# mpls label protocol tdp

Router1(config)# tag-switching tdp router-id serial0/0

Router1(config)# mpls ldp logging neighbor-changes

interface Serial0/0

ip address 172.16.1.1 255.255.255.252

no shut

tag-switching ip

((Router2))

Router2(config)# ip cef

Router2(config)# mpls label protocol tdp

Router2(config)# tag-switching tdp router-id serial0/0

Router2(config)# mpls ldp logging neighbor-changes

interface Serial0/0

ip address 172.16.1.2 255.255.255.252

no shut

tag-switching ip

please be informed that you have to use any routing protocol to start advertise the L3 information.

http://www.cisco.com/en/US/tech/tk436/tk428/technologies_configuration_example09186a0080093fcc.shtml

Best Regards,

Mounir Mohamed

New Member

Re: MPLS configuration example

i built my test mpls network using this page

http://www.informit.com/articles/article.asp?p=391649&seqNum=2&rl=1

and 3 x 2811 routers (2 PE's and 1 P)

and 2 x 2621 routers as the "CE" which dont run MPLS themselves...

Re: MPLS configuration example

the document is good, but is everything working with you or you facing a problem?

New Member

Re: MPLS configuration example

yes, ThanK.This is my first experience with this protocol (MPLS).Which type of routing protocol ( isis, ospf) do you think, it is more adapatable with mpls in isp network ?

Best regards

Re: MPLS configuration example

ISIS is recommended in service provider networks and it's more sclabel than OSPF

New Member

Re: MPLS configuration example

please what is main reason isis is more scalable than ospf ?

Best regards.

Re: MPLS configuration example

Dear Steph,

Kindly check the following URL

http://www.cisco.com/en/US/tech/tk436/tk428/technologies_configuration_example09186a0080093fcc.shtml

Best Regards,

Mounir Mohamed

New Member

Re: MPLS configuration example

Hi

H r u

I am Abdul Khadeer from chennai . i had compeleted the ccna course but not certification .plz if do u have any dumps plz send it to me .so I am planing to give the exam

New Member

Re: MPLS configuration example

Here's a copy of the configuration that I had on my two lab PE routers that was testing multicast tunneling through mpls. You will need two CE routers for a total of four routers. It's not a perfect config (the traffic engineering is only half begun) but it will get you going.

New Member

Re: MPLS configuration example

Hi

You may find some valuable infos here at http://ciscorouterconfig.blogspot.com/

jasrine47

http://ciscorouterconfig.blogspot.com/

1412
Views
4
Helpful
10
Replies