Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MPLS COS

I have private IP WAN (fR), which consists of 5 branch offices in different cities and a head office, I want to have all citrix traffic (port 1494) to get priority over all other traffic in these branch offices connected to the head office via MPLS based core. The serial interfaces of branch offices routers communicate through an MPLS network (managed by provider) before it communicate with our head office.

My question is regarding the configuration required to achieve this task, is it only require configuring CE routers in my branch offices?

with something like this?

class-map match-any citrix

match protocol citrix

policy-map cit-traffic

class citrix

set precedence 5

int serial 0/0

service-policy output cit-traffic

The reading i have done so far, states that there needs to be some work done on PE router (setting experimental value) when marked packets entering MPLS network.

Can someone put some light on this to clarify my concept?

Regards,

Muhammad

7 REPLIES

Re: MPLS COS

TO achieve the prioeirty for citrix traffic what you can do is:

1) Contact your SP and tell him that you need highest priority SLA for citrix traffic.

And specify you are going ot mark citrix traffic as prec 5.

2) In return he would set all the incoming prec 5 traffic to EXP 5 and take it through his core as pr the SLA committed to you.

So ideally you donnot need to do much, when you expect QOS from a MPLS cloud. As the SP takes care of the same for you.

Only Thing which you have to do is classification and marking (CU marking) of the traffic. You should be doing this on both end CE's.

HTH-Cheers,

Swaroop

New Member

Re: MPLS COS

Hi Swaroop,

Thanks for your reply, my service provider is saying they will not do anything in MPLS cloud, so all i can do is on CEs,

Is specific protocol priority still achievable?

Muhammad

Re: MPLS COS

IF the SP says he will not do anything in the MPLS cloud, then you can ask him waht is the trust mapping he has configured, and also confirm with him whether he has any QOS implemented in his core at all.

If he has basic trust mapping of PREC-EXP then your PREC 5 should be treated as EXP 5.

Or he will have to do the same, or else if he is doing a FIFI through his core and till the point there is no congestion in his CORE it will not affect your applications, whatever priority they are.

HTH-Cheers,

Swaroop

New Member

Re: MPLS COS

I have applied the following on headoffice and 2 branch offices, but i dont see any packets marked in branch offices with what i have set, i can see packets marked in the one applied in headoffice

class-map match-all ica-rdp

match protocol citrix

match access-group 100

!

!

policy-map high

class ica-rdp

set ip precedence 5

priority percent 50

class class-default

bandwidth percent 25

branch1#sh policy-map interface

Serial0/0/0.16: DLCI 16 -

Service-policy output: high

Class-map: ica-rdp (match-all)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: protocol citrix

Match: access-group 100

QoS Set

precedence 5

Packets marked 0

Queueing

Strict Priority

Output Queue: Conversation 72

Bandwidth 50 (%)

Bandwidth 524 (kbps) Burst 13100 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

37692 packets, 6430816 bytes

5 minute offered rate 75000 bps, drop rate 0 bps

Match: any

Queueing

Output Queue: Conversation 73

Bandwidth 25 (%)

Bandwidth 262 (kbps)Max Threshold 64 (packets)

(pkts matched/bytes matched) 1244/1175530

(depth/total drops/no-buffer drops) 0/0/0

Another thing i can not understand is why applying this service-policy as outgoing on my branch offices routers, because the traffic we want to control/protect in branch office will be inbound and outbound for headoffice router.

Re: MPLS COS

Hello,

the problem could be your class-map:

class-map match-all ica-rdp

match protocol citrix

match access-group 100

This will only match traffic with citrix ports and also matching the ACL 100. So if the ACL is not written properly, then potentially no traffic will match. Can you post the ACL 100?

Alternatively you could use "match-any":

Router(config)#class-map match-any ica-rdp

Router(config-cmap)#end

But without knowing the ACL it is hard to give an advice.

Regards, Martin

New Member

Re: MPLS COS

here is the acl

access-list 100 permit tcp any any eq 3389

Muhammad

Re: MPLS COS

Hi, are you sure the ACL should not be

access-list 100 permit tcp any eq 3389 any

This will depend on the traffic flow aka server location with respect to the service-policy direction.

Also be aware that in any case you need "match-any" to be configured for your class-map. The reason is that "match protocol citrix" will match on:

sh ip nbar port-map citrix

port-map citrix udp 1604

port-map citrix tcp 1494

So no traffic can have 3389 AND 1494 as TCP port and therefore no traffic is sorted into your class. So try the suggested config in my previous post and give us the results.

Hope this helps! Please rate all posts.

Regards, Martin

179
Views
0
Helpful
7
Replies
CreatePlease to create content