Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

MPLS doesnt work with edundant link

The P router is connected with PE via 2 link. One is working as primary, and other one working as secondry. When i shut down the primary link, the MPLS traffic works well. But, when i bring the primary link up and shut down the secondry link, MPLS traffic doesn't work. Whereas, there is no problem in the normal IP traffic. But, when i shut and no shut the primary interface, MPLS traffic starts working normal. What could be the problem? Attached is the configuration of PE device for your refrence? By the way, P device is from Huawei. I really need to solve this problem as soon as possible. Please respond.

interface GigabitEthernet3/4

description __________________________

ip address 72.178.x.x.255.255.252

ip ospf message-digest-key 1xxx

ip ospf cost 100

speed nonegotiate

mpls label protocol ldp

tag-switching ip

no cdp enable

end

interface GigabitEthernet3/3

description _______________________

ip address 52.178.x.x.255.255.252

ip ospf message-digest-key xxx

speed nonegotiate

mpls label protocol ldp

tag-switching ip

no cdp enable

5 REPLIES

Re: MPLS doesnt work with edundant link

Hi Shahnawaz,

How are you manipulating the cost on the Huawei side. Anyways.. before we try it would like to understand, why do you want only one link to be active at a time.

====================

Would suggest dont use the cost to set your primary and secondary. Simply run them at defaults and let the P and PE load balance over them.

When one link fails the other one would take over. This is the general practise followed for dual homeing scenarios's, untill u have a very specific reason to do so.

====================

Do reply back once you do it.

HTH-CHeers,

Swaroop

Re: MPLS doesnt work with edundant link

Hi,

In fact it should work except of maybe a transient connectivity break because of a race condition. OSPF and LDP will start sending hellos and setting up adjacencies and LDP session, respectively.

Once OSPF is converged it will start using the new/reenabled link. OSPF routing decision does not take LDP availability into account. So when LDP is not ready yet, but OSPF decides to send all traffic over the primary link, there are no labels yet (show mpls forwarding-table, search for "untagged"). Thus connectivity for VPN traffic is broken.

One way of overcoming this is to use targeted LDP:

R(config)# mpls ldp neighbor x.x.x.x targeted ldp

This means the LDP session is kept even if the interface is down, as long as x.x.x.x has IP connectivity.

Now all this said, it should recover without manual intervention. Your config looks fine to me. Have you checked, what the underlying problem is?

show mpls ldp discovery ! are LDP hellos sent and received after link recovery?

show mpls ldp neighbor ! is LDP session reestablished?

show mpls forwarding-table ! are labels entered into LFIB after link recovery?

Targeted LDP might still solve your problem, because you would not loose the LDP session.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: MPLS doesnt work with edundant link

Thank you very much to both of you for your quick reply.I am also facing the problem with load balancing, this is the reason that redundany is being used. But, in the case of load-balancing, the MPLS trafic works fine for weeks; and suddenly the problem starts.In order to solve this issue, I thought to use the redundancy option. Equal cost (100) that of the Cisco is configured on the gig interface o Huawei router.

Now coming to mheusinger answer, I didn't try the target ldp command, but I have tried the following command on the Cisco 6509: -

router id loopbak 1

discovery targeted-hello accept

One more thing, I would like to say here is that when I do the continous ping, I have noticed that MPLS traffic works till the OSPF database is full. Once the OSPF database is full, the ping stops.

Do i need to put the loopback IP of the Huawei router or gig interface, while configuring the targeted ldp? LDP session is established in the beining, but stops later on i think. Can we configure the target ldp for point to point link or is it for teh router, which is some hop away?

Thanks again and look forward to your reply.

Re: MPLS doesnt work with edundant link

Hi,

you should always use the Loopback as LDP ID.

The LDP ID is used to setup the TCP session to port 646. So it would be best to configure:

mpls ldp router-id Loopback1

Otherwise, when the interface IP is as LDP ID used you will loose LDP sessions (and all labels), when the interface goes down.

Regards, Martin

New Member

Re: MPLS doesnt work with edundant link

Hello,

Thanks a lot. My doubts are cleared now. I shall try this.

Shahnawaz

291
Views
0
Helpful
5
Replies
CreatePlease to create content