Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

MPLS Inter VRF route leaking

Hi,

is it possible to leake a route from one VRF to another VRF on the Same PE. without having a RR in picture.

Regards,

Rajiv Mahuli

4 REPLIES

Re: MPLS Inter VRF route leaking

Dear rajivmahuli1982,

yes, but you must use the

import functionality of route-target and enable Border Gateway Protocol (BGP) on the router, This solution documented by Cisco in the below URL.

http://www.cisco.com/en/US/tech/tk436/tk832/technologies_configuration_example09186a0080231a3e.shtml

There is some changes in the below example as this is my self test for this document.

ip vrf VRF-A

rd 1:1

route-target export 1:1

route-target import 1:1

route-target import 2:1

!

ip vrf VRF-B

rd 2:1

route-target export 2:1

route-target import 2:1

route-target import 1:1

!

interface Serial1/0

ip vrf forwarding VRF-A

ip address 192.168.99.1 255.255.255.0

!

interface Serial1/1

ip vrf forwarding VRF-B

ip address 172.16.10.1 255.255.255.0

router bgp 1

!

address-family ipv4 vrf VRF-A

redistribute connected

!

address-family ipv4 vrf VRF-B

redistribute connected

Best Regards,

Mounir Mohamed

New Member

Re: MPLS Inter VRF route leaking

Hi Mounir,

thanks for the reply but what if there is no MPBGP peering at all if its a standalone router will this still work ??

Re: MPLS Inter VRF route leaking

yes even if no BGP neighbor configured.

Please rate helpful posts.

Best Regards,

Mounir Mohamed

New Member

Re: MPLS Inter VRF route leaking

Thanks i got the answer

thanks for the document.

796
Views
13
Helpful
4
Replies