Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.

MPLS Issue

I have setup basic MPLS switching between 5 routers. BGP is enable between Pescara and Pesaro with VRF routing for Customer A/B. if i do sh ip route vrf Customer_A and b on both routers, i cannot see the bgp routing for both customers even though bgp is active between both routers. Can someone pls check my config's. see attachment.

Francisco

12 REPLIES
VIP Super Bronze

Re: MPLS Issue

Francisco,

I could not open the text document you send for your config (rar extention). But to achive route leaking between VRFs, you need to redistribute connected and static routes under each family ipv4 VRF.

HTH

Reza

New Member

Re: MPLS Issue

Hi

you need to enable neigbor in address-family vpnv4 on router Pescara and Pesaro.

Something like this:

Router bgp 100

address-family vpnv4

neighbor 10.10.10.6 activate

neighbor 10.10.10.6 send-community both

no auto-summary

no synchronization

exit-address-family

Jon

Re: MPLS Issue

Reza/Jon,

all you suggested i have done. I have uploaded the config and used winzip instead.

Francisco

VIP Super Bronze

Re: MPLS Issue

Francisco,

Why do you have the same loopback address(200.0.4.1)for both costumer-A and B and why are they not /32 (host addresses)for router pescars?

Also, I don't see any static routes to the null0 interface and redistributed to your vrf's

Thanks,

Reza

Re: MPLS Issue

I have the same loopback address(200.0.4.1)for both costumer-A and B because what i am trying to do is build vrf routing table for both customers even though they are on the same subnet without conflicting.

Reza, can you suggest what i should do to get routing working.

thanks

Francisco

VIP Super Bronze

Re: MPLS Issue

Francisco,

I would try it with different subnets per vrf and see what happens:

for example for customer-A

ip vrf customer-a

rd 1:1

route-target export 1:1

route-target import 1:1

for customer-B

ip vrf customer-b

rd 2:2

route-target export 2:2

route-target import 2:2

assign loopback 1 to customer-a

ip forwarding customer-a

1.1.1.1/32

assign loopback 2 to customer-b

ip forwarding customer-b

2.2.2.2/32

then

IP vrf customer-a 1.1.1/24 null0

IP vrf customer-2 2.2.2/24 null0

then do redistribute connected and static under each VRF

Reza

Re: MPLS Issue

on both Pescara and Pesaro?

VIP Super Bronze

Re: MPLS Issue

yes

Hall of Fame Super Silver

Re: MPLS Issue

Hello Francisco,

in case of overlapping subnets in different VRFs if you want them to communicate you still need to use NAT as in a classic scenario because the vpnv4 prefix with the leading 64bit RD is used only between PEs: after prefixes are imported in a VRF routing table they are again standard IPv4 prefixes.

So MPLS VPNs support overlapping IP subnets on different customers but only if they don't need to communicate directly.

Hope to help

Giuseppe

Re: MPLS Issue

Giuseppe,

the reason why i have the overlapping subnets is i dont want the customers to communicate with each other.

Francisco

New Member

Re: MPLS Issue

Hi Francisco,

As jon suggested you do not have the VPNv4 address family configured under router bgp. You have the ipv4 address family. Hence the neighbors are unable to communicate. Please configure the following under BGP

********Pescara********

router bgp 100

address-family vpn4

neighbor 10.10.10.4 activate

neighbor 10.10.10.4 send-community both

!

********Pesaro********

!

router bgp 100

address-family vpn4

neighbor 10.10.10.6 activate

neighbor 10.10.10.6 send-community both

!

Please do a "show ip bgp vpnv4 all summary" on both devices to confirm that the vpn4 neighbor relationship has been established. If you still have issues than please can you issue a ping from either of your PE routers sourcing the loopback and ping the other loopback so for eg on Pescara do a "ping 10.10.10.6 source lo0". Also post the output of "show ip bgp vpnv4 all summary" and the "show ip bgp vpnv4 all". Thx

Re: MPLS Issue

yes that was it. after adding address-family vpn4 on both routers, all working now.

Thanks all

Francisco.

301
Views
0
Helpful
12
Replies
CreatePlease to create content